Notices

Shifting hard - clean shift solenoid?

 
Old 05-14-2018, 07:24 PM
  #1  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Shifting hard - clean shift solenoid?

Hi,

My 2011 just started shifting hard into 2nd gear. Iíve been searching on this and Iíve read cleaning the shift solenoids under the air box can help clear it up. It has 125,000 miles. I bought it a few months ago and the tranny fluid was black, iíve since changed 4quarts with Valvoline multi vehicle synthetic and a few weeks later 4 more quarts. It is now somewhere between red and black. Today is the first very hot day weíve had in northern MI, wonder if this contributed in someway, as yesterday it was shifting fine. Anyone have success cleaning the solenoids?

Thanks
Jason
Jason46 is offline  
Old 05-14-2018, 09:49 PM
  #2  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
I cleaned the 4 screens in the dual solenoid block on the front of the tranny but they were clean to begin with. There is a single solenoid under the intake tube but I left it alone. I drove it a bit afterwards and there didn’t seem to be any change and still had a lazy shift into 2nd while most of the time shifting fine. I’m going to call around tomorrow to have the tranny filter changed.

Any input appreciated
Jason46 is offline  
Old 05-14-2018, 10:27 PM
  #3  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Does the gen have an external filter,I can't seem to determine this. I looked around for one and did not see anything that looks like the canister filter I've seen online but mostly in 1st gen forums.

Thinking about just doing another fluid change but I don't want to make it worse,I've been using valvoline multi vehicle synthetic.
Jason46 is offline  
Old 05-20-2018, 01:12 PM
  #4  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
I did another drain fill and tried lubegard which didn't help Thinking about replacing pressure switches, but the car is showing no codes.
Jason46 is offline  
Old 05-23-2018, 04:09 PM
  #5  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
I changed the ATF filter (which was one of the harder jobs I’ve done, and I’ve rebuilt newer Saab’s) and this seems to be clearing up the hard shifting. The filter was not plugged as much as I thought it would be. If I do this again I’d consider either removing the filter with a single hose or relocating the filter, it is difficult to get to any of the clamps.

I found the filter looking at oem part diagrams. Neither autozone or advance list a filter for it, and the fact there is no YouTube video of anyone changing a filter on a 2nd gen lead me to think there wasn’t an external filter. The nearest dealership is 150miles away so I didn’t consult a dealer.
Jason46 is offline  
Old 05-27-2018, 01:00 PM
  #6  
Registered Member
 
Join Date: Sep 2005
Age: 72
Posts: 2,868
Likes: 0
Received 118 Likes on 115 Posts
Attached iis symptom/cause chart. Lots of possibles.

good luck
Attached Files
TexasHonda is offline  
Old 05-27-2018, 01:37 PM
  #7  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 39
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Thanks , for your reply.
It shifted perfect for a few days after changing the filter, maybe coincidence. I have since changed the 2nd gear pressure sensor, I'm fairly certain a shift solenoid is bad, I'm taking it to a shop to diagnose. Interesting the top item is a bad motor mount.
Jason46 is offline  
Old 06-12-2019, 02:28 PM
  #8  
New Member
 
Join Date: Jun 2019
Age: 51
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Did you ever get rid of the 2nd gear issue? Did you try and reboot the transmission computer?
djskins is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
markk
2G TL Problems & Fixes
146
06-12-2019 11:41 AM
jda123
Third Generation TL (2004-2008)
16
08-10-2018 10:07 AM
wise2k
Second Generation TL (1999-2003)
8
10-20-2009 07:50 PM
savy
First Generation CL Discussion (1997-1999)
6
05-30-2009 07:34 AM
Rabbit97
1G CL Problems & Fixes
2
10-04-2006 07:37 PM


Thread Tools
Search this Thread
Quick Reply: Shifting hard - clean shift solenoid?


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.