Notices

New trans with weird issue

 
Old 01-31-2019, 08:49 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Sep 2012
Location: So Cal
Posts: 115
Recieved 11 Likes on 8 Posts
New trans with weird issue

Hey all,
I just picked up a 30k mile AV6 trans and installed it into my 04 TL. Install went pretty smoothly, trans seems to work great. But I have an intermittent issue where the trans will shift down into 4th, the blinking d light comes on along the check engine light and stability control light. I get P2770 and P0977. I swapped shift sonoid b from my old trans. And bench tested both. No change, I also bench tested the torque converter clutch Solonoid. No issues with that either.

When it acts up, I can shut the car off, clear the codes and drive another 50 miles perfectly fine.

Any ideas?
laid67 is offline  
Old 01-31-2019, 11:10 PM
  #2  
Registered Member
 
ifeliciano's Avatar
 
Join Date: Nov 2018
Location: Dallas
Posts: 52
Recieved 1 Like on 1 Post
ECU/Trans reset?
ifeliciano is offline  
Old 02-01-2019, 11:02 AM
  #3  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,654
Recieved 5,794 Likes on 4,645 Posts
https://acurazine.com/forums/3g-tl-p...-p0977-919601/

I take it you installed fresh DW-1 fluid after the swap too?
thoiboi is offline  
Old 02-03-2019, 01:19 PM
  #4  
Registered Member
Thread Starter
 
Join Date: Sep 2012
Location: So Cal
Posts: 115
Recieved 11 Likes on 8 Posts
yup. Fresh DW1. I broke down and finally took it to a shop, they said it sounds like an electrical issue and the only thing he could do is test the harness one wire at a time. So I guess thatís my next course of action. My only concern is that an intermittent issue may not show it self when testing continuity through the harness.

also. How can I check if my PCM is up to date?
laid67 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tarponman85
3G TL Tires, Wheels & Suspension
8
11-03-2007 04:03 AM
JUBIE
Car Parts for Sale
2
01-08-2006 11:38 PM
Southern
Second Generation TL (1999-2003)
34
10-11-2004 07:29 PM
KrZyTypeS
2G CL Transmission Recall Q & A
2
07-26-2004 12:09 PM


Thread Tools
Search this Thread
Quick Reply: New trans with weird issue


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.