Notices

AC not working. 04 TL

 
Old 07-11-2019, 02:39 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Jan 2019
Age: 32
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
AC not working. 04 TL


Little over a month my AC stopped working. I got it checked my local advanced auto and replaced ththe fuse and relay and still no AC. The guy that works at advanced noticed when he pushed down on a wiring harness the AC came on with no issue but was blowing hot air. The next day I took it to an auto to check to see it there was any leaks and it they said didnt see any leaks. I took my car to another mechanic for a second look and they said the samething. I also got my AC recharged and it worked however in a few weeks I'm having the same issue. When I pushed on the wiring of the picture below it comes on but blows hit air. I'm confused at this point.
Eric Heart is offline  
Old 07-11-2019, 04:46 PM
  #2  
Registered Member
iTrader: (1)
 
Join Date: Apr 2007
Location: NJ
Age: 55
Posts: 7,814
Received 807 Likes on 659 Posts
Check pressures again to see if refrigerate charge up to snuff.
Turbonut is online now  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KJEFFERIES68
Second Generation TSX Discussion (2009-2014)
5
07-14-2019 12:49 PM
sseiyah
1G & 2G MDX Discussion (2001-2013)
5
05-15-2018 12:37 AM
PhilWithers
2G CL Problems & Fixes
4
03-11-2009 04:31 PM
jpooncanada
First Generation TSX Discussion (2004-2008)
105
04-09-2007 07:55 PM
Mike
Ramblings
59
06-12-2005 12:22 PM


Thread Tools
Search this Thread
Quick Reply: AC not working. 04 TL


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.