Notices

Radiator Fan won't turn on!

 
Old 12-22-2011, 12:28 PM
  #1  
Registered Member
Thread Starter
 
Persia-TL's Avatar
 
Join Date: Aug 2009
Posts: 150
Likes: 0
Received 2 Likes on 2 Posts
Radiator Fan won't turn on!

Hey all,

So last week my 04 TL with 97k miles on it over heated. I pulled over right away, turned the engine off and let it cool down. it was a cold day so it worked to my advantage.

I then checked to see if I was losing fluids, maybe the radiator was cracked or a whole in the hose. But non of that, it was all good. Then i looked at the fan and tried to turn it, and realize it wasn't turning smoothly at all. Took the fan out and saw that it was seized. so i figured after 97k miles the fan gave out.

so I went to the deal, bought a new fan, put it in, and let the car run to see if the fan would come on, and NOPE it didnt!. the car started over heating again so i turned off the engine right away. used a test light and checked to see if i was getting power to the fan, but nope, no power to the fan at all.

I checked the fuse and it was good. any ideas what it could be?

Maybe the relay? the wire going to fan to give it power is no good?

thanks in advance.
Persia-TL is offline  
Old 12-22-2011, 01:33 PM
  #2  
takin care of Business in
iTrader: (5)
 
swoosh's Avatar
 
Join Date: Jan 2008
Location: Kansas City, MO
Age: 35
Posts: 31,026
Received 4,716 Likes on 4,052 Posts
to check the fan, switch the fans and see if it comes on....

take the coolant reservoir out and check the wires/relays under there....
swoosh is offline  
Old 12-22-2011, 02:08 PM
  #3  
Registered Member
Thread Starter
 
Persia-TL's Avatar
 
Join Date: Aug 2009
Posts: 150
Likes: 0
Received 2 Likes on 2 Posts
The new fan that i put in comes on, i took power directly from the battery to it, and it works. but no power gets to the fan from the harness that is connected to.
Persia-TL is offline  
Old 12-22-2011, 06:08 PM
  #4  
Registered Member
 
Join Date: Mar 2010
Location: 626/714
Posts: 1,752
Received 82 Likes on 63 Posts
Does the fan(s) turn on when you turn on the A/C? If so, try switching the relay from the AC fan to the main fan.
SpiderX1016 is offline  
Old 07-12-2019, 12:10 PM
  #5  
2007 6SMT Type-S
 
SurfingScotty's Avatar
 
Join Date: Sep 2004
Location: Colleyville, TX
Age: 38
Posts: 790
Received 18 Likes on 17 Posts
Mine is doing the same thing. The radiator fan does not turn on unless I put power directly to it from the battery. The AC fan works fine.
I replaced the coolant sensor last summer (on top of the engine near the intake manifold). Is there another sensor that could have failed?
SurfingScotty is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TL-Rocket
Third Generation TL (2004-2008)
6
12-04-2017 06:59 AM
01CLOwner
Second Generation CL Discussion (2000-2003)
21
10-09-2015 01:07 PM
Aleax
Third Generation TL (2004-2008)
9
09-14-2015 07:39 PM
NSolace
2G TL Problems & Fixes
15
09-03-2015 08:02 PM
prox
5G TLX Problems & Fixes
6
09-01-2015 02:03 AM


Thread Tools
Search this Thread
Quick Reply: Radiator Fan won't turn on!


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.