Notices

Crankshaft position sensor code p0335 and limp mode; please help!

 
Old 07-11-2019, 07:29 AM
  #1  
New Member
Thread Starter
 
Join Date: Jul 2019
Location: Philadelphia
Age: 21
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Crankshaft position sensor code p0335 and limp mode; please help!

please assist me with my 06 tsx 6spd.

I replaced the crankshaft position sensor TWICE so that must not be the problem, because P0335 code still pops up with “crankshaft position sensor A circuit”. it’s the only code right now and every time i reset the code, it comes back and randomly goes into limp mode whenever it wants which causes VSA lights to come on.

any ideas of what it could be?
6SpeedT is offline  
Old 07-11-2019, 09:17 AM
  #2  
Registered Member
 
Join Date: Sep 2005
Age: 73
Posts: 2,872
Likes: 0
Received 119 Likes on 116 Posts
Since a new sensor did not fix, the fault is likely an open in wiring or connector. See attached troubleshooting procedure.

good luck
Attached Files
File Type: pdf
Acura TSX04-07_P0335.pdf (301.1 KB, 5 views)
TexasHonda is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wrestletough
3G TL Problems & Fixes
2
10-02-2015 07:42 PM
Dnguyen92
First Generation CL Discussion (1997-1999)
0
05-25-2013 02:54 AM
tonyng704
First Generation TL (1996-1998)
2
06-16-2008 03:33 PM
tonyng704
First Generation TL (1996-1998)
1
06-10-2008 11:38 PM
amsmk
Second Generation TL (1999-2003)
1
11-05-2006 10:57 PM


Thread Tools
Search this Thread
Quick Reply: Crankshaft position sensor code p0335 and limp mode; please help!


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.