Notices

07' MDX Motor Mount

 
Old 07-11-2019, 02:45 AM
  #1  
New Member
Thread Starter
 
Join Date: Jul 2019
Location: Santa Ana
Age: 28
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
07' MDX Motor Mount

Ok so, this is actually my first time really getting under the hood of a car. Although I have basic understanding of certain parts and their function I am still learning my way around. So I am currently working on a 2007 MDX. The engine looked like cookie monster puked gunk all over it, I have managed to clean some of it but still pretty bad. About 3 weeks ago I changed the oil, filter, cabin air filter, air filter. Last week I noticed decreased performance, feels kind sluggish? heavy? As if another ton of weight just got dropped on it. I also felt like the engine was running hotter than usual along with a burning rubber smell. So yesterday I got around to the valve cover gasket and would like to say I'm pretty confident that was causing the leak throughout the engine as well as the burning rubber smell. Now, as far as the sluggish feeling I'm thinking it might have to do with the suspension mostly. i just ordered sway bar links and bushings too... I am however unsure if motor mounts could cause that or add to that issue

passenger side mount


Are these 2 parts supposed to be rubbing against each other?
? I'm am not sure if it just looks misaligned to me or if I they due for replacement immediately.
latina1209 is offline  
Old 07-11-2019, 06:23 AM
  #2  
Moderator
iTrader: (1)
 
justnspace's Avatar
 
Join Date: Feb 2010
Posts: 81,180
Received 14,146 Likes on 10,510 Posts


this pic shows the water pump/engine bracket to hold the engine mount. You can kind of see that attaching bracket is not lined up correctly. a gradient gap growing from left to right.

this could mean the engine mount is shot, or it could mean the previous installer installed it wrong.

As for your other pictures, I cant tell what parts they are...in relation to other parts.
I can kinda see that it's the back valve cover...but not sure what you're pointing at

Last edited by justnspace; 07-11-2019 at 06:27 AM.
justnspace is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Didymus Anthony Simmons
4G TL Problems & Fixes
7
03-17-2014 11:52 AM
Itsmorethanasunroof
2G CL Problems & Fixes
12
06-02-2013 12:40 PM
Mike
Second Generation CL Discussion (2000-2003)
1045
09-03-2009 09:28 PM
StonedCL
Second Generation CL Discussion (2000-2003)
5
01-24-2009 11:56 AM
dasuddith33
2G CL Problems & Fixes
7
11-20-2008 12:08 PM


Thread Tools
Search this Thread
Quick Reply: 07' MDX Motor Mount


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.