Notices

Battery Drain! Not the HFL 🤬

 
Old 07-02-2019, 10:14 AM
  #1  
Registered Member
Thread Starter
 
Join Date: Jun 2019
Age: 27
Posts: 10
Received 0 Likes on 0 Posts
Battery Drain! Not the HFL 🤬

Iíve had this issue for about a week doing a few different tests. I finally disconnected my hfl, but still no luck. The car wonít crank at all unless jumped. Any ideas? Iím thinking maybe trying the a/c clutch. Also my Navi stopped working about a week or so before this issue started. I just get the check disc message on my screen. Could the Navi disc drive in he trunk be the culprit?
Pjarmon is offline  
Old 07-02-2019, 01:31 PM
  #2  
Registered Member
iTrader: (2)
 
horseshoez's Avatar
 
Join Date: Jan 2017
Location: Southern New Hampshire
Age: 63
Posts: 5,006
Received 906 Likes on 674 Posts
Assuming your battery is new and fully charged, you might want to have a look-see at the positive battery cable/starter cable. Mine is a bit sketchy right now and I'll be replacing mine in the next week or two, the new part was only like $50 with shipping.
horseshoez is offline  
The following users liked this post:
Pjarmon (07-02-2019)
Old 07-02-2019, 07:52 PM
  #3  
Registered Member
iTrader: (1)
 
Join Date: Apr 2007
Location: NJ
Age: 55
Posts: 7,814
Received 807 Likes on 659 Posts
There's many items on that circuit, mine was the power window master switch.
Turbonut is online now  
Old 07-02-2019, 10:25 PM
  #4  
Registered Member
Thread Starter
 
Join Date: Jun 2019
Age: 27
Posts: 10
Received 0 Likes on 0 Posts
Update

Still battery still draining. Iím getting a ground somewhere on my positive connection. I took a look at the starter. But I canít see anything wrong down there with the connection. What the hell!
Pjarmon is offline  
Old 07-03-2019, 12:05 AM
  #5  
Senior Moderator
 
csmeance's Avatar
 
Join Date: Feb 2006
Location: Daytona Beach/Gainesville FL
Posts: 18,406
Received 1,069 Likes on 750 Posts
remove all fuses and add them back one by one until your car wakes up dead with a fully charged battery
csmeance is offline  
Old 07-03-2019, 06:04 AM
  #6  
Registered Member
iTrader: (1)
 
Join Date: Apr 2007
Location: NJ
Age: 55
Posts: 7,814
Received 807 Likes on 659 Posts
Turbonut is online now  
Old 07-05-2019, 06:19 AM
  #7  
Senior Moderator
 
LoveMyTL-S's Avatar
 
Join Date: Mar 2005
Location: St. Cloud, FL
Age: 62
Posts: 11,863
Received 334 Likes on 291 Posts
For me it was the A/C relay.
LoveMyTL-S is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HottnesTLX
3G MDX Discussion (2014+)
14
11-27-2018 06:24 PM
Mr. Eclectic
3G TL Problems & Fixes
21
10-27-2016 12:53 PM
TroyNJ
3G TL Problems & Fixes
11
01-21-2015 09:21 PM
ZRatedDog
3G TL Problems & Fixes
7
06-01-2014 08:19 PM
Contella
3G TL Problems & Fixes
4
02-04-2013 11:50 PM


Thread Tools
Search this Thread
Quick Reply: Battery Drain! Not the HFL 🤬


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.