Display lights on my factory stereo went out twice - Page 3 - AcuraZine - Acura Enthusiast Community

Notices

Display lights on my factory stereo went out twice

 
Old 01-06-2007, 12:16 PM
  #81  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
Originally Posted by LuvMyTSX
Gawd....my headunit lights were flickering Tuesday night for maybe 3-4 minutes, but never went out completely. This was on the way to drop off the car at the dealer for an oil change. I had them look at it, but they said it was fine so nothing they could do of course. Just hoping if mine goes out, it does it while under warranty.
Sorry to be the bearer of bad news, but it's guaranteed to go. Mine has been flickering occasionally for the last month, and now it's dead.
Dan Martin is offline  
Old 01-06-2007, 12:38 PM
  #82  
Senior Moderator
 
LuvMyTSX's Avatar
 
Join Date: Jun 2005
Location: NY
Age: 39
Posts: 14,668
Thanked 9 Times in 8 Posts
Originally Posted by Dan Martin
Sorry to be the bearer of bad news, but it's guaranteed to go. Mine has been flickering occasionally for the last month, and now it's dead.
Nooooooo

I hope you get taken care of though, since you're out of warranty.
LuvMyTSX is offline  
Old 01-08-2007, 02:33 AM
  #83  
Registered Member
 
plee9's Avatar
 
Join Date: Nov 2004
Location: Vancouver
Age: 36
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
dude. my a/c temp control light went out, my stereo light went out, and then my turn signals started sounding funny. they all got replaced under warranty but i am disappointed with acura cars now. my 99 camry did not have this much problem.
plee9 is offline  
Old 01-10-2007, 10:28 AM
  #84  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
So I had my visit to Erin Mills Acura today to have my console lights looked at. I am 8,000KM out of warranty, so I was expecting to have to bend over for this one.

Thankfully, it wasn't nearly as bad as I was expecting. Everyone on the service counter was great to deal with and very friendly. There's a new fix for the problem, and they can now replace just the radio unit instead of the whole console like they had to do originally.
The new unit specifically addresses the voltage regulator issue, so it should be a permanent fix now. The radio unit is $289 and there's an hour's labor to install it. They had the part in stock so it was $384 total (~$330USD) and 50 minutes later I was out the door.

I needed an oil change and they threw it in for free.

I couldn't ask for anything else really. I certainly didn't encounter any of the craziness the other members are reporting.

+1 for Erin Mills.
Dan Martin is offline  
Old 01-10-2007, 10:47 AM
  #85  
Senior Moderator
 
LuvMyTSX's Avatar
 
Join Date: Jun 2005
Location: NY
Age: 39
Posts: 14,668
Thanked 9 Times in 8 Posts
That's awesome. I'm relieved they now have a permanent fix for the issue. I didn't want to have to get an extended warranty just to cover the electrical stuff, since I have the CPO warranty that goes to 100,000 miles for the drivetrain, but only adds another year to make 5 years for the electrical part of the warranty.
LuvMyTSX is offline  
Old 01-10-2007, 10:56 AM
  #86  
Registered Member
 
jlukja's Avatar
 
Join Date: Dec 2003
Location: Long Beach, CA
Age: 56
Posts: 20,559
Thanked 5 Times in 5 Posts
Originally Posted by LuvMyTSX
That's awesome. I'm relieved they now have a permanent fix for the issue. I didn't want to have to get an extended warranty just to cover the electrical stuff, ....
jlukja is offline  
Old 01-10-2007, 11:06 AM
  #87  
dom
Senior Moderator
 
dom's Avatar
 
Join Date: Apr 2003
Location: Toronto, Canada
Age: 42
Posts: 47,711
Thanked 797 Times in 659 Posts
Great news on two fronts Dan.

First, its great that they resolved the problem and you weren't hit too hard for it.

Second, sounds like most of us who had this repair done a little later on are safe from it happening again, since they changed the radio and not the console. I know when I had my repair done in March of 06 only the radio was changed.

And thats not nearly as expensive as I thought it would be, but I still think it should have been free. Its the second time its happened and they didn't fix it right the first time.
dom is offline  
Old 01-10-2007, 11:20 AM
  #88  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
Originally Posted by dom
Great news on two fronts Dan.

First, its great that they resolved the problem and you weren't hit too hard for it.

Second, sounds like most of us who had this repair done a little later on are safe from it happening again, since they changed the radio and not the console. I know when I had my repair done in March of 06 only the radio was changed.

And thats not nearly as expensive as I thought it would be, but I still think it should have been free. Its the second time its happened and they didn't fix it right the first time.
I just sent you a PM, but your box was full, so I emailed it.

The guy said he thinks it's the same part number as the '06 radio. I'm inclined to believe him because my radio reception is quite a bit better. I can get 92.5 from Buffalo and it comes in like they were broadcasting from Toronto.
Dan Martin is offline  
Old 01-10-2007, 12:13 PM
  #89  
dom
Senior Moderator
 
dom's Avatar
 
Join Date: Apr 2003
Location: Toronto, Canada
Age: 42
Posts: 47,711
Thanked 797 Times in 659 Posts
Its all those nudes female members keep sending me.

So it only 3 to 4 years to find a fix. Nice going honda.
dom is offline  
Old 01-10-2007, 12:33 PM
  #90  
Have camera, will travel
 
waTSX's Avatar
 
Join Date: Jan 2004
Location: Federal Way, WA
Age: 57
Posts: 7,783
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Dan Martin
So I had my visit to Erin Mills Acura today to have my console lights looked at. I am 8,000KM out of warranty, so I was expecting to have to bend over for this one.

Thankfully, it wasn't nearly as bad as I was expecting. Everyone on the service counter was great to deal with and very friendly. There's a new fix for the problem, and they can now replace just the radio unit instead of the whole console like they had to do originally.
The new unit specifically addresses the voltage regulator issue, so it should be a permanent fix now. The radio unit is $289 and there's an hour's labor to install it. They had the part in stock so it was $384 total (~$330USD) and 50 minutes later I was out the door.

I needed an oil change and they threw it in for free.

I couldn't ask for anything else really. I certainly didn't encounter any of the craziness the other members are reporting.

+1 for Erin Mills.
This is the best news we've heard on this issue so far. I hope there'll be a TSB on this fix so other dealers are aware of it. Even better, a recall for all TSX's. If the part is inherently faulty, Acura should address it, imo.
waTSX is offline  
Old 01-10-2007, 12:59 PM
  #91  
Senior Moderator
 
LuvMyTSX's Avatar
 
Join Date: Jun 2005
Location: NY
Age: 39
Posts: 14,668
Thanked 9 Times in 8 Posts
Originally Posted by waTSX
This is the best news we've heard on this issue so far. I hope there'll be a TSB on this fix so other dealers are aware of it. Even better, a recall for all TSX's. If the part is inherently faulty, Acura should address it, imo.
I agree, but I doubt they'll do anything. Would be so nice to have a recall and get it fixed, though.
LuvMyTSX is offline  
Old 01-10-2007, 02:55 PM
  #92  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
I'm still going to send a letter to Acura Canada to see if I can get anything out of them. Had they fixed it right the first time, I wouldn't be out of pocket now. I'll let you guys know how it goes. Worse case scenario, I'm no worse off than I am now, so I really don't have anything to lose...
Dan Martin is offline  
Old 01-10-2007, 11:22 PM
  #93  
Moderator
 
Street Spirit's Avatar
 
Join Date: Mar 2004
Posts: 9,161
Thanks: 0
Thanked 58 Times in 34 Posts
Originally Posted by dom
Its all those nudes female members keep sending me.


Street Spirit is offline  
Old 01-21-2007, 11:51 AM
  #94  
08 MDX with Sports
 
Newplay1's Avatar
 
Join Date: Aug 2004
Location: NJ
Age: 39
Posts: 1,890
Thanks: 0
Thanked 0 Times in 0 Posts
My Navi screen and my speedo gauge gets little DIM, actually it gets pretty dark enough to be noticed and annoy the shit out of me time to time. Only way I know how to fix it is park/turn off car and turn it back on and 9 out of 10 its back to normal.



What do you think? Dealer time?
Newplay1 is offline  
Old 01-21-2007, 12:29 PM
  #95  
Senior Moderator
 
LuvMyTSX's Avatar
 
Join Date: Jun 2005
Location: NY
Age: 39
Posts: 14,668
Thanked 9 Times in 8 Posts
Originally Posted by Newplay1
My Navi screen and my speedo gauge gets little DIM, actually it gets pretty dark enough to be noticed and annoy the shit out of me time to time. Only way I know how to fix it is park/turn off car and turn it back on and 9 out of 10 its back to normal.



What do you think? Dealer time?
Hard to say. Mine flickered while on the way to the dealer for an oil change. I told them about it, they looked at it, and said they couldn't do anything since it wasn't out completely. They may tell you the same thing, but you can call and talk to the SA about it.
LuvMyTSX is offline  
Old 01-25-2007, 08:29 PM
  #96  
Registered Member
 
EL UNICO's Avatar
 
Join Date: Jan 2007
Age: 35
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
so this is not just a fuse problem. mine wnt out on the ay home today from work. got 68000 miles on my 04 w/nav
EL UNICO is offline  
Old 02-18-2007, 09:40 PM
  #97  
fdl
Senior Moderator
 
fdl's Avatar
 
Join Date: Jul 2003
Location: Toronto
Age: 43
Posts: 21,673
Thanks: 0
Thanked 1 Time in 1 Post
My freakn console just went out as well. I am 4K and 7 mo out of warranty.
fdl is offline  
Old 02-18-2007, 09:44 PM
  #98  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
Originally Posted by fdl
My freakn console just went out as well. I am 4K and 7 mo out of warranty.
Is this #1 or #2 for you?
Dan Martin is offline  
Old 02-18-2007, 10:01 PM
  #99  
fdl
Senior Moderator
 
fdl's Avatar
 
Join Date: Jul 2003
Location: Toronto
Age: 43
Posts: 21,673
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by Dan Martin
Is this #1 or #2 for you?

#1.

I'm going to fight for it under warranty, but I'm very happy to hear that if worse comes to worst its a $400 fix and not a $2000 fix.
fdl is offline  
Old 02-18-2007, 10:05 PM
  #100  
Photography Nerd
 
Dan Martin's Avatar
 
Join Date: Sep 2003
Location: Toronto
Age: 38
Posts: 21,489
Thanks: 0
Thanked 9 Times in 5 Posts
Originally Posted by fdl
#1.

I'm going to fight for it under warranty, but I'm very happy to hear that if worse comes to worst its a $400 fix and not a $2000 fix.
It's pretty painless now, but it still sucks to have to pay anything for a clearly defective part. It's only an hour for them to swap units, so it's a quick in and out visit.
Dan Martin is offline  
Old 03-19-2007, 05:33 PM
  #101  
Registered Member
 
Join Date: Jan 2007
Age: 35
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
honda put out a new warranty for the factory radios 100k, 7 yrs
99TLnasty is offline  
Old 03-19-2007, 05:52 PM
  #102  
Registered Member
 
jlukja's Avatar
 
Join Date: Dec 2003
Location: Long Beach, CA
Age: 56
Posts: 20,559
Thanked 5 Times in 5 Posts
Originally Posted by 99TLnasty
honda put out a new warranty for the factory radios 100k, 7 yrs
Is it on the new 07 models coming out or is it retroactive to the 04 models as well? Got any more detailed info on this? I was amazed to look back at the poll and see so many of our members with this problem.
jlukja is offline  
Old 04-09-2007, 06:05 PM
  #103  
fdl
Senior Moderator
 
fdl's Avatar
 
Join Date: Jul 2003
Location: Toronto
Age: 43
Posts: 21,673
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by jlukja
Is it on the new 07 models coming out or is it retroactive to the 04 models as well? Got any more detailed info on this? I was amazed to look back at the poll and see so many of our members with this problem.

Its retro to all current models. My dealer offered to fix my head unit problem for free, which was certainly good news, and then just last week I received a letter from Acura stating that the warranty on my radio is now 160,000KM or 7 years
fdl is offline  
Old 04-09-2007, 06:16 PM
  #104  
fdl
Senior Moderator
 
fdl's Avatar
 
Join Date: Jul 2003
Location: Toronto
Age: 43
Posts: 21,673
Thanks: 0
Thanked 1 Time in 1 Post
Here is my letter.

fdl is offline  
Old 04-10-2007, 12:43 AM
  #105  
Registered Member
 
Join Date: Nov 2003
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
My 2004 Navi went out recently at about 64.5 K miles. The dealership said they requested and "goodwill" repair with the district so I got it done for free. They said only the circuit board needed to be repaired. Just the other day though, I noticed the illumination on the driver side heater button is out. I wonder if it's related to the other repair. I'm going to call into the dealer tomorrow.
Bloopie is offline  
Old 04-10-2007, 10:28 AM
  #106  
Registered Member
 
jlukja's Avatar
 
Join Date: Dec 2003
Location: Long Beach, CA
Age: 56
Posts: 20,559
Thanked 5 Times in 5 Posts
Thanks fdl. I haven't received the letter but I did see the TSB that extended the warranty. I'm hoping my letter is in the mail. I'm not having any problems with it right now but its good to know it'll be covered.
jlukja is offline  
Old 04-10-2007, 11:40 AM
  #107  
08 MDX with Sports
 
Newplay1's Avatar
 
Join Date: Aug 2004
Location: NJ
Age: 39
Posts: 1,890
Thanks: 0
Thanked 0 Times in 0 Posts
Some days my guages and Navi screen is very DIM night or day just dim. I'm not sure if I should be worried or take it to my dealer.. I just dont want my local service guys to fudge things up more inside..
Newplay1 is offline  
Old 04-19-2007, 11:40 AM
  #108  
Registered Member
 
Join Date: Apr 2007
Age: 47
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Is there an updated link for the FSBs? I click on them and get nubbins.
francis23 is offline  
Old 04-20-2007, 03:44 PM
  #109  
Registered Member
 
Join Date: Apr 2004
Posts: 100
Thanked 2 Times in 2 Posts
It worked for me...Here is the link...Try it

http://photos.imageevent.com/astrobo...sb/B04-021.pdf
vollum is offline  
Old 04-27-2007, 08:55 PM
  #110  
Registered Member
 
thegarse's Avatar
 
Join Date: Apr 2007
Location: N. CA
Age: 38
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
I've had it with my 04 navi. Hud lights went out. They replaced radio, hud, and gps. I'm sure the service agent makes his money this way.

-mike
thegarse is offline  
Old 03-04-2008, 04:09 PM
  #111  
Registered Member
 
Join Date: Mar 2008
Age: 33
Posts: 95
Thanks: 0
Thanked 2 Times in 2 Posts
Anybody with a salvaged title get this done? I have a salvaged title TSX and they said they will not do it being the warranty has been voided. How much does it cost to get this fix if the warranty has been voided? My friend (who was previous owner) said that he talked to customer relations and they said it doesn't matter if its salvaged title or not its a recall and they have to fix it (acura, and customer relations told me that they will not fix it because it is not a safety issue which I think is full of it..)
quakerroatmeal is offline  
Old 02-10-2019, 06:20 PM
  #112  
Registered Member
 
Join Date: Oct 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Question lights on HVAC and Stero

Hopefully I'm on the right thread. My 2004 Acura TSX now has no light on any of the buttons such as the preset buttons on the radio and Auto and fan buttons on HVAC. At night I only see the LCD panels. Everything else is dark so I have to go by memory to push the right button (or trial and error) at night. I imagine these were lit at one time. Does anyone know if this a fuse/bulb issue or do I have to replace some PC board or the entire units?
wrlsdata is offline  
Old 02-10-2019, 07:21 PM
  #113  
Registered Member
 
Join Date: Oct 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
OK I have decided this is the right thread and I read the Honda doc posted in one of the replies. My 14 year old TSX is still a fun car to drive and it has less than 90000 miles. Only a couple of repairs were needed in all these years. Since Stereo and HVAC work fine, I will think about adding an external light to illuminate the buttons!
wrlsdata is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Yumcha
Automotive News
11
12-28-2018 10:57 AM
rockyboy
Second Generation RDX (2013-2018)
46
01-25-2016 07:00 PM
handsom-hustla
Car Parts for Sale
70
11-13-2015 06:04 PM
scionxb3003
Car Parts for Sale
6
10-02-2015 06:50 PM
Gianni Formica
3G TL Audio, Bluetooth, Electronics & Navigation
1
09-07-2015 09:28 PM


Thread Tools
Search this Thread
Quick Reply: Display lights on my factory stereo went out twice


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.