Navigation Screen doesn't display and Top Radio display doesn't work. - AcuraZine Community

Log In 


Navigation Screen doesn't display and Top Radio display doesn't work.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-18-2011, 02:17 PM   #1
New Member
Thread Starter
 
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Navigation Screen doesn't display and Top Radio display doesn't work.

Started my 2006 TL this morning and the navigation screen wouldn't come on. Then I noticed that the radio channel display was not working on the dashboard, either. I've read a couple posts about this but none with any resolution that worked for me.

Just came out of warranty 200 miles ago. Thankfully my transmission failed RIGHT before the warranty expired, so I'm not complaining. I doubt the repair for the audio/nav will be nearly the cost of a new transmission.

Any suggestions on where to start with this nav/radio display thing would be greatly appreciated. Not sure if this is relevant but about 3 months ago the back light on the seat warmer went out and then over the past 3 months (one at a time) almost all of the backlights on the buttons on my steering wheel have gone out.
kreed is offline   Reply With Quote
Old 07-18-2011, 07:42 PM   #2
2008 Acura 3.2TL
 
ParaSurfer1979's Avatar
 
Join Date: May 2010
Location: Wilmington, NC
Age: 36
Posts: 3,131
Thanked 110 Times in 88 Posts
200miles ago acura will still probably warranty it. Take it to Acura asap and see what they can work out. Good luck bro. Keep us posted. Speak to Service manager.
ParaSurfer1979 is offline   Reply With Quote
Old 07-18-2011, 09:04 PM   #3
Senior Moderator
 
csmeance's Avatar
 
Join Date: Feb 2006
Location: Daytona Beach/Gainesville FL
Posts: 17,621
Thanked 841 Times in 568 Posts
Quote:
Originally Posted by ParaSurfer1979 View Post
200miles ago acura will still probably warranty it. Take it to Acura asap and see what they can work out. Good luck bro. Keep us posted. Speak to Service manager.


it sounds like one of the boards inside the screen failed since the navi-screen connects the upper display as well as the navi system. If acura doesn't cover it, PM me and I'll see if I can help out with figuring out a cheaper solution.
csmeance is offline   Reply With Quote
The Following User Says Thank You to csmeance For This Useful Post:
D1G1TAL GHOST (07-24-2011)
Old 07-20-2011, 09:46 PM   #4
New Member
Thread Starter
 
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
kreed is offline   Reply With Quote
Old 07-20-2011, 09:47 PM   #5
New Member
Thread Starter
 
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Please forgive the typos. (iPad)
kreed is offline   Reply With Quote
Old 07-21-2011, 01:16 PM   #6
Senior Moderator
 
csmeance's Avatar
 
Join Date: Feb 2006
Location: Daytona Beach/Gainesville FL
Posts: 17,621
Thanked 841 Times in 568 Posts
Quote:
Originally Posted by kreed View Post
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
Acura is a good brand that takes care of their customers. You have to remember that acura's car's are a bit more technical than your typical toyota with features like auto dimming mirrors, HID's, memory seats, navi, solar sensing climate control, etc.

It's just like a BMW/Mercedes, the more technology you have, the more prone something is to break! Take my BMW for example, in time I've had it out of factory warranty, the aftermarket company has picked up the tab for almost 23,000 dollars worth of repair work.

My Transmission went out on my TL and my dash cracked and Acura covered it even though I was past 100K miles! That's why I bought a honda and didn't compare to a toyota or nissan or other brand. They took care of me and made me into a loyal customer.
csmeance is offline   Reply With Quote
Old 07-23-2011, 11:28 PM   #7
Registered Member
 
Join Date: Jan 2011
Age: 28
Posts: 33
Thanked 0 Times in 0 Posts
I have the same issue again with my navi. I had the issue a while back when the navi would be intermittently working. The problem was that it kept losing connection with all of the buttons and even the LCD radio screen would not work. What literally solved my problem was hitting a bumb. I hit one at a good speed that everything came on. I'm thinking it's a bad ground? Not really sure. Only problem now is that the problem is back after 6 months. If anyone knows how yo fix this please pm me. I live in San Francisco if u guys know any shops that can fix it.
D1G1TAL GHOST is offline   Reply With Quote
Old 11-26-2013, 12:50 AM   #8
Registered Member
 
Join Date: Aug 2011
Age: 37
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Did you get it fixed? I have the same problem with the radio stations not displaying. The navigation works only if I turn off the radio. I'll be taking mine apart soon and let you know if I find a short, loose wires, or maybe there are quarters in the tape deck.
Quote:
Originally Posted by kreed View Post
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
Fedexo is offline   Reply With Quote
Old 11-30-2013, 10:11 PM   #9
Registered Member
 
Join Date: Jul 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
My screen quit working in September. Took it to the dealer and they diagnosed a bad screen and sent it out for repair. Seven weeks later they tell me the screen can't be repaired and a used one (no warranty) is $800 and a new one is $3,000! I'm not a happy camper. Does anyone have a better solution?

Gordon
GBeeman is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'06 Navigation Flickering & Radio not working Ol'Dave 3G TL Problems & Fixes 2 02-25-2016 09:05 PM
Acura TL '04-'06 Navi NewtoAcura11 3G TL Audio, Bluetooth, Electronics & Navigation 8 09-28-2015 04:40 PM
Rental Review: 2016 Hyundai Sonata Hybrid PortlandRL Car Talk 2 09-14-2015 12:01 PM
No wall paper to display spoiler900 5G TLX Audio, Bluetooth, Electronics & Navigation 4 09-10-2015 01:06 PM
Peugeot: Fractal Concept News Yumcha Automotive News 3 09-06-2015 04:40 PM


Tags
04, 2006, accord, acura, blank, bmw, display, honda, light, mdx, navigation, radio, screen, tl, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:19 AM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.