Notices
Third Generation TL (2004-2008)
Sponsored by:
Sponsored by:

Hi everyone just wanted some new owner tips

 
Old 03-30-2019, 03:03 AM
  #1  
New Member
Thread Starter
 
Join Date: Mar 2019
Location: QC
Age: 27
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Hi everyone just wanted some new owner tips

I currently drive an 04 tl base model 5s automatic and having restored some features her previous owner neglected i was hoping for few tips or what tipe of handling to expect, front suspension was redone with air intake, radiator as well as 2 front engine mount replaced oil change and other including parts to reservice accompanying what I re did to her, she has 189k km on Odom and honda service tech says transmission A1 after trying car, also brakes redone too, i Beleive in only needing a soon service of timing belt and re alignment and i think I've done all she needs, so what should I expect from here out?
ChocoboRacerQC is offline  
Old 03-30-2019, 09:15 AM
  #2  
Administrator
 
Ron A's Avatar
 
Join Date: Feb 2004
Posts: 15,193
Received 790 Likes on 445 Posts
Welcome to the forums.

Since this is a topic/technical issue which will require replies and discussion, this thread has been moved from the New Member Introductions forum to the model specific forum.
Ron A is offline  
Old 03-31-2019, 12:30 PM
  #3  
Registered Member
 
Jackass's Avatar
 
Join Date: Sep 2008
Location: KCMO Burbs
Age: 43
Posts: 2,014
Received 373 Likes on 289 Posts
1.) Wow...that is one heck of a long sentence.
2.) Not exactly sure what all was said here. What does the front suspension have to do with the air intake?
3.) The transmission is throwing a code? Or it is ok?
4.) Two front engine mounts? I thought we only had 3 engine mounts total...front, back, and side?

There really is only a couple of somewhat common "issues" for these cars:
1.) Dash cracks...nothing you can do. When its time, its time. Some people have cracked at 5 years, others at 10+ with no cracks yet. Mine held out for 12'ish years.
2.) Auto transmissions - just keep up on fluid and replace the pressure switches
3.) LCA bushings - just inspect and replace if torn
4.) HFL module fails and drains battery

I think those are the more common issues.
Jackass is offline  
Old 03-31-2019, 10:16 PM
  #4  
Registered Member
 
PhilB81's Avatar
 
Join Date: Apr 2005
Location: Clearwater Fl
Age: 38
Posts: 843
Received 15 Likes on 12 Posts
Originally Posted by Jackass View Post
1.) Wow...that is one heck of a long sentence.
2.) Not exactly sure what all was said here. What does the front suspension have to do with the air intake?
3.) The transmission is throwing a code? Or it is ok?
4.) Two front engine mounts? I thought we only had 3 engine mounts total...front, back, and side?

There really is only a couple of somewhat common "issues" for these cars:
1.) Dash cracks...nothing you can do. When its time, its time. Some people have cracked at 5 years, others at 10+ with no cracks yet. Mine held out for 12'ish years.
2.) Auto transmissions - just keep up on fluid and replace the pressure switches
3.) LCA bushings - just inspect and replace if torn
4.) HFL module fails and drains battery

I think those are the more common issues.
^^^ what he said, only other thing I had to do on mine was to replace the driveshafts because of vibration under throttle.

also, my drive by wire pedal position was starting to go, so I replaced it, but I don't think that's a common issue. I just felt that occasionally pressing the pedal just a little did nothing or too much, which made smooth starts with the manual tricky.
PhilB81 is offline  
Old 04-02-2019, 09:57 AM
  #5  
Senior Moderator
 
LoveMyTL-S's Avatar
 
Join Date: Mar 2005
Location: St. Cloud, FL
Age: 62
Posts: 11,855
Received 333 Likes on 290 Posts
If your battery is draining (after sitting a few days), it's either the HFL module fails and drains battery or A/C relay ($6.00 part). I unhooked the HFL and replaced the relay. A/C fans blows harder now.
Congrats on the new to you TL and welcome to AZ!!
LoveMyTL-S is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pzhoward
2G TL Problems & Fixes
2
11-22-2010 06:10 PM
98tlracer
Second Generation TL (1999-2003)
22
11-18-2004 08:17 PM
types1967
Ramblings
29
11-27-2003 02:00 PM
StreetEffectz
Audio, Video, Electronics & Navigation
4
08-20-2002 09:17 PM
Austin519
Second Generation CL Discussion (2000-2003)
16
06-24-2002 08:30 AM


Thread Tools
Search this Thread
Quick Reply: Hi everyone just wanted some new owner tips


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.