Notices

Fog Lights Not Working?

 
Old 12-06-2018, 02:38 PM
  #1  
New Member
Thread Starter
 
Join Date: Feb 2017
Age: 21
Posts: 4
Received 0 Likes on 0 Posts
Fog Lights Not Working?

Hi everyone,

I recently tried to turn the fog lights on in my 03 TL recently, and when I attempted to do so, they would not work. When I pressed the switch, I heard an audible click, from what I believe is the fog light relay, but the green light would not turn on. I am guessing it is a bad fuse?
Sahil Purohit is offline  
Old 12-06-2018, 07:51 PM
  #2  
Registered Member
 
Iggy's Avatar
 
Join Date: Nov 2001
Location: Southern N.H.
Posts: 1,397
Received 120 Likes on 102 Posts
They won't go on if the headlights are in high beam
Iggy is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PhilWithers
2G CL Problems & Fixes
4
03-11-2009 04:31 PM
Integra_drk
First Generation TL (1996-1998)
4
11-09-2008 05:04 PM
Big Pip
Second Generation TL (1999-2003)
11
09-12-2008 09:58 PM
chitownRLer
First Generation RL (1996-2004)
3
04-27-2006 09:42 AM
Ruski
Second Generation TL (1999-2003)
7
07-21-2003 03:17 PM


Thread Tools
Search this Thread
Quick Reply: Fog Lights Not Working?


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.