02 sensor problem - AcuraZine - Acura Enthusiast Community

Notices

02 sensor problem

 
Old 10-10-2018, 11:12 PM
  #1  
New Member
Thread Starter
 
Join Date: Oct 2018
Age: 26
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
02 sensor problem

I have a 2005 Acura TSX 2.4 vtec I changed the catalytic converter and the o2 sensor that goes into the converter but my check engine stays on. What could be problem?
Nick Creech is offline  
Old 10-11-2018, 07:52 AM
  #2  
Administrator
 
Ron A's Avatar
 
Join Date: Feb 2004
Posts: 15,116
Thanked 770 Times in 434 Posts
Welcome to the forums.

This thread has been moved to the model specific forum for better response.
Ron A is offline  
Old 10-15-2018, 10:39 AM
  #3  
Registered Member
 
Join Date: Sep 2005
Age: 72
Posts: 2,861
Thanks: 0
Thanked 116 Times in 113 Posts
What codes are presented?

good luck
TexasHonda is offline  
Old 11-05-2018, 03:15 PM
  #4  
Registered Member
 
Reorge's Avatar
 
Join Date: Aug 2003
Location: New Orleans, LA
Posts: 632
Thanked 150 Times in 118 Posts
+1. You have two O2 sensors. Are you sure you changed the one that failed (if that is the problem)? Code?
The other one is upstream of converter.
Reorge is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
noynek
First Generation TL (1996-1998)
1
05-21-2018 03:05 PM
MaCe
First Generation CL Discussion (1997-1999)
5
04-24-2004 11:01 AM
mcdanjw
Second Generation CL Discussion (2000-2003)
12
03-24-2004 07:53 AM
DDT-TypeS
Second Generation CL Discussion (2000-2003)
7
10-25-2001 07:47 PM
NighthawkBlack
Audio, Video, Electronics & Navigation
5
10-12-2000 10:57 PM


Thread Tools
Search this Thread
Quick Reply: 02 sensor problem


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.