Xlr8's Motor mounts are trash. - AcuraZine - Acura Enthusiast Community

Notices
Third Generation TL (2004-2008)
Sponsored by:
Sponsored by:

Xlr8's Motor mounts are trash.

 
Old 12-30-2018, 12:13 AM
  #1  
New Member
Thread Starter
 
Join Date: Sep 2014
Location: Phoenix, AZ
Posts: 3
Thanked 0 Times in 0 Posts
Xlr8's Motor mounts are trash.

So this is just a post to let others know of my experience with xlr8 motor mounts for a 3rd gen TL. The tab in the front mount snapped and the side mount bushing and housing failed on my xlr8 mounts and then when I called them about it they acted as if it was user error. Keep in mind I'm running a completely stock engine and my friend who is a mechanic with over 30+ years of experience was the one who installed them for me. The only mod we had to make of course was drill a hole in the side mount for the grounding wire. They didn't even bother to make things right. Way to stand behind your "proven" product xlr8. Oh further, it appears as if you can't even buy the mounts for 3 gen Acura TL on xlr8's site anymore when I called a 2nd time about my mounts issue some schmuck on the other end couldn't give me a clear answer and just said "they must have been discontinued". To me it appears to be an indication that xlr8 knows they put out an inferior product. I for one was not impressed with the so called quality or the way this was handled by xlr8.
Xicano Mike is offline  
Old 12-30-2018, 01:05 AM
  #2  
Rotrex + Comptech TLer
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 885
Thanked 91 Times in 80 Posts
Heeltoe automotive FTW
Saving4aTL is online now  
Old 12-31-2018, 02:06 PM
  #3  
Mr. Detail
 
Scottwax's Avatar
 
Join Date: Oct 2011
Location: Arlington, TX
Age: 57
Posts: 948
Thanked 122 Times in 104 Posts
Tab on my Innovative front mount snapped too, replaced it with OEM and used their urethane sound mount which so far has been solid and pretty much vibration free. Not sure if the front mount failed because of design/material error, it was somehow not properly installed or because apparently I also had a bad side mount (which I had on hand but the shop said I didn't need) and 3 bad transmission mounts which I told them to replace but they never ordered or installed (didn't charge me though) or a combination of everything?

Since going back to an OEM front mount, Innovative side mount and 3 new transmission mounts its been rock solid.
Scottwax is offline  
Old 01-02-2019, 02:11 PM
  #4  
Vroooom!!!
 
RC51Ryder's Avatar
 
Join Date: Sep 2008
Location: Northern Va
Posts: 620
Thanked 1 Time in 1 Post
I have a side mount (front passenger side) and it has been solid for me so far. I need to replace the one up front when I can get some free time. I forgot how I did the ground but it stick out as an issue for me.
RC51Ryder is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
boxmanryan
Car Parts for Sale
1
01-12-2015 09:15 AM
03_BigJ_TypeS
2G TL Performance Parts & Modifications
21
08-01-2014 12:29 AM
Lefty2Guns
3G TL Performance Parts & Modifications
21
07-22-2014 08:48 AM
youngTL
Ramblings
5
10-13-2005 12:30 PM


Thread Tools
Search this Thread
Quick Reply: Xlr8's Motor mounts are trash.


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.