Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine TL/TLX Community > Third Generation TL (2004-2008)
Reload this Page >

Took my car to get a cracked rim and a wheel balanced, picked it back up with a noise

Notices
Third Generation TL (2004-2008)
Sponsored by:
Sponsored by:

Took my car to get a cracked rim and a wheel balanced, picked it back up with a noise

 
Old 06-09-2019, 07:40 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Nov 2018
Age: 23
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
Took my car to get a cracked rim and a wheel balanced, picked it back up with a noise

I took my car to get a rim fixed and a wheel balanced, and ended up hearing a sound while driving it home from the shop. I didnít turn back because I had picked it up when they closed and I was hoping it would go away. The noise has now gotten worse. I have 19 inch wheels on my car (which were not my choice) so I thought the size of the wheel may be straining the car. But that doesnít make sense because I did not hear even a creak prior. The tires are Hancook, Ventus v12 evo2s. Everything was fine, even driving to the shop, no creaking, no power steering whine, no clunk. Now, upon steering even without acceleration there is an annoying winding noise, and some clunk noises. I checked my fluids, everything is good, I donít think itís the common o ring fix because there are no air bubbles in my power steering fluid. The noise could mean my pump is going bad, but what are the clunking noises...? I remember reading that the rack and pinion was a common issue with this car. Iím not sure if itís that, or a bad axle, or a bad pump. I recently changed my drive belt, tensioner pulley, and my idle pulley. Would those new parts somehow overwork the pump? I donít know. Iím going to try to attach a video for you guys to hear the sound. And before anyone says anything like ďsearch it upĒ I did. Itís hard to get advice when every post is about a bad axle or topping your fluid up. Iíve had my car safetied less than 4 months ago and havenít driven it much. Everything underneath the car is clean although I did need to change one tie rod. One more thing to make clear is that there was absolutely no noise prior to taking my car to this shop, what I mean by that is I have had no sign of any issues that led me to this problem. Everything was fine until I simply got a wheel balanced, Iím not sure if they took my car for a joy ride, even if they did, Iím not sure what happened during that. I do plan on going back to the shop but I doubt they will refund me money or tell me that something went wrong.
95s14rb25 is offline  
Old 06-09-2019, 07:50 PM
  #2  
Registered Member
Thread Starter
 
Join Date: Nov 2018
Age: 23
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
Why is adding a video so hard on this forum? Am I doing something wrong? Lol. Hereís a link I just added to YouTube in hope of some answers. I basically am looking for a definite answer so I can figure out if the shop tampered with my car.
95s14rb25 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SicK TypeS
Car Talk
12
09-23-2006 10:08 PM
TL_Type_S
2G CL Tires, Wheels, & Suspension
2
03-06-2004 08:05 AM
PeterUbers
Car Parts for Sale
11
12-30-2003 06:05 PM
joechan
1G TSX Problems & Fixes
2
08-08-2003 12:30 AM


Thread Tools
Search this Thread
Quick Reply: Took my car to get a cracked rim and a wheel balanced, picked it back up with a noise


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.