Notices

App Installed on RDX :D (WIP)

 
Old 07-09-2019, 09:47 AM
  #41  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by omygod711 View Post
So on my second drive I realize the issues with this "hack"

The distraction mode will reset every restart of the car, so you will need to go in to dealer menu and turn off the distraction mode every time
Using voice command in Android auto does not work well because it seems like the mic is picking up some noise or static. You can see the "4 dots" jumping around during voice command and google hardly understand you.
That sucks for short drives. We would have to add the app to the whitelist which unfortunately requires root. I wonder if there's a way to have HeadUnit Reloaded use the phone mic instead of the RDX's. It's probably a matter of permissions not being allowed to access the mic within the app or something.
pbsredrdx is offline  
Old 07-09-2019, 10:07 AM
  #42  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by pbsredrdx View Post
That sucks for short drives. We would have to add the app to the whitelist which unfortunately requires root. I wonder if there's a way to have HeadUnit Reloaded use the phone mic instead of the RDX's. It's probably a matter of permissions not being allowed to access the mic within the app or something.
Do you know how to whitelist if we get root?
I can try some tool to root it and get supersu.
omygod711 is offline  
Old 07-09-2019, 11:08 AM
  #43  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by omygod711 View Post
Do you know how to whitelist if we get root?
I can try some tool to root it and get supersu.
Not specifically for the RDX but it's probably like every other Android device. I would try to find an exploit for our build number 5.1.1. Take a look on how they did it on the Civic:


https://www.civicx.com/threads/final...l.12632/page-2
pbsredrdx is offline  
Old 07-09-2019, 01:05 PM
  #44  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by pbsredrdx View Post
Not specifically for the RDX but it's probably like every other Android device. I would try to find an exploit for our build number 5.1.1. Take a look on how they did it on the Civic:


https://www.civicx.com/threads/final...l.12632/page-2
We might have it easier with the RDX, it looks like we don't need to whitelist an app to use it. Also since we are at 5.1.1, we will need a different exploit. I tried loading kingroot apk to head unit but it runs in portait mode and the right screen took over the whole screen making it unusable.
omygod711 is offline  
Old 07-09-2019, 01:46 PM
  #45  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by omygod711 View Post
We might have it easier with the RDX, it looks like we don't need to whitelist an app to use it. Also since we are at 5.1.1, we will need a different exploit. I tried loading kingroot apk to head unit but it runs in portait mode and the right screen took over the whole screen making it unusable.
Cool. I would love to help but my work schedule doesn't really give me much time to tinker with stuff like this anymore but I'll keep an eye on this thread to see if I can help.
pbsredrdx is offline  
Old 07-09-2019, 01:52 PM
  #46  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by pbsredrdx View Post
Would be nice to have it working natively instead of the HeadUnit Reloaded. Maybe they disabled it. Could use the PM commands to reenable it?


https://android.stackexchange.com/qu...m-apps-via-adb
PM list does work but I don't see any app related to android auto.

I also emailed the developer of headUnit Reloaded and ask if he can add a cursor for us with no touch screen, but he said it is not possible.

The biggest annoyance now is the "Distract mode" in dealer menu. Really don't know how to change those settings.
omygod711 is offline  
Old 07-09-2019, 11:55 PM
  #47  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
PM list does work but I don't see any app related to android auto.

I also emailed the developer of headUnit Reloaded and ask if he can add a cursor for us with no touch screen, but he said it is not possible.

The biggest annoyance now is the "Distract mode" in dealer menu. Really don't know how to change those settings.
here's the location of the package

Code:
/system/app/AndroidAuto/AndroidAuto.apk
And I just snapped a screenshot of all the enabled packages on the RDX HU...

Android Auto package info
the1dynasty is offline  
Old 07-10-2019, 08:55 AM
  #48  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by the1dynasty View Post
here's the location of the package

Code:
/system/app/AndroidAuto/AndroidAuto.apk
And I just snapped a screenshot of all the enabled packages on the RDX HU...

Android Auto package info
Thanks, I have the list on my notepad and I read through it a few times but some how I totally still missed it. Are you able to "reinstall" it? I am still trying to root, I tried a couple of tools and they all failed, one of them might have messed up my adb and I have to fix it first.
omygod711 is offline  
Old 07-10-2019, 02:25 PM
  #49  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
Thanks, I have the list on my notepad and I read through it a few times but some how I totally still missed it. Are you able to "reinstall" it? I am still trying to root, I tried a couple of tools and they all failed, one of them might have messed up my adb and I have to fix it first.
I have not... I honestly checked for disabled apps to see if it was disabled first... then I thought, let me check enabled apps and it was showing enabled... I didn't think to try to install it again or anything else with it... honestly, I'm just happy right now because I realized Google released an update for my Pixelbook that allows me to do adb commands via crosh... just the fact that I was able to connect to the RDX without having to go through the Linux terminal on here and a bunch of hoops to get adb working, had me excited enough to not even try installing an app on the RDX HU yet lol...
the1dynasty is offline  
Old 07-10-2019, 02:28 PM
  #50  
Registered Member
 
Join Date: Oct 2018
Location: Minnesota
Age: 27
Posts: 598
Received 127 Likes on 83 Posts
Originally Posted by the1dynasty View Post
I have not... I honestly checked for disabled apps to see if it was disabled first... then I thought, let me check enabled apps and it was showing enabled... I didn't think to try to install it again or anything else with it... honestly, I'm just happy right now because I realized Google released an update for my Pixelbook that allows me to do adb commands via crosh... just the fact that I was able to connect to the RDX without having to go through the Linux terminal on here and a bunch of hoops to get adb working, had me excited enough to not even try installing an app on the RDX HU yet lol...
I wonder if we download the apk from the headunit if there are some settings that could be changed in the manifest file or not. Also wonder what other settings Acura is setting in perhaps the build.config file perhaps disabling some of the APKs, because they show as enabled according to android
Dereileak is offline  
Old 07-10-2019, 03:12 PM
  #51  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
I tried running the following

Code:
adb shell monkey -p com.honda.androidauto.projection.sink -c android.intent.category.LAUNCHER 1
but I get the following

Code:
** No activities found to run, monkey aborted.
But I know it works because running

Code:
adb shell monkey -p com.honda.settings -c android.intent.category.LAUNCHER 1
does in fact launch the "Settings" menu of the vehicle... I also tried CarPlay this way and it launches it as well... It seems like there might be a form of Android Auto installed on the head unit but it's not a final build or something because it doesn't want to run...
the1dynasty is offline  
Old 07-10-2019, 03:29 PM
  #52  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
running 'getprop' gets me this... not sure if this info is useful at all lol

Code:
[Navirecovered]: [1]
[amplifier_service.started]: [1]
[auto.system.config]: [20]
[auto.system.opticaldrive]: [3]
[carplay_audio_in_card]: [-1]
[carplay_audio_in_channel]: [1]
[carplay_audio_in_sample_rate]: [0]
[carplay_autoplay]: [1]
[core_services.started]: [true]
[dalvik.vm.dex2oat-Xms]: [64m]
[dalvik.vm.dex2oat-Xmx]: [512m]
[dalvik.vm.dexopt-flags]: [m=y]
[dalvik.vm.heapgrowthlimit]: [192m]
[dalvik.vm.heapmaxfree]: [3m]
[dalvik.vm.heapminfree]: [512k]
[dalvik.vm.heapsize]: [320m]
[dalvik.vm.heapstartsize]: [8m]
[dalvik.vm.heaptargetutilization]: [0.8]
[dalvik.vm.image-dex2oat-Xms]: [64m]
[dalvik.vm.image-dex2oat-Xmx]: [64m]
[dalvik.vm.isa.arm.features]: [div]
[dalvik.vm.stack-trace-file]: [/data/anr/traces.txt]
[debug.force_rtl]: [0]
[dev.adb]: [1]
[dev.bootcomplete]: [1]
[dhcp.wlan0.dns1]: [192.168.86.1]
[dhcp.wlan0.dns2]: []
[dhcp.wlan0.dns3]: []
[dhcp.wlan0.dns4]: []
[dhcp.wlan0.domain]: [lan]
[dhcp.wlan0.gateway]: [192.168.86.1]
[dhcp.wlan0.ipaddress]: [192.168.86.43]
[dhcp.wlan0.leasetime]: [86400]
[dhcp.wlan0.mask]: [255.255.255.0]
[dhcp.wlan0.mtu]: []
[dhcp.wlan0.pid]: [4342]
[dhcp.wlan0.reason]: [RENEW]
[dhcp.wlan0.result]: [ok]
[dhcp.wlan0.server]: [192.168.86.1]
[dhcp.wlan0.vendorInfo]: []
[dr.recording.default_file_size]: [314572800]
[dr.recording.path]: [/data/local/tmp/DR]
[factory.ssid]: [ASUS_5G]
[factory.wifipassword]: [1234567890]
[factoryflashing.downloadstarted]: [false]
[factoryflashing.preinstall]: [false]
[hmcm.system.config]: [0]
[hwui.render_dirty_regions]: [false]
[init.svc.EmmcVendorStatus]: [running]
[init.svc.GalUsbReset]: [running]
[init.svc.M4fwload]: [stopped]
[init.svc.RingSniffer]: [running]
[init.svc.StateMachine]: [running]
[init.svc.StorageService]: [running]
[init.svc.VcsNative]: [running]
[init.svc.adbd]: [running]
[init.svc.bootanim]: [stopped]
[init.svc.cmem]: [stopped]
[init.svc.configADB]: [stopped]
[init.svc.console]: [running]
[init.svc.cp-server]: [running]
[init.svc.ddf_natp]: [running]
[init.svc.debuggerd]: [running]
[init.svc.dhcpcd_wlan0]: [running]
[init.svc.dr-carplay-srv]: [running]
[init.svc.dr-hal-service]: [running]
[init.svc.drm]: [running]
[init.svc.drplaybacksrv]: [running]
[init.svc.drrecordersrv]: [running]
[init.svc.dspd]: [running]
[init.svc.dumpstate]: [stopped]
[init.svc.gps-manager]: [running]
[init.svc.hars_klogger]: [running]
[init.svc.healthd]: [running]
[init.svc.installd]: [running]
[init.svc.ipod-daemon]: [running]
[init.svc.iprenew_wlan0]: [stopped]
[init.svc.isostream]: [stopped]
[init.svc.keystore]: [running]
[init.svc.lad_dra7xx]: [stopped]
[init.svc.late_load]: [stopped]
[init.svc.letgw_trigger]: [running]
[init.svc.lmkd]: [running]
[init.svc.logd]: [running]
[init.svc.mdnsd]: [running]
[init.svc.media]: [running]
[init.svc.most-ipc]: [running]
[init.svc.most-stack]: [running]
[init.svc.netd]: [running]
[init.svc.p2p_supplicant]: [running]
[init.svc.preload]: [stopped]
[init.svc.pstore_logdump]: [running]
[init.svc.pvrsrvinit]: [stopped]
[init.svc.sdcard]: [running]
[init.svc.servicemanager]: [running]
[init.svc.setupDio]: [stopped]
[init.svc.setup_maps_dir]: [stopped]
[init.svc.smc]: [stopped]
[init.svc.surfaceflinger]: [running]
[init.svc.touchbridge]: [running]
[init.svc.ueventd]: [running]
[init.svc.usb_init]: [stopped]
[init.svc.utility]: [running]
[init.svc.vold]: [running]
[init.svc.watchdogd]: [running]
[init.svc.zygote]: [running]
[launcher.started]: [1]
[log.tag.app.audioset]: [D]
[log.tag.app.auxin]: [D]
[log.tag.app.btaudio]: [D]
[log.tag.app.btsettings]: [D]
[log.tag.app.camera]: [D]
[log.tag.app.carplay]: [D]
[log.tag.app.clock]: [D]
[log.tag.app.displayset]: [D]
[log.tag.app.email]: [D]
[log.tag.app.flm]: [D]
[log.tag.app.gal]: [D]
[log.tag.app.hdmi]: [D]
[log.tag.app.hvac]: [D]
[log.tag.app.intercom]: [D]
[log.tag.app.jukebox]: [D]
[log.tag.app.konnect]: [D]
[log.tag.app.misc]: [D]
[log.tag.app.nfc]: [D]
[log.tag.app.notifset]: [D]
[log.tag.app.optical]: [D]
[log.tag.app.ota]: [D]
[log.tag.app.phone]: [D]
[log.tag.app.res]: [D]
[log.tag.app.rsm]: [D]
[log.tag.app.settings]: [D]
[log.tag.app.siri]: [D]
[log.tag.app.sms]: [D]
[log.tag.app.svcamera]: [D]
[log.tag.app.systemset]: [D]
[log.tag.app.trip]: [D]
[log.tag.app.tuner]: [D]
[log.tag.app.usb]: [D]
[log.tag.app.vehset]: [D]
[log.tag.app.wrch]: [D]
[log.tag.app.xm]: [D]
[log.tag.auto.ampvcs]: [W]
[log.tag.auto.aninputvcs]: [W]
[log.tag.auto.autossvcs]: [W]
[log.tag.auto.autovcs]: [W]
[log.tag.auto.cameravcs]: [W]
[log.tag.auto.diagnostics]: [W]
[log.tag.auto.diagshvcs]: [W]
[log.tag.auto.hvacvcs]: [W]
[log.tag.auto.netblocklib]: [W]
[log.tag.auto.opticalvcs]: [W]
[log.tag.auto.resvcs]: [W]
[log.tag.auto.sattunervcs]: [W]
[log.tag.auto.systemsyncvcs]: [W]
[log.tag.auto.tcu]: [D]
[log.tag.auto.tertunervcs]: [W]
[log.tag.auto.trafftunervcs]: [W]
[log.tag.auto.uxcvcs]: [W]
[log.tag.auto.uxmvcs]: [W]
[log.tag.auto.vcsapi]: [W]
[log.tag.auto.voicerecvcs]: [W]
[log.tag.auto.wichvcs]: [W]
[log.tag.garmin.dr]: [I]
[log.tag.mm.audiohal]: [D]
[log.tag.mm.dtcp]: [D]
[log.tag.mm.hmcm]: [D]
[log.tag.mm.mass]: [D]
[log.tag.mm.mss]: [D]
[log.tag.mm.raam]: [I]
[log.tag.mm.vls]: [D]
[log.tag.navi.NaviFr]: [I]
[log.tag.navi.NaviVcs]: [I]
[log.tag.navi.app]: [D]
[log.tag.net.bt]: [D]
[log.tag.net.btrfcomm]: [V]
[log.tag.net.btvcs]: [V]
[log.tag.net.dsp]: [V]
[log.tag.net.eom]: [V]
[log.tag.net.linkmgr]: [V]
[log.tag.net.tcudata]: [V]
[log.tag.net.uxvcs]: [D]
[log.tag.sensor.Speed]: [I]
[log.tag.sys.hwctrl]: [W]
[log.tag.sys.utility]: [D]
[log.tag.ttm]: [E]
[media.aac_51_output_enabled]: [true]
[net.bt.name]: [Android]
[net.change]: [net.dns2]
[net.dns1]: [2603:9001:3b80:3107:f6f2:6dff:feab:2fa]
[net.dns2]: [192.168.86.1]
[net.hostname]: [android-c9de48665b2ec781]
[net.qtaguid_enabled]: [1]
[net.tcp.default_init_rwnd]: [60]
[nodeposition]: [1]
[partition.system.verified]: [1]
[persist.af.speex.quality]: [10]
[persist.campaign_name]: []
[persist.error_id]: [0]
[persist.error_is_internal]: [true]
[persist.error_state]: [NONE]
[persist.estimated_install_time]: []
[persist.factoryreset.completed]: []
[persist.gpu.yuv.full_range]: [0]
[persist.hwc.primary.tv]: [1]
[persist.ignitioncount]: [178]
[persist.image_size]: []
[persist.last_progress]: [0]
[persist.most.v4l2.fast.handler]: [0]
[persist.ntp_offset]: [0]
[persist.regular_update_state]: [IDLE]
[persist.release_notes_path]: []
[persist.service.bdroid.bdaddr]: [00:C0:59:26:0F:2B]
[persist.sys.country]: [US]
[persist.sys.dalvik.vm.lib.2]: [libart.so]
[persist.sys.inline_completion]: [1]
[persist.sys.language]: [en]
[persist.sys.localevar]: []
[persist.sys.profiler_ms]: [0]
[persist.sys.timezone]: [GMT-04:00]
[persist.sys.usb.config]: [mtp,adb]
[persist.tcu_update_state]: [0]
[persist.trigger_mode]: [SERVER]
[persist.update_name]: []
[persist.update_source]: [NONE]
[persist.user_offset]: [0]
[persist.version.garmin.dr]: [Version: DR = 1.03, Lib = production/1.127.50-5-g5a42ba4a56]
[persist.wifi.mac_address]: [10:98:c3:0a:4f:30]
[pms.scanning.finished]: [1]
[ro.adb.secure]: [1]
[ro.allow.mock.location]: [0]
[ro.baseband]: [unknown]
[ro.board.platform]: [jacinto6]
[ro.boot.console]: [ttyS0]
[ro.boot.hardware]: [gen1CBD_HS]
[ro.boot.selinux]: [permissive]
[ro.boot.serialno]: [40239033]
[ro.bootloader]: [unknown]
[ro.bootmode]: [unknown]
[ro.build.characteristics]: [tablet,nosdcard]
[ro.build.date.utc]: [1541140049]
[ro.build.date]: [Fri Nov  2 02:27:29 EDT 2018]
[ro.build.description]: [gen1CBD_HS-user 5.1.1 LMY48P 515 release-keys]
[ro.build.display.id]: [LMY48P release-keys]
[ro.build.fingerprint]: [Acura/gen1CBD_HS/gen1CBD_HS:5.1.1/LMY48P/515:user/release-keys]
[ro.build.flavor]: [gen1CBD_HS-user]
[ro.build.fwversion]: [D.1.1.2]
[ro.build.host]: [amhraoatlbldp01]
[ro.build.id]: [LMY48P]
[ro.build.product]: [gen1CBD_HS]
[ro.build.tags]: [release-keys]
[ro.build.type]: [user]
[ro.build.user]: [jenkins]
[ro.build.version.all_codenames]: [REL]
[ro.build.version.codename]: [REL]
[ro.build.version.incremental]: [515]
[ro.build.version.release]: [5.1.1]
[ro.build.version.sdk]: [22]
[ro.carrier]: [unknown]
[ro.com.android.dateformat]: [MM-dd-yyyy]
[ro.com.ti.omap_multizone_audio]: [true]
[ro.config.alarm_alert]: [Alarm_Classic.ogg]
[ro.config.notification_sound]: [pixiedust.ogg]
[ro.config.ringtone]: [Ring_Synth_04.ogg]
[ro.crypto.state]: [unencrypted]
[ro.dalvik.vm.native.bridge]: [0]
[ro.debuggable]: [0]
[ro.factorytest]: [0]
[ro.hardware]: [gen1CBD_HS]
[ro.hwc.lcd.0.fps]: [57]
[ro.hwc.lcd.0.x_dpi]: [200]
[ro.hwc.lcd.0.y_dpi]: [200]
[ro.kernel.android.gps]: [/dev/ttyS1]
[ro.logd.size]: [4096K]
[ro.opengles.version]: [131072]
[ro.product.board]: [A110]
[ro.product.brand]: [Acura]
[ro.product.cpu.abi2]: [armeabi]
[ro.product.cpu.abi]: [armeabi-v7a]
[ro.product.cpu.abilist32]: [armeabi-v7a,armeabi]
[ro.product.cpu.abilist64]: []
[ro.product.cpu.abilist]: [armeabi-v7a,armeabi]
[ro.product.device]: [gen1CBD_HS]
[ro.product.locale.language]: [en]
[ro.product.locale.region]: [US]
[ro.product.manufacturer]: [DENSO]
[ro.product.model]: [Acura Infotainment System]
[ro.product.name]: [gen1CBD_HS]
[ro.rcb.mep0.ipaddress]: [192.168.50.8]
[ro.revision]: [0]
[ro.rfkilldisabled]: [1]
[ro.runtime.firstboot]: [1562787376680]
[ro.secure]: [1]
[ro.serialno]: [40239033]
[ro.sf.lcd_density]: [160]
[ro.wifi.channels]: []
[ro.zygote]: [zygote32]
[selinux.reload_policy]: [1]
[service.adb.enable]: [1]
[service.adb.tcp.port]: [5555]
[service.bootanim.exit]: [1]
[service.linkmanager.state]: [LM_STATE_DISCONNECTED]
[service.surfaceflinger.ready]: [1]
[skip.factoryflashing]: [false]
[sys.ams.ready]: [1]
[sys.antitheft_control]: [CLOSED]
[sys.battery_disconnected]: [safe]
[sys.boot_completed]: [1]
[sys.boot_completed_intent_sent]: [1]
[sys.bootanimtype]: [bootanimationELS.zip]
[sys.cpu_governor.set]: [ondemand]
[sys.diag.inline_control]: []
[sys.launcher_loaded]: [1]
[sys.logd_started]: [1]
[sys.powerstate]: [FullMode]
[sys.sensor_service_ready]: [1]
[sys.settings_global_version]: [576]
[sys.settings_system_version]: [11]
[sys.start_from_waitmost]: [1]
[sys.startupmanager.ready]: [1]
[sys.sysctl.extra_free_kbytes]: [16200]
[sys.sysctl.tcp_def_init_rwnd]: [60]
[sys.temperature.value]: [47]
[sys.usb.config]: [mtp,adb]
[sys.usb.state]: [mtp,adb]
[sys.voltage.value]: [12534]
[telematics.DrawingFunctionNo]: [3987ZTHR A110M1]
[telematics.DrawingHardwareNo]: [39870TJB A111M1]
[telematics.DrawingSoftwareNo]: [39872TJB A110M1]
[telematics.NADSwVersion]: [112.0.6000]
[telematics.PhoneNumber]: [19564087058]
[telematics.SWVersionBuild]: [003]
[telematics.SWVersionMajor]: [17]
[telematics.SWVersionMinor]: [07]
[telematics.TCUMin]: [310170822546826]
[vold.post_fs_data_done]: [1]
[wifi.interface]: [wlan0]
[wlan.driver.status]: [ok]
[wrap.com.honda.tjba.navigation]: [LD_PRELOAD=/system/lib/libdlmalloc.so]
the1dynasty is offline  
Old 07-10-2019, 03:41 PM
  #53  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by Dereileak View Post
I wonder if we download the apk from the headunit if there are some settings that could be changed in the manifest file or not. Also wonder what other settings Acura is setting in perhaps the build.config file perhaps disabling some of the APKs, because they show as enabled according to android
You could do an ADB pull but it wouldn't do us any good without root. The APK can be modified but it'll probably not install until we have root.
pbsredrdx is offline  
Old 07-10-2019, 05:01 PM
  #54  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Just glancing over some other posts and I wonder if there is a way to start the Android Auto listening service on the RDX since the APK is already installed in the unit.

https://stackoverflow.com/questions/...om-a-adb-shell

Have to find what service runs the listening service for Android Auto and have it run in the background waiting for an Android device to connect. Not sure if that command requires root though to get it started.
pbsredrdx is offline  
Old 07-10-2019, 07:37 PM
  #55  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
I am able to pull the Androidauto.apk from the head unit. No root needed. It is only 331kb, probably nothing of interest. But I don't have time to look at it yet.

I wonder if we can install the civic AndroidAuto.apk to RDX.

Last edited by omygod711; 07-10-2019 at 07:51 PM.
omygod711 is offline  
Old 07-10-2019, 09:18 PM
  #56  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
I am able to pull the Androidauto.apk from the head unit. No root needed. It is only 331kb, probably nothing of interest. But I don't have time to look at it yet.

I wonder if we can install the civic AndroidAuto.apk to RDX.
That might not be a bad idea... Hopefully it's got the same signature keys etc to overwrite the current installed apk...

How did you manage to pull the apk? I can grab the AA apk from my type r and push it to the RDX to see if it will work... I just couldn't get the apk pulled from the RDX but it was hot in my garage and I didn't want to sit there very long lol...
the1dynasty is offline  
Old 07-10-2019, 09:28 PM
  #57  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by the1dynasty View Post
That might not be a bad idea... Hopefully it's got the same signature keys etc to overwrite the current installed apk...

How did you manage to pull the apk? I can grab the AA apk from my type r and push it to the RDX to see if it will work... I just couldn't get the apk pulled from the RDX but it was hot in my garage and I didn't want to sit there very long lol...
Yeah that might be a good idea. It may install separately since it's probably a different package name but we won't know until someone tries it. Also maybe it'll run without needing to turn off driver distraction.
pbsredrdx is offline  
Old 07-10-2019, 10:48 PM
  #58  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by the1dynasty View Post
That might not be a bad idea... Hopefully it's got the same signature keys etc to overwrite the current installed apk...

How did you manage to pull the apk? I can grab the AA apk from my type r and push it to the RDX to see if it will work... I just couldn't get the apk pulled from the RDX but it was hot in my garage and I didn't want to sit there very long lol...

I used the command adb.exe shell pull /system/app/AndroidAuto/AndroidAuto.apk

are we not suppose to have permission to pull it? I attached the apk here, nothing interesting in it, maybe it is incomplete?
Attached Files
File Type: apk
AndroidAuto.apk (330.5 KB, 10 views)
omygod711 is offline  
The following users liked this post:
the1dynasty (07-11-2019)
Old 07-11-2019, 12:30 AM
  #59  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
I used the command adb.exe shell pull /system/app/AndroidAuto/AndroidAuto.apk

are we not suppose to have permission to pull it? I attached the apk here, nothing interesting in it, maybe it is incomplete?
Weird because I tried the same command but I got an error for READ ONLY blah blah... I'll try again after work...
the1dynasty is offline  
Old 07-11-2019, 07:20 PM
  #60  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
how can i enable usb debugging in rdx headunit?
lahirugl is offline  
Old 07-11-2019, 08:12 PM
  #61  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by lahirugl View Post
how can i enable usb debugging in rdx headunit?
I assumed you will need the full instruction. You need to enable ADB before debugging will do anything.

Enable ADB mode:
First you need to get into the dealer menu by press and hold the 3 buttons on top of the track pad. You will enter the dealer menu after 10 sec or so. Once you are there, you will see two options, select the bottom option. Now press and hold the right button on top of the touch pad until more options appear. One of them is USB. Select it and change it from apple car play to ADB.

Note: You will also see "distraction" in this menu, you will need to turn if "off" Everytime you start ur car to keep head unit reload running while car is in motion.

Enable debugging:

Assuming u are still in dealer menu, You can use the upper right hand button on the screen (it's something like return / exit etc) to return to normal headunit menu.
On the normal menu, select Setting. In setting, select About. Around the bottom of the about menu there should be a Build Number. Keep tapping on it for about 7 times until you see a message that you are a developer. You now unlock developer menu. In the ABOUT menu, there should be a developer item or maybe it is under about - advanced. You will have to look for it a bit. Once you find the developer option USB debugging will be there.
omygod711 is offline  
Old 07-11-2019, 08:14 PM
  #62  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by the1dynasty View Post
Weird because I tried the same command but I got an error for READ ONLY blah blah... I'll try again after work...
Maybe you used push? If it's read only pull should work because you are reading it.
omygod711 is offline  
Old 07-11-2019, 08:26 PM
  #63  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Tried clicking on the build number.. nothing happens
lahirugl is offline  
Old 07-11-2019, 08:57 PM
  #64  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
I assumed you will need the full instruction. You need to enable ADB before debugging will do anything.

Enable ADB mode:
First you need to get into the dealer menu by press and hold the 3 buttons on top of the track pad. You will enter the dealer menu after 10 sec or so. Once you are there, you will see two options, select the bottom option. Now press and hold the right button on top of the touch pad until more options appear. One of them is USB. Select it and change it from apple car play to ADB.

Note: You will also see "distraction" in this menu, you will need to turn if "off" Everytime you start ur car to keep head unit reload running while car is in motion.

Enable debugging:

Assuming u are still in dealer menu, You can use the upper right hand button on the screen (it's something like return / exit etc) to return to normal headunit menu.
On the normal menu, select Setting. In setting, select About. Around the bottom of the about menu there should be a Build Number. Keep tapping on it for about 7 times until you see a message that you are a developer. You now unlock developer menu. In the ABOUT menu, there should be a developer item or maybe it is under about - advanced. You will have to look for it a bit. Once you find the developer option USB debugging will be there.
Tried clicking on the build number.. nothing happens
lahirugl is offline  
Old 07-11-2019, 08:57 PM
  #65  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by lahirugl View Post
Tried clicking on the build number.. nothing happens
Keep tapping it??
omygod711 is offline  
Old 07-11-2019, 09:00 PM
  #66  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
Keep tapping it??
Tried 20 times
lahirugl is offline  
Old 07-11-2019, 09:07 PM
  #67  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by lahirugl View Post
Tried 20 times
Maybe it's already enable, can you look around for the advance option in about?
omygod711 is offline  
Old 07-11-2019, 10:39 PM
  #68  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Mine was enabled already. Tapping the bulls number does nothing for me. I've been using Android for many years and I know my way around it quite a bit... But tapping for me does nothing. I got all the adb stuff to work so I guess it was somehow enabled already for me.
the1dynasty is offline  
Old 07-12-2019, 07:04 AM
  #69  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by lahirugl View Post
Tried 20 times
I'm in my car now and double check the option. If you already enabled developer options the option should be inside About menu at the very bottom.
omygod711 is offline  
Old 07-12-2019, 10:38 AM
  #70  
Registered Member
 
Join Date: May 2005
Age: 41
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Go Private

Since Honda is heavily invested in OTA and this ancient version of Android you guys should have this thread NOT public if you dont want them locking you out in future updates. I have had calls with them and they are extremely phobic about people modifying the existing forked version they internally developed. Its a high visability project and the more it gets in the media higher the chance you'll lose ability to do this.
dezoris is offline  
Old 07-12-2019, 08:18 PM
  #71  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
I'm in my car now and double check the option. If you already enabled developer options the option should be inside About menu at the very bottom.
Its not enabled in my car and im not able to enable it
lahirugl is offline  
Old 07-12-2019, 09:46 PM
  #72  
Registered Member
 
Join Date: Jul 2018
Age: 33
Posts: 116
Received 6 Likes on 6 Posts
Originally Posted by lahirugl View Post
Its not enabled in my car and im not able to enable it

sorry, I might've missed a step. Look at the first post here, https://acurazine.com/forums/third-g...-menus-980593/
You have to enable the developer option mode inside the Diagnostic Menu. see if that helps.
omygod711 is offline  
Old 07-13-2019, 04:33 PM
  #73  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by omygod711 View Post
sorry, I might've missed a step. Look at the first post here, https://acurazine.com/forums/third-g...-menus-980593/
You have to enable the developer option mode inside the Diagnostic Menu. see if that helps.
Finally installed it. But this is how its looks like
lahirugl is offline  
Old 07-13-2019, 08:23 PM
  #74  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by lahirugl View Post
Finally installed it. But this is how its looks like
You have to change the resolution to at least 720p in the HeadUnit Reloaded settings. Also change the DPI if you don't want it to run in widescreen AA. I use 250 for my DPI.
pbsredrdx is offline  
Old 07-14-2019, 08:22 AM
  #75  
New Member
 
Join Date: Jul 2019
Age: 35
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by pbsredrdx View Post
You have to change the resolution to at least 720p in the HeadUnit Reloaded settings. Also change the DPI if you don't want it to run in widescreen AA. I use 250 for my DPI.
It worked. Thanks.
Do i have to set Driver Distraction off every time to use AA when driving?
lahirugl is offline  
Old 07-14-2019, 11:21 AM
  #76  
New Member
 
Join Date: Jul 2019
Age: 34
Posts: 8
Received 0 Likes on 0 Posts
Originally Posted by lahirugl View Post
It worked. Thanks.
Do i have to set Driver Distraction off every time to use AA when driving?
Awesome man!! Glad you got it working...
the1dynasty is offline  
Old 07-14-2019, 02:59 PM
  #77  
Registered Member
 
Join Date: Apr 2019
Location: LA, CA
Posts: 29
Received 9 Likes on 4 Posts
Originally Posted by lahirugl View Post
It worked. Thanks.
Do i have to set Driver Distraction off every time to use AA when driving?
For now yes. Every time you restart your car you have to turn it off so it'll suck for short trips.

Also, Google Now does work but it's very finicky. I changed the Mic Audio Rate to 44100 in HeadUnit Reloaded settings and I can give it commands and it'll respond. However, I have to be screaming pretty loud and listening to my voice recordings through my account I hear a lot of static. It seems to be using the RDX's microphone up top. So it works but you may have to scream really loud for it to hear you.
pbsredrdx is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Barb Jackson
2G RDX Audio, Bluetooth, Electronics & Navigation
11
09-15-2015 02:27 PM
Ch33sE1
3G TL Photograph Gallery
58
09-09-2010 05:39 PM
Sly Raskal
Technology
5
08-06-2009 02:30 PM
DAYTA
1G TSX Photograph Gallery
8
03-17-2009 04:02 PM


Thread Tools
Search this Thread
Quick Reply: App Installed on RDX :D (WIP)


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.