Notices

How reliable has your TSX been?

 
Old 05-15-2019, 09:36 PM
  #81  
Registered Member
iTrader: (1)
 
EuroRspec's Avatar
 
Join Date: Jan 2009
Posts: 167
Received 19 Likes on 17 Posts
Loved my first gen TSX 6spd, and after a few years in other makes, bought my 2012 Wagon in 2016 with 37K miles. Car has been solid besides a few annoyances.

-At 40k noticed a vibration at 60mph+ and it never really went away with more speed. Dealer determined it was the Pass axle and replaced under warranty. Got better, but I'm super sensitive to the feeling and I can still feel it. Even after lowering the car and changing the wheels, no change. So it's something in the suspension.

-At 55k miles, which is now and probably related to the above - I'm hearing a very pronounced clunk out of the suspension on warmer days and after driving for 10+ miles(Nothing when the car is cold). After extensive research, I think it's my lower ball joint, which there is a TSB for, and my car falls into the model year range and exhibits similar symptoms. I decided to order a new passenger ball joint and will install in the upcoming weeks(Hopefully that's it).

- In addition to that, I have an annoying driver seat creak. Sounds like it's coming from the lower seat back. I'm too lazy to mess with it and was hoping it would heal itself but, it hasn't lol.

Other than regular maintenance, the car has been really solid. It's almost paid off and I've thought about selling(I'm really torn), but I love the simplicity, reliability + the handling and feel(I'm torn). The car still looks great + relevant in the present day.
EuroRspec is offline  
The following users liked this post:
Sheefo2k (05-16-2019)
Old 05-16-2019, 11:38 AM
  #82  
ceb
Registered Member
 
Join Date: May 2011
Posts: 5,079
Received 1,172 Likes on 871 Posts
2013 wagon here with about 80k miles. Aside from regular maintenance (still on original brakes), I had a bad battery at 30k miles and a defective cigarette lighter socket - both fixed under warranty. 31+mpg on the highway.

Every time I get a hankering for a new car, I ask myself what I'd miss. That list is long and overshadows the advantages of a new car. I've put far more miles on a car before but it has been 30 years that I've owned a car for more than 3 years.
ceb is offline  
Old 05-17-2019, 03:37 PM
  #83  
Registered Member
 
jdmjustin's Avatar
 
Join Date: Apr 2019
Location: Springfield, MO
Age: 35
Posts: 52
Received 10 Likes on 8 Posts
2010 here, bought it in Oct 2017 with 95K currently at 118k. Nothing but maintenance. No oil burning, which I hear is rare :lmao:

Only annoyance is the seat fabric ripping and the armest on the drivers door. Also PO must of worn a ring on their right hand, ebrake lever is all scratched up. Also my temp control lights have went out twice. All other lights on the climate control work. I just deal with it now. More of a hassle to take it all apart. I replaced with OEM Acura bulbs, and they burned out within 2 weeks.


Scratched up...need to refurb this.

Dirty Interior

Climate control bulbs out, this was after I replaced them, 3 weeks later. Drivers went first, then passenger side.

50/50 of arm rest, also showing the crappy seat material Acura used for the sides of the seats...

100% stock, OEM+ af
jdmjustin is offline  
Old 05-18-2019, 02:26 PM
  #84  
Registered Member
 
raindogt's Avatar
 
Join Date: Nov 2013
Posts: 41
Received 15 Likes on 3 Posts
'09 6MT here, black exterior, black interior, 160k on the clock . Same "problems" as you-- seat ripping in same spot and temp light out on passenger side.

One more annoyance is the garage door clicker-- I don't consider my car to be old (even though it really kind of is lol) but I was bummed when my new garage doors weren't compatible with the homelink on the car. I know the frequency can be updated-- just not worth the $80 or so for a car that will be given to my (newly driving) son in the next year or so.
raindogt is offline  
Old 05-20-2019, 08:39 AM
  #85  
Registered Member
 
jdmjustin's Avatar
 
Join Date: Apr 2019
Location: Springfield, MO
Age: 35
Posts: 52
Received 10 Likes on 8 Posts
Originally Posted by raindogt View Post
'09 6MT here, black exterior, black interior, 160k on the clock . Same "problems" as you-- seat ripping in same spot and temp light out on passenger side.

One more annoyance is the garage door clicker-- I don't consider my car to be old (even though it really kind of is lol) but I was bummed when my new garage doors weren't compatible with the homelink on the car. I know the frequency can be updated-- just not worth the $80 or so for a car that will be given to my (newly driving) son in the next year or so.
My house was built in '15, took me almost an hour for the Homelink to work on my door. I have 2 doors, but only got it work for the door I use. I tried programming the 2 other buttons, but gave up.
jdmjustin is offline  
Old 05-25-2019, 09:13 PM
  #86  
Registered Member
 
Join Date: Nov 2006
Age: 34
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
I have a 12 Wagon with 109k miles, bought it with 9k miles, besides maintenance all I had to do was new axles.

Wife has a 13 wagon with 60 k miles, nothing but oil changes.
tonggi is offline  
 


Thread Tools
Search this Thread

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.