Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine TL/TLX Community > Second Generation TL (1999-2003)
Reload this Page >

Acura TL 03 - 3K rpm cut off while running and engine dies

Notices

Acura TL 03 - 3K rpm cut off while running and engine dies

 
Old 12-13-2018, 11:15 AM
  #1  
New Member
Thread Starter
 
Join Date: Jan 2018
Age: 27
Posts: 3
Received 0 Likes on 0 Posts
Acura TL 03 - 3K rpm cut off while running and engine dies

I have an 2003 TL. It had the check engine light on from a long time.
One cold morning, the car started and the wasnt going over 3rpm. I drove for a while. When pulled over and restarted the engine, it doesnt start the engine, the battery seems to look good.
The car tries to start but doesnt. It started eventually. After going for a little distance, the engine suddenly died on me, the steering was hard and brakes were hard too.
After few attempts, the car started again and I directly drove home and parked it there.

Any ideas on where to look and what might have gone wrong ?
Vamsikalluru is offline  
Old 12-13-2018, 11:18 AM
  #2  
Registered Member
iTrader: (1)
 
losiglow's Avatar
 
Join Date: Nov 2010
Location: Salt Lake City, UT
Age: 37
Posts: 3,100
Received 736 Likes on 523 Posts
Get the error code first. Without an error code it's going to be kind of difficult to diagnose. You may have to take it to an auto parts store for them to scan it, unless you happen to have your own scanner. Autozone, O'reileys, Advanced Auto, NAPA, any of those can scan and tell you the code for free.

Once you get the code let us know.
losiglow is offline  
The following users liked this post:
Vamsikalluru (12-13-2018)
Old 12-13-2018, 11:21 AM
  #3  
New Member
Thread Starter
 
Join Date: Jan 2018
Age: 27
Posts: 3
Received 0 Likes on 0 Posts
Will do that and let you know. I'm new to all this. Thanks
Vamsikalluru is offline  
Old 12-13-2018, 11:31 AM
  #4  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,986
Received 5,846 Likes on 4,687 Posts
thoiboi is offline  
Old 12-13-2018, 11:41 AM
  #5  
Registered Member
iTrader: (1)
 
losiglow's Avatar
 
Join Date: Nov 2010
Location: Salt Lake City, UT
Age: 37
Posts: 3,100
Received 736 Likes on 523 Posts
Yeah, definitely could be. There are a variety of sensors and components that could cause it to go into limp mode if they malfunction. Might be as easy as replacing a sensor.
losiglow is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lauryn115
3G TL Problems & Fixes
6
12-07-2018 01:38 PM
fbazakos
Second Generation CL Discussion (2000-2003)
19
05-16-2017 04:31 PM
Dan
2G CL Frequently Asked Questions
30
06-10-2014 10:09 PM
CLS2001_97124
Second Generation CL Discussion (2000-2003)
49
01-15-2004 10:49 AM
Dizzy
Second Generation CL Discussion (2000-2003)
3
08-03-2001 12:06 PM


Thread Tools
Search this Thread
Quick Reply: Acura TL 03 - 3K rpm cut off while running and engine dies


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.