Notices

02 tl stalling after startup

 
Old 05-30-2019, 08:17 PM
  #1  
New Member
Thread Starter
 
Join Date: May 2019
Age: 41
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
02 tl stalling after startup

Iím new to this forum stuff so bear with me...

my 02 tl starts perfectly, idles a little high (1100 rpm), but when you try to accelerate it starts to stumble and attempts to die. But it never dies or throws a check engine code. Iíd relate it to being like a carburetor with a bad accelerator pump. I can pump the gas pedal and get it to move in a jerky fashion or If I just hold the pedal in one spot it tries to die, then accelerates then tries to die. However 30 to 45 seconds of this and it runs perfectly. It does it with the engine hot or cold, and weather appears to have no affect. Ive cleaned idle air control, no change. Iíve tested the tps with my code scanner and it appears to be fine. Iím baffled. It seems to be something in the initial startup phase but I donít know a lot about these cars. This thing has given me 255k of reliable miles and been a great car and I canít let it beat me on the first difficult issue it throws me.

Thanks ahead of time for any help!!
Angry Twizzlers is offline  
Old 06-04-2019, 02:12 PM
  #2  
Registered Member
 
Join Date: Jul 2017
Age: 24
Posts: 281
Received 22 Likes on 19 Posts
I've been away from my TL for over a month now so I can't recall the exact name of the thing, but there's a little hole on the lower intake manifold that can get clogged up over time. There's a DIY on this forum about cleaning it out - it's a quick job so see if that does the trick.
Arkady is offline  
Old 06-05-2019, 04:35 PM
  #3  
Registered Member
 
Silencer_'s Avatar
 
Join Date: Aug 2015
Location: San Francisco, CA
Age: 28
Posts: 122
Received 9 Likes on 9 Posts
Maybe it's an o2 sensor? I remember having the same problem. I switched it out and the car ran fine afterwards.
Silencer_ is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jojo2112
1G & 2G MDX Discussion (2001-2013)
7
05-16-2014 09:21 PM
jayn1321
2G TL Problems & Fixes
18
03-22-2011 06:11 PM
MaxMike93
1G CL Problems & Fixes
8
05-16-2010 12:21 AM
skyline
Second Generation CL Discussion (2000-2003)
14
03-29-2002 01:25 AM
skyline
First Generation CL Discussion (1997-1999)
4
03-29-2002 12:52 AM


Thread Tools
Search this Thread
Quick Reply: 02 tl stalling after startup


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.