E-002: Jpipe, High Flow Pre-Cat and Pre Cat Delete Upgrade (video and dynos inside) - AcuraZine - Acura Enthusiast Community

Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine RL/RLX Community > Second Generation RL (2005-2012)
Reload this Page >

E-002: Jpipe, High Flow Pre-Cat and Pre Cat Delete Upgrade (video and dynos inside)

Notices

E-002: Jpipe, High Flow Pre-Cat and Pre Cat Delete Upgrade (video and dynos inside)

 
Old 04-20-2012, 06:05 PM
  #1  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
E-002: Jpipe, High Flow Pre-Cat and Pre Cat Delete Upgrade (video and dynos inside)

As promised guys I have a video of the jpipe plus pcd combo.
Please excuse the scratch on the rear bumper.. I JUST shut the garage door too close a few days ago



And for the review:
Only driven about 50 miles or so today. I won't be able to do much driving over the weekend as we need the SUV for the trip to Disney for the weekend.

So far..

Pros:
The sound is great; deeper not raspy. It only enhances the exhaust note and during idle and normal cruising it's quite like OEM.

Power is IMMEDIATELY noticed. The power curve/band is not as noticeable, its more linear power. I would say a good amount of HP was free'd up.

I was gunning it on an on ramp to a bridge and hit the rev limiter in second gear.. usually I know when to shift ( since it takes forever )

Cons:
The CEL (check engine light) came on as I was pulling into my house ~ 50 miles later.

Might have to play with the foulers etc to resolve this later ( doesnt matter to me, just annoying to look at )

The exhaust smelled a little more, those with no cats and or HFC (high flow cats) know what I mean; Then again it might be because it's still new and hasn't had a chance to break in.

Overall I am completely satisfied and i'm starting to itch for a complete exhaust ie cat back from japan.

Coming from a 480 whp Lancer Evolution, so the power increase with this combo was MUCH needed and wish it were a factory option (A-SPEC)

Feel free to ask any questions, I'll try to answer them as soon as I can.
It is a Friday night and I'm heading to Disney for the weekend
vletnguyen is offline  
The Following 8 Users Say Thank You to vletnguyen For This Useful Post:
253RL (04-20-2012), EL19 (04-20-2012), fatty (04-28-2012), lkoszela (05-01-2012), neuronbob (04-22-2012), oo7spy (04-22-2012), SSjTrunks112O (04-20-2012), Tony Torque (04-20-2012)
Old 04-20-2012, 06:35 PM
  #2  
Registered Member
iTrader: (4)
 
EL19's Avatar
 
Join Date: Nov 2006
Location: DC
Age: 32
Posts: 5,292
Thanked 158 Times in 135 Posts
All I can say is good shit my man! The exhaust smell is not going to go away, thats the smell of a catless car. Doesn't bother me too much though. I like the sound. I'm not sure why the mufflers sound tinny or blown out during the inital start up, but otherwise the exhaust sounds good. I'm still torn on whether to do PCD or HFPC.

You do the install yourself? Or pay someone? I did it myself and it was a great learning experience. The defoulers might need to be backed out a lil but most likely they are not far enough into the exhaust stream causing an inefficient catalytic converter cel. Also they have to be pointing straight up if I remember correctly. Enjoy the new power!
EL19 is offline  
Old 04-20-2012, 07:57 PM
  #3  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
OMG! You just made the next 5 years of ownership so much more enjoyable! I'm getting the PCD's ASAP! And can't wait for the j pipe to come available again! To clarify you got the 3G TL pcd? Not the 6g accord right?, anyways man I'm super excited as you guys might know from my excessive posting thanks again bro I'm still smiling! Also as L mentioned did you install yourself? I'm pretty skilled just don't like headaches! Also does rv6 guarentee no cel or what's the deal with that?
253RL is offline  
Old 04-20-2012, 07:59 PM
  #4  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
That sounds so good! Sorry I read everthing before I watched the vid hahahaha! Thanks man
253RL is offline  
Old 04-20-2012, 08:42 PM
  #5  
Registered Member
 
Tony Torque's Avatar
 
Join Date: Mar 2012
Age: 32
Posts: 124
Thanked 5 Times in 5 Posts
Wow that sounds good and clean.
Tony Torque is offline  
Old 04-20-2012, 09:43 PM
  #6  
Registered Member
 
Tony Torque's Avatar
 
Join Date: Mar 2012
Age: 32
Posts: 124
Thanked 5 Times in 5 Posts
Signature test post.
Tony Torque is offline  
Old 04-20-2012, 10:16 PM
  #7  
Registered Member
iTrader: (1)
 
HEAVY_RL's Avatar
 
Join Date: Nov 2008
Location: RVa
Age: 38
Posts: 6,987
Thanked 982 Times in 801 Posts
Test failed.
HEAVY_RL is offline  
Old 04-20-2012, 10:18 PM
  #8  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
It's clickable but fail^!
253RL is offline  
Old 04-20-2012, 10:19 PM
  #9  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
Hey heavy do you know the answer to the rv6 pcd fitment? It looks as though the 7G accord the 3G tl and 2g rl share the same power plant?...

Last edited by 253RL; 04-20-2012 at 10:25 PM. Reason: Typo
253RL is offline  
Old 04-20-2012, 10:28 PM
  #10  
Registered Member
iTrader: (1)
 
HEAVY_RL's Avatar
 
Join Date: Nov 2008
Location: RVa
Age: 38
Posts: 6,987
Thanked 982 Times in 801 Posts
Negative, my pockets arent deep enough to try the 3gTL HFPCs
HEAVY_RL is offline  
Old 04-20-2012, 10:54 PM
  #11  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
Never mind guys found my answer on page 7 of the rv6 thread, MR. L mentioned it, 3G TL and 7G accord PCD fit 2.5G 05-08 RL! Why is it 2.5G?
253RL is offline  
Old 04-21-2012, 04:38 PM
  #12  
Registered Member
 
ktrulez's Avatar
 
Join Date: May 2010
Posts: 30
Thanked 4 Times in 4 Posts
are you the only one with the CEL problem? I hope I don't get it when I get a chance to install mine.
ktrulez is offline  
Old 04-21-2012, 04:49 PM
  #13  
Registered Member
 
fatty's Avatar
 
Join Date: Oct 2007
Age: 37
Posts: 366
Thanked 5 Times in 4 Posts
Originally Posted by ktrulez View Post
are you the only one with the CEL problem? I hope I don't get it when I get a chance to install mine.
You picked it up too?!?!?!????
fatty is offline  
Old 04-21-2012, 08:13 PM
  #14  
Registered Member
 
fatty's Avatar
 
Join Date: Oct 2007
Age: 37
Posts: 366
Thanked 5 Times in 4 Posts
What are you picking up from Japan? I wanted the amuse R1 but I am too afraid to damage it because I know I scrape my pipe everywhere.

http://www.bulletproofautomotive.com...il.php?ID=3796
fatty is offline  
Old 04-21-2012, 08:16 PM
  #15  
Registered Member
 
Tony Torque's Avatar
 
Join Date: Mar 2012
Age: 32
Posts: 124
Thanked 5 Times in 5 Posts
Originally Posted by HEAVY_RL View Post
Test failed.
Yeah I have to figure it out lol sorry no more posts about this don't want to ruin the thread.
Tony Torque is offline  
Old 04-21-2012, 10:03 PM
  #16  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
^^^ baller status I don't think anyone in the states has that exhaust! I would love to hear that thing in vtec!P
253RL is offline  
Old 04-22-2012, 01:40 AM
  #17  
Registered Member
 
ichi d's Avatar
 
Join Date: Apr 2010
Posts: 965
Thanked 76 Times in 64 Posts
Op looks like u have the chrome signal bulbs, I'm I right?
ichi d is offline  
Old 04-22-2012, 02:45 AM
  #18  
Registered Member
 
Join Date: Jan 2012
Location: 253 Washington
Age: 32
Posts: 480
Thanked 58 Times in 51 Posts
^^looks like it to me good eye ichi!
253RL is offline  
The Following User Says Thank You to 253RL For This Useful Post:
ichi d (04-22-2012)
Old 04-22-2012, 10:48 PM
  #19  
Former Sponsor
 
Join Date: Nov 2005
Location: Chicagoland
Age: 34
Posts: 1,697
Thanked 487 Times in 232 Posts
Originally Posted by vletnguyen View Post
As promised guys I have a video of the jpipe plus pcd combo.
Please excuse the scratch on the rear bumper.. I JUST shut the garage door too close a few days ago

http://youtu.be/y_Cgrce9uWM


And for the review:
Only driven about 50 miles or so today. I won't be able to do much driving over the weekend as we need the SUV for the trip to Disney for the weekend.

So far..

Pros:
The sound is great; deeper not raspy. It only enhances the exhaust note and during idle and normal cruising it's quite like OEM.

Power is IMMEDIATELY noticed. The power curve/band is not as noticeable, its more linear power. I would say a good amount of HP was free'd up.

I was gunning it on an on ramp to a bridge and hit the rev limiter in second gear.. usually I know when to shift ( since it takes forever )

Cons:
The CEL (check engine light) came on as I was pulling into my house ~ 50 miles later.

Might have to play with the foulers etc to resolve this later ( doesnt matter to me, just annoying to look at )

The exhaust smelled a little more, those with no cats and or HFC (high flow cats) know what I mean; Then again it might be because it's still new and hasn't had a chance to break in.

Overall I am completely satisfied and i'm starting to itch for a complete exhaust ie cat back from japan.

Coming from a 480 whp Lancer Evolution, so the power increase with this combo was MUCH needed and wish it were a factory option (A-SPEC)

Feel free to ask any questions, I'll try to answer them as soon as I can.
It is a Friday night and I'm heading to Disney for the weekend
Did you do a hard reset (pull battery) after the install?
Richie v6 is offline  
Old 04-23-2012, 12:30 PM
  #20  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
Sorry guys was busy at Disney the entire weekend. Going to try to answer your questions.

L's TL: I did attempt to install myself. I did turbo installs ,cams, transmission/transfer case etc in the past by myself. The bolts were rusted so I gave up after I couldnt open one of many bolts. I had the family mechanic do it.

I'm sure it could have been done with more elbow grease/air compressor but I rather pay the mechanic who does it for a living in peanuts HAHAHA

The guys/gals in areas with no salt should be fine. My car was from the Northeast until last month.

253RL: The PCD are from the 3g TL. Fitment was good. I'm going to play with the CEL this week sometime.

ktrulez: I am not sure if i'm the only one with CEL, I'm sure I'll figure it out this week.

ichi d: I am not sure if the previous owner swapped it as I bought the car CPO'd and all I added to the exterior was splash guards.

fatty: In no way am I ordering that exhaust.. I rather have half of a new watch HAHA.
I had Ti exhaust before and they are LOUD. the burnt tips look awesome though.
Worst case I'll do a custom setup with some Ti mufflers. There are a few mandrel bend places around here.

Richie v6: No I did not. I'll do that later tonight and see if it holds for the week. If not I'll try backing out the o2 sensor more .
I also did not try the learning procedure for the ecu.
vletnguyen is offline  
The Following 2 Users Say Thank You to vletnguyen For This Useful Post:
253RL (04-23-2012), EL19 (04-23-2012)
Old 04-23-2012, 01:16 PM
  #21  
Registered Member
iTrader: (4)
 
EL19's Avatar
 
Join Date: Nov 2006
Location: DC
Age: 32
Posts: 5,292
Thanked 158 Times in 135 Posts
Originally Posted by 253RL View Post
OMG! You just made the next 5 years of ownership so much more enjoyable! I'm getting the PCD's ASAP! And can't wait for the j pipe to come available again! To clarify you got the 3G TL pcd? Not the 6g accord right?, anyways man I'm super excited as you guys might know from my excessive posting thanks again bro I'm still smiling! Also as L mentioned did you install yourself? I'm pretty skilled just don't like headaches! Also does rv6 guarentee no cel or what's the deal with that?
Originally Posted by vletnguyen View Post
Sorry guys was busy at Disney the entire weekend. Going to try to answer your questions.

L's TL: I did attempt to install myself. I did turbo installs ,cams, transmission/transfer case etc in the past by myself. The bolts were rusted so I gave up after I couldnt open one of many bolts. I had the family mechanic do it.

I'm sure it could have been done with more elbow grease/air compressor but I rather pay the mechanic who does it for a living in peanuts HAHAHA

The guys/gals in areas with no salt should be fine. My car was from the Northeast until last month.

253RL: The PCD are from the 3g TL. Fitment was good. I'm going to play with the CEL this week sometime.

ktrulez: I am not sure if i'm the only one with CEL, I'm sure I'll figure it out this week.

ichi d: I am not sure if the previous owner swapped it as I bought the car CPO'd and all I added to the exterior was splash guards.

fatty: In no way am I ordering that exhaust.. I rather have half of a new watch HAHA.
I had Ti exhaust before and they are LOUD. the burnt tips look awesome though.
Worst case I'll do a custom setup with some Ti mufflers. There are a few mandrel bend places around here.

Richie v6: No I did not. I'll do that later tonight and see if it holds for the week. If not I'll try backing out the o2 sensor more .
I also did not try the learning procedure for the ecu.
I feel you man. I installed PCDs on my 09 Accord Coupe and it was a brand new car so the bolts werent rusted. But dam that was one hell of a install job with no prior experience. When I swapped the factory cats back in, everything went ALOT smoother. If I do these on the RL, which I'm thinking I will do the HFPCs, I'll attempt it myself first with a mechanic close by for rusted bolts
EL19 is offline  
Old 04-25-2012, 09:53 PM
  #22  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
Slight update.
I pulled the battery for about an hour to reset the CEL code but about 10-15 miles later it turned back on. The car does feel like it has more low end tq which was much needed in this car.
When I have time I'll try to play with the o2 sensor to try and get rid of the annoying CEL.

L's TL: My mechanic had to cut the bolts off, he gave up on trying to remove them.
vletnguyen is offline  
Old 04-26-2012, 02:14 PM
  #23  
Registered Member
 
Join Date: Aug 2011
Location: Boston, MA
Age: 30
Posts: 180
Thanked 29 Times in 26 Posts
Do you know what was the CEL code by any chance?
MrKev is offline  
Old 04-30-2012, 03:10 PM
  #24  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
The codes were the cat codes.
I just cleared them and they came back today. I was being lazy and didnt have a chance to play with the o2 sensors.
vletnguyen is offline  
The Following User Says Thank You to vletnguyen For This Useful Post:
justnspace (04-30-2012)
Old 04-30-2012, 08:19 PM
  #25  
Registered Member
 
ktrulez's Avatar
 
Join Date: May 2010
Posts: 30
Thanked 4 Times in 4 Posts
update us if you have gotten rid of the messages.
ktrulez is offline  
Old 04-30-2012, 09:26 PM
  #26  
Registered Member
 
fatty's Avatar
 
Join Date: Oct 2007
Age: 37
Posts: 366
Thanked 5 Times in 4 Posts
Has the smell gone away a bit at all?
fatty is offline  
Old 05-01-2012, 01:54 AM
  #27  
Registered Member
 
Join Date: Feb 2010
Posts: 305
Thanked 4 Times in 4 Posts
Originally Posted by vletnguyen View Post
The codes were the cat codes.
I just cleared them and they came back today. I was being lazy and didnt have a chance to play with the o2 sensors.
Would a similar issue happen if I got HFPC's as opposed to PCD's?
SSjTrunks112O is offline  
Old 05-01-2012, 08:24 AM
  #28  
Registered Member
iTrader: (4)
 
EL19's Avatar
 
Join Date: Nov 2006
Location: DC
Age: 32
Posts: 5,292
Thanked 158 Times in 135 Posts
HFPCs dont throw codes
EL19 is offline  
Old 05-01-2012, 08:56 PM
  #29  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
I had high flow cats on other cars that threw codes.
i figure might as well get something with no restriction and a little more power ( my state doesn't have emissions)
when i have some time.. i'll take a more in depth look at the situation.

As for the smell i havent really noticed it as much, but then again it's 90's here now and i drive with windows up pretty much 99% of the time now.

I dont think the code does anything, and i do not think that it puts the vehicle into "limp" mode. it's just annoying to look at, wish we had some sort of engine management. That would open up more options for mods ie: forced induction

maybe when i make some real money i'll buy a used comptech kit and see how it goes with jpipe/pcd. There is only one s/c RL and I doubt he has the jpipe/pcd. He hasn't updated his thread.
vletnguyen is offline  
Old 05-02-2012, 03:14 PM
  #30  
Registered Member
iTrader: (4)
 
EL19's Avatar
 
Join Date: Nov 2006
Location: DC
Age: 32
Posts: 5,292
Thanked 158 Times in 135 Posts
4G and 3G guys are reporting no codes with the high flow cats. Thats the only reason i say that. But I'm sure the high flow cats can throw codes on other cars, or even this one. Something a defouler can fix. And yes that light is annoying to look at!
EL19 is offline  
Old 05-07-2012, 04:53 PM
  #31  
Registered Member
 
Join Date: Feb 2010
Posts: 305
Thanked 4 Times in 4 Posts
Does anyone on azine have the j-pipe/hfpc set up? If so what are your reviews? I should be getting my j-pipe finally put on within the next week or two..
SSjTrunks112O is offline  
Old 05-07-2012, 06:37 PM
  #32  
2012 TL SH-AWD
iTrader: (1)
 
Zelaya's Avatar
 
Join Date: Mar 2010
Location: Maryland
Posts: 1,648
Thanked 118 Times in 103 Posts
Originally Posted by vletnguyen View Post
Slight update.
I pulled the battery for about an hour to reset the CEL code but about 10-15 miles later it turned back on. The car does feel like it has more low end tq which was much needed in this car.
When I have time I'll try to play with the o2 sensor to try and get rid of the annoying CEL.

L's TL: My mechanic had to cut the bolts off, he gave up on trying to remove them.
May I ask why you have to wait an hour to reconnect the battery. I thought 15 minutes is more than enough. I'll reset mine and see if I feel more torque. Just ordered another jpipe for my 4th gen TL. Can't wait.
Zelaya is offline  
Old 05-08-2012, 09:27 AM
  #33  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
Zelaya:
i was doing laundry and just left the battery off and connected it when i was done with my chores.

Remember to have your navi/radio codes handy. Good news was all my presents were still intact ( someone said there is a capacitor in the car for this reason )

i'll be installing the crank pulley and looking further into the CEL problem soon.

How does your car sound with the 5zigen exhaust and j pipe? Did you/are you going to have pcd/hfpc ?
vletnguyen is offline  
Old 05-08-2012, 09:40 AM
  #34  
2012 TL SH-AWD
iTrader: (1)
 
Zelaya's Avatar
 
Join Date: Mar 2010
Location: Maryland
Posts: 1,648
Thanked 118 Times in 103 Posts
^^ the 5zigen exhaust with the jpipe sound awesome and I'm happy the way it sounds so don't have any plans on adding pcd/hfpc yet. Did you feel any difference after you reset the CEL
Zelaya is offline  
Old 05-26-2012, 10:14 PM
  #35  
Registered Member
 
Sniffles's Avatar
 
Join Date: Nov 2011
Location: Boston, Mass
Age: 31
Posts: 284
Thanked 49 Times in 45 Posts
did you ever fix the CEL?
Sniffles is offline  
Old 07-03-2012, 03:56 PM
  #36  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
Forgot to update this thread.

The CEL is off and been off for a while now. I just re installed the o2 sensors and it worked. Maybe their was a leak or something.

I also installed the stock sized light weight pulley.

Overall, the car is so much more enjoyable to drive. The power band is very linear now and with the pulley it engages sooner. Even the wifey noticed the power difference when she drove it.

The PCD still yields a slight odor, however it is a lot better then when it was first installed. The odor isn't as bad as my catless EVO VIII.

Next mod would be exhaust, custom quad setup if I can't get the 5zigen.

My autotoys nav/video just died over the weekend also. They just made a newer version so I'll wait to see how that pans out.
vletnguyen is offline  
Old 07-04-2012, 04:34 PM
  #37  
Registered Member
 
tlmaster1's Avatar
 
Join Date: Jun 2009
Location: NJ
Age: 36
Posts: 240
Thanks: 0
Thanked 12 Times in 10 Posts
vletnguyen- go with DOM'S unit its good.
http://www.tvandnav2go.com/
tlmaster1 is offline  
Old 07-05-2012, 05:30 PM
  #38  
Registered Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Location: Clearwater,FL
Posts: 216
Thanked 23 Times in 15 Posts
Originally Posted by tlmaster1 View Post
vletnguyen- go with DOM'S unit its good.
http://www.tvandnav2go.com/
Where can I purchase the unit? Also it seems to only do video I would need another unit ( usa-spec ) to run audio?
vletnguyen is offline  
Old 12-22-2016, 08:51 PM
  #39  
Registered Member
 
MayorMcCheese's Avatar
 
Join Date: Aug 2011
Location: North Jersey
Age: 29
Posts: 366
Thanked 21 Times in 18 Posts
Post Your thoughts on Jpipe or HFPC

So I am looking to buy myself a little christmas to myself and I want to buy something for the Acura.
Currently I have the 09+ RL sway bar sitting in my trunk waiting for instal so I either want the HFPC from RV6 or the Jpipe

i didn't really see a comparison between these 2 head to head on this forum but i only searched in the RL section.

what are the net gains of both parts? 15hp? I need some more HP out of this car I feel the weight on takeoff and unless im in mid rpm 3rd gear for a highway pull it isnt up to par with todays cars on the road with similar hp.

I have a lightweight pulley on now with a KNN drop in but I need freed up hp from that exhaust.

What are your thoughts?

Happy whatever the fuck you celebrate!
MayorMcCheese is offline  
Old 12-22-2016, 09:09 PM
  #40  
Moderator
iTrader: (1)
 
justnspace's Avatar
 
Join Date: Feb 2010
Posts: 79,831
Thanked 13,840 Times in 10,282 Posts
good evening, the Honda engineers created vtec! it's this engine characteristic that provides POWER at 4k and above RPM!
so, if you never drive above 4k, power mods will be a little pointless, as you cant get around the engine's characteristic of vtec!

now, the power adders do provide torque downlow, but where you really feel the car pull is in VTAK!
justnspace is offline  

Thread Tools
Search this Thread
Quick Reply: E-002: Jpipe, High Flow Pre-Cat and Pre Cat Delete Upgrade (video and dynos inside)


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.