Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine RL/RLX Community > Second Generation RL (2005-2012)
Reload this Page >

Check Transmission, AFS (Blinking), and Blinking Drive Light

Notices

Check Transmission, AFS (Blinking), and Blinking Drive Light

 
Old 07-28-2017, 07:03 PM
  #1  
New Member
Thread Starter
 
Join Date: Jul 2017
Age: 32
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Cool Check Transmission, AFS (Blinking), and Blinking Drive Light

Hi. We have a 2005 RL SH-AWD, that is being picky lately.. INTERMITTENT issue when starting. The check transmission, and AFS light come on together on start up. The AFS "idiot" light blinks, and so does the D5 selector light. We can turn the car off, and it usually goes away. We have tested / replaced the battery, the alternator was on it's way out, so it too was replaced. The 'ol girl has 240,000 miles. At one point, she did pop up a code P1717, which indicates a failing park position sensor. Do any of you have any additional ideas? We know the transmission is in good repair. Rear differential replaced in October 2016, and transmission was serviced at the same time.
sphilli80907 is offline  
Old 07-28-2017, 08:06 PM
  #2  
Registered Member
 
truonghthe's Avatar
 
Join Date: Jun 2008
Age: 31
Posts: 6,728
Received 992 Likes on 853 Posts
P1717 along with blinking D5 selector an be resolve by replacing your transmission range switch sensor (part cost around $100 and about 30 mins).
truonghthe is offline  
Old 07-28-2017, 08:07 PM
  #3  
New Member
Thread Starter
 
Join Date: Jul 2017
Age: 32
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Thanks!

I appreciate the help!
sphilli80907 is offline  
Old 04-30-2019, 07:15 AM
  #4  
Happyjack57
 
Join Date: Mar 2016
Location: home of the philly folk fest since 19473
Age: 61
Posts: 9
Received 0 Likes on 0 Posts
Yo philly try the reset trick turn off all your accesories radio lights etc... turn key on to position 2 turn off wait 2 seconds
turn the key back to position 2 again wait 2 seconds turn off, then press gas pedal to floor turn key back on to pos 2 count 35 seconds
turn key off. this should reset tcu and ecu its worked for me on my 06 TL many a time
Happyjack is offline  
Old 05-03-2019, 08:55 PM
  #5  
New Member
 
Join Date: May 2019
Age: 33
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
I had the same issue with my 2005 Acura RL because the mechanic screwed it when they replaced my motor mounts. Try changing or checking the dual and single transmission solenoids. At Acura they are very expensive. i got my solenoids from a junk yarin N. Carolina for $40 dollars. Once I put them on transmission ran find. They are located under the battery and the plate that holds the battery. You cant see from the top nor from the bottom of the car.
johnnelltk03 is offline  
 


Thread Tools
Search this Thread

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.