Bad Transmission Range switch? - AcuraZine - Acura Enthusiast Community

Notices

Bad Transmission Range switch?

Old 07-13-2018, 05:28 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Jul 2012
Location: Hayward CA
Posts: 89
Thanked 4 Times in 4 Posts
Unhappy Bad Transmission Range switch?

Last week, suddenly my RL pop up checking Emission message along with P1717, checking AFS, AWD light is on and the D light flashing. I turned off the car immediately and restarted, check emission still stay on while AWD is off. Is still drives normally and does not show any sign of mechanical issue. All the light turn off after 2 days like nothing happened. Since last week, this 's been happening 3 times already and all the light turn of itself after 1 or 2 days. New battery less than 1 year.

Search around and find this post has similar symptoms https://acurazine.com/forums/second-...terday-962641/
I already orders the sensor and will update after replacing it, any idea what's going on?
hugous is offline  
Old 07-13-2018, 05:55 PM
  #2  
Fk no!TheyldstroyEvrthing
 
RL09's Avatar
 
Join Date: Jan 2016
Posts: 2,491
Thanked 192 Times in 159 Posts
The check Emission system light when it's intermittent can mean oxygen in the gas cap.

Make sure you are doing many clicks when you twist the gas cap on after refueling not just two or three clicks. If the light goes away, then it was that.
RL09 is offline  
Old 07-17-2018, 11:22 AM
  #3  
Registered Member
 
Join Date: May 2012
Age: 40
Posts: 141
Thanked 11 Times in 9 Posts
Let me know... I have had this issue for years... new battery etc.... Has anyone actually figured out a 100% fix for this? I dont mind everything flashing at me, but when your on the highway and you cant get into 5th gear because it wont let you if the check tranny light is on.....gets annoying.... Its been happening almost consistently for the past week, getting frustrated and not sure if it was ever really fixed with people doing the transmission sensors...
mrm143 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Skirmich
1G & 2G MDX Discussion (2001-2013)
7
05-25-2017 09:33 PM
spydercatt
Second Generation TL (1999-2003)
8
06-21-2015 06:26 PM
98BlueStreak
1G CL Problems & Fixes
1
02-12-2013 04:52 PM
spydercatt
Second Generation TL (1999-2003)
0
01-28-2013 07:19 PM
isex02
Second Generation TL (1999-2003)
0
06-22-2005 03:25 PM


Thread Tools
Search this Thread
Quick Reply: Bad Transmission Range switch?


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.