2005 RL electrical problems - AcuraZine - Acura Enthusiast Community

Notices

2005 RL electrical problems

 
Old 02-13-2019, 04:15 AM
  #1  
Registered Member
Thread Starter
 
Join Date: Jul 2017
Age: 31
Posts: 5
Thanked 0 Times in 0 Posts
2005 RL electrical problems

I bought a 1 owner 05 RL with 80,000 miles about 2 years ago. Iíve had some electrical problems that have gotten worse lately.

the passenger side headlight flickers and goes out every once in a while. (Just turn them on and off quick and it goes away)

my power windows stopped working twice

sometimes my key fob doesnít recognize Driver 1 and all my settings are reset (after I turn the vehicle on and off problem goes away)

but lately i have my stereo stereo shut off and not work. Randomly and I get a check emissions and check awd light.

Again turn it off and on and it goes away

also my nav screen dome light and headlights flicker randomly

ANY HELP??

Thanks !
Jtgfagan is offline  
Old 02-13-2019, 10:34 AM
  #2  
Fk no!TheyldstroyEvrthing
 
RL09's Avatar
 
Join Date: Jan 2016
Posts: 2,637
Thanked 202 Times in 168 Posts
I'll take a shot altho im no expert:

Originally Posted by Jtgfagan View Post
I bought a 1 owner 05 RL with 80,000 miles about 2 years ago. Iíve had some electrical problems that have gotten worse lately.

the passenger side headlight flickers and goes out every once in a while. (Just turn them on and off quick and it goes away)


Most probably bulb needs changing. Switch bulbs over to make sure.

my power windows stopped working twice
Odd. But, search on this site for the reset procedure for power windows.

sometimes my key fob doesnít recognize Driver 1 and all my settings are reset (after I turn the vehicle on and off problem goes away)
I'm starting to suspect the battery. How old is it?

but lately i have my stereo stereo shut off and not work. Randomly and I get a check emissions and check awd light.
AWD usually follow the emissions one. You need to pull the codes and see. Can be many things triggering the emissions, mainly o2 sensor and/or cat converter.

Again turn it off and on and it goes away
Make sure you are tighteing the as cap a few clicks when you fill up and not just a click or two. That may trigger emissions too.

also my nav screen dome light and headlights flicker randomly
Didn't you already mention the headlight?

Nav flicker... well, do a search on this on the site.

ANY HELP??

Thanks !
You won't get many answers if you don't try and search for yourself in previous threads for solutions in the future.
RL09 is offline  
The Following User Says Thank You to RL09 For This Useful Post:
HEAVY_RL (02-13-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Riley Herron
3G TL Problems & Fixes
7
12-21-2018 03:54 PM
Spencer325
3G TL Problems & Fixes
12
10-29-2011 10:22 PM
earthbound741
Second Generation TL (1999-2003)
5
04-03-2008 08:56 AM
NYCAcura2.5TL
1G TL Problems & Fixes
5
07-28-2007 09:57 AM
robdog82
First Generation CL Discussion (1997-1999)
23
10-14-2005 04:33 PM


Thread Tools
Search this Thread
Quick Reply: 2005 RL electrical problems


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.