Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine RL/RLX Community > Second Generation RL (2005-2012)
Reload this Page >

2005 Acura RL still misfiring after Coils and plugs changed

Notices

2005 Acura RL still misfiring after Coils and plugs changed

 
Old 03-02-2019, 04:51 PM
  #1  
New Member
Thread Starter
 
Join Date: Mar 2019
Age: 45
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2005 Acura RL still misfiring after Coils and plugs changed

i recently experienced my car missing and idling hard after I start it. I just filled the gas tank up but have not been using 93 octane lately. Took it to my mechanic and he changed plugs and coils but stated itís still misfiring and idling hard. My mechanic stated that the timing belt may be stretched. As I said earlier I hadnít use high octane gas. I need help and answer please. I have about 260,000 miles and this the 1st major problem with my RL
2005AcuraRLSJT is offline  
Old 03-02-2019, 05:53 PM
  #2  
Registered Member
 
Join Date: Feb 2012
Age: 28
Posts: 90
Received 9 Likes on 8 Posts
Well for one, were the correct spark plugs bought?
2. All the connections for the coils seated all the way?
3. Use premium as recommended
4. If you haven't done the TB by this point, probably should do that ASAP.
pewpew is offline  
Old 03-03-2019, 11:31 AM
  #3  
New Member
Thread Starter
 
Join Date: Mar 2019
Age: 45
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by pewpew View Post
Well for one, were the correct spark plugs bought?
2. All the connections for the coils seated all the way?
3. Use premium as recommended
4. If you haven't done the TB by this point, probably should do that ASAP.
brought the correct plugs and coils are seated all the way in. Does not know what TB is????
2005AcuraRLSJT is offline  
Old 03-03-2019, 02:57 PM
  #4  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,984
Received 5,845 Likes on 4,686 Posts
What coils and plugs did you use?

TB = Timing Belt
thoiboi is offline  
Old 03-10-2019, 09:53 AM
  #5  
Registered Member
 
TonyCD's Avatar
 
Join Date: Mar 2004
Posts: 785
Received 129 Likes on 104 Posts
Throwing any trouble codes?
TonyCD is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
3.2beast
Second Generation CL Discussion (2000-2003)
14
12-31-2018 10:34 PM
hurricanejosh
2G TL Problems & Fixes
4
02-04-2013 01:42 PM
3.2_Vtec
2G TL Problems & Fixes
8
03-31-2012 08:51 PM
rxphiler
Second Generation TL (1999-2003)
15
08-25-2009 10:54 AM
BLACKURA_NY
3G TL Tires, Wheels & Suspension
42
02-08-2008 10:33 PM


Thread Tools
Search this Thread
Quick Reply: 2005 Acura RL still misfiring after Coils and plugs changed


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.