Notices

Aftermarket HID Ballast??

 
Old 06-02-2019, 08:37 AM
  #1  
New Member
Thread Starter
 
Join Date: Jun 2019
Age: 42
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Aftermarket HID Ballast??

Hey all! Wondering if anyone can recommend an aftermarket ballast for the headlight or if the OEM is best.

Just trying to to save money on some repairs before I sell my CLS.

thanks
Kicksdechris is offline  
Old 06-03-2019, 10:11 AM
  #2  
~HondaF1~
 
R J Poseidon 6's Avatar
 
Join Date: Jun 2005
Location: Central Florida, USA
Posts: 1,133
Received 51 Likes on 42 Posts
There are tons out there...

I've always gone with these guys:
https://www.hidextra.com/

I just buy a complete kit regardless of what I need and have spares for the others.

Hope this helps!
R J Poseidon 6 is offline  
Old 06-03-2019, 10:18 AM
  #3  
New Member
Thread Starter
 
Join Date: Jun 2019
Age: 42
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by R J Poseidon 6 View Post
There are tons out there...

I've always gone with these guys:
https://www.hidextra.com/

I just buy a complete kit regardless of what I need and have spares for the others.

Hope this helps!

Thank you! I was concerned about the installation...does it mount to the bottom of the headlight like the oem ballast?
Kicksdechris is offline  
Old 06-03-2019, 12:47 PM
  #4  
~HondaF1~
 
R J Poseidon 6's Avatar
 
Join Date: Jun 2005
Location: Central Florida, USA
Posts: 1,133
Received 51 Likes on 42 Posts
It's definitely not an OEM fit.

It will give you double sided sticky tape and zip ties to install how ever you'd like, there's tons of room.
R J Poseidon 6 is offline  
Old 06-03-2019, 01:47 PM
  #5  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 38,193
Received 5,884 Likes on 4,719 Posts
thoiboi is offline  
Old 06-04-2019, 12:06 PM
  #6  
Registered Member
 
smcafee's Avatar
 
Join Date: May 2013
Location: Irvine, OC, SoCal
Posts: 82
Received 9 Likes on 8 Posts
What's the symptom?

On my HID TL one headlight would come on then go out a short time later, wash, rinse, repeat.

Turns out it was the igniter which was partially melted and no longer making proper contact with the bulb base.
smcafee is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kwizzle
Second Generation CL Discussion (2000-2003)
5
09-16-2014 08:23 AM
o4Komodo
Car Parts for Sale
2
06-12-2009 01:20 AM
Tangsta
2G CL Problems & Fixes
4
01-31-2008 06:42 PM
Nyshadow
2G TL Problems & Fixes
4
10-05-2007 02:12 PM
type-s09
Car Parts for Sale
2
10-30-2006 07:24 AM


Thread Tools
Search this Thread
Quick Reply: Aftermarket HID Ballast??


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.