Emission & VSA check light, car revving, and now won't start - AcuraZine - Acura Enthusiast Community

Go Back  AcuraZine - Acura Enthusiast Community > AcuraZine TSX Community > First Generation TSX Discussion (2004-2008)
Reload this Page >

Emission & VSA check light, car revving, and now won't start

Notices

Emission & VSA check light, car revving, and now won't start

Old 09-30-2018, 10:41 AM
  #1  
New Member
Thread Starter
 
Join Date: Apr 2018
Age: 24
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Emission & VSA check light, car revving, and now won't start

So as title suggests: I'm driving down the road and all of a sudden both system check lights come on at the same time for emission & VSA systems. Within a couple miles, my car is revving from idle to 3000RPMs with the transmission in neutral (6-speed manual shift). I make it to my destination and turn off my car (not without taking a quick video of what it was doing, luckily) for it to not turn back on. If I attempt to start it, nothing happens, system trips whatever safety mechanisms it has and everything goes completely dark for 20 minutes. It doesn't even try to turn over. Not even the faintest click sound before all dashboard lights go out and renders my entire car useless. I'm completely at a loss here. Battery tests at 12V, all fuses and relays are good, changing the oil today since it is due, but not sure where to go from there. It seems like it's in the ignition system possibly but I'm not sure what would cause the sudden change while driving. I have already replaced the starter several months ago so that's what makes me wonder what it could be since my car drove perfectly fine with a bad starter.. just wouldn't start again when it went out.. obviously. Any ideas?
Jill-of-all-Trades is offline  
Old 10-01-2018, 10:46 AM
  #2  
Registered Member
 
Join Date: Feb 2015
Posts: 2,396
Thanked 584 Times in 452 Posts
A good guess would be loose grounds or battery cables.
BROlando is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Fcarrillo9
1G TSX Problems & Fixes
1
05-05-2018 02:45 AM
psteng19
1G TSX Problems & Fixes
7
09-01-2017 07:47 PM
lojik
First Generation TSX Discussion (2004-2008)
3
09-04-2015 08:43 AM
griffing
2G TL Problems & Fixes
3
11-24-2012 09:44 AM
cmpuopolo
1G TSX Problems & Fixes
2
08-07-2010 06:10 PM


Thread Tools
Search this Thread
Quick Reply: Emission & VSA check light, car revving, and now won't start


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.