Notices

2007 TSX power steering whines and hose shuts when running

 
Old 04-05-2019, 09:42 PM
  #1  
Registered Member
Thread Starter
 
Join Date: May 2017
Age: 38
Posts: 8
Likes: 0
Liked 0 Times in 0 Posts
2007 TSX power steering whines and hose shuts when running

On my TSX Iím getting a terrible whine when running. It happens as soon as i start it and it never ceases. I replaced the pump and itís doing the exact same thing. I also noticed on the old and new pump the hose from the pump to the reservoir is shut as if itís clamped down. This is the complete hose. Iím totally lost as of what it could be. This is my second hose. On the car. Could it be the belt, hoses, lines, alternator? Help please
dlodeuce4 is offline  
Old 04-06-2019, 05:37 PM
  #2  
Registered Member
 
Reorge's Avatar
 
Join Date: Aug 2003
Location: New Orleans, LA
Posts: 646
Liked 152 Times in 120 Posts
Sounds like some kind of blockage between the fluid and pump.
Since the hose was replaced it can't be the hose.

Most Honda/Acura PS fluid reservoirs have a small mesh screen inside to filter the fluid.
It's hard to see because it's the same color as the plastic reservoir.
Sometimes it can get clogged with small debris.
On some Honda Odysseys the clogging was so common that a new repair part was issued without a screen.

You could remove the reservoir (it's relatively easy) and back-flush it with brake cleaner.
Or you could pull out the screen with pliers or a screwdriver.

Make sure you replace the fluid with fluid made for Honda/Acura.
This is very important.
Reorge is offline  
Old 04-06-2019, 06:40 PM
  #3  
Registered Member
Thread Starter
 
Join Date: May 2017
Age: 38
Posts: 8
Likes: 0
Liked 0 Times in 0 Posts
Ok cool thanks so much
dlodeuce4 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Prufessor_Oak
2G TL Problems & Fixes
5
01-11-2016 11:55 PM
MrHeeltoe
First Generation TSX Discussion (2004-2008)
20
07-03-2010 05:49 AM
chikai
2G CL Transmission Recall Q & A
2
11-28-2003 07:46 AM
ejammies
First Generation CL Discussion (1997-1999)
12
11-06-2003 10:00 PM
acura269
Audio, Video, Electronics & Navigation
0
09-25-2003 12:08 PM


Thread Tools
Search this Thread
Quick Reply: 2007 TSX power steering whines and hose shuts when running


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.