Notices

Cleaned Intake Without Removing Now Stalls When Warm

 
Old 07-13-2015, 03:47 PM
  #1  
PSC
Registered Member
Thread Starter
 
Join Date: Jan 2007
Posts: 85
Likes: 0
Received 2 Likes on 1 Post
Cleaned Intake Without Removing Now Stalls When Warm

Hi guys I still have my 1997 2.5 TL.
I've been having a rough idle so I sprayed intake cleaner into the port to clean it out. The little door was sticky around the edges.
I did not remove it from the intake manifold but I did disconnect the negative battery terminal.
After letting it drain and evaporate it started up fine.

Now though when it reaches operating temperature, once I let off the accelerator, it idles very low and stalls. I have to hit the gas to prevent it from stalling.
Once the temp is low the idle is fine and it does not stall.

I also tried removing the negative terminal again for 5 minutes to see if that would make a difference. I read something about resetting the ECU that way.
No luck it still stalls.

Did I ruin something by not removing the intake first?
I'm annoyed at myself. It was idling rough before but at least I could drive.
Any ideas?

One more thing. Initially the first time I tried to start after cleaning it would not start, but I thought that I just didn't give it enough time.
I tried again after 15 minutes and it started fine.

Last edited by PSC; 07-13-2015 at 03:54 PM.
PSC is offline  
Old 07-13-2015, 04:39 PM
  #2  
PSC
Registered Member
Thread Starter
 
Join Date: Jan 2007
Posts: 85
Likes: 0
Received 2 Likes on 1 Post
I turned the idle screw up a little and now it stays at ~750 rpms. It's not stalling.
Peace guys.
PSC is offline  
Old 07-13-2015, 05:04 PM
  #3  
PSC
Registered Member
Thread Starter
 
Join Date: Jan 2007
Posts: 85
Likes: 0
Received 2 Likes on 1 Post
Next I will remove the IACV and clean it separately because it probably sucked some gunk that came off from cleaning the port door.
PSC is offline  
Old 07-15-2015, 01:06 PM
  #4  
Radical Member
 
9632tl's Avatar
 
Join Date: Jan 2010
Location: Roseburg, Oregon
Age: 29
Posts: 797
Received 16 Likes on 11 Posts
My guess is that some of the gunk clogged the screen on the IACV, and now it cant pass enough air to idle on its own.
9632tl is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cycdaniel
1G TSX Performance Parts & Modifications
5
02-26-2019 08:55 AM
Powder Monkey
2G CL Problems & Fixes
11
09-09-2018 12:55 AM
Laoch
First Generation RL (1996-2004)
3
10-02-2015 03:27 PM
Kevin Sami
Second Generation TL (1999-2003)
4
09-22-2015 09:59 AM
Dunnik
Third Generation TL (2004-2008)
7
09-15-2015 11:52 PM


Thread Tools
Search this Thread
Quick Reply: Cleaned Intake Without Removing Now Stalls When Warm


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.