Notices

DIY: 1st Gen Acura RL Instrument Cluster LED Bulbs

 
Old 09-10-2008, 07:36 PM
  #81  
Registered Member
 
Join Date: Oct 2007
Age: 33
Posts: 60
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by GSARL View Post
clear or white ..its all the same shit....I wish I had a pic to post ,I thought it looked pretty damn good..nice and bright and even
ya wish you did!! i may have to take your word on it and find some clear bulbs.

and chitownRLer, I sent you a pm, but to anyone wanting the xenon white LEDs im selling mine, only been on for a couple months so lots of life left on them.
MasterD86 is offline  
Old 10-15-2008, 09:17 PM
  #82  
Registered Member
 
Join Date: Mar 2008
Location: Toronto, ON
Age: 34
Posts: 21
Likes: 0
Received 0 Likes on 0 Posts
I saw this LED earlier - http://www.superbrightleds.com/specs/74.html
The third one, xHP3 SMD, have LEDs on the side and the measurements are really close to those of the 3-LED ones in the original post (from ebay). These are actually slightly smaller. Even though incandescent #74 bulbs don't fit, I'm wondering if these would since the size is so close. They have the 2 LEDs on the side so it should light up the cluster much more evenly, if they fit of course. I saw this type of LED used on a 2nd gen Legend cluster, and it was lit up beautifully, no spotting.

Anyone have any insight on if this LED would fit our clusters?
thrillhouse is offline  
Old 10-17-2008, 06:04 PM
  #83  
Registered Member
 
Join Date: Oct 2007
Age: 33
Posts: 60
Likes: 0
Received 0 Likes on 0 Posts
omg im so pissed.

so i got the clear bulbs from a local shop that specializes in bulbs, come home to put them in and wouldn't ya know it....

because the damn power tilt\telescope is fubar I couldn't get the gauge bezel out, then I was thinking to remove the top part of the steering column cover but didn't want to pull too hard and break it?

any idea if I just have to pull the cover off?

(btw selling the LEDs now for $15 shipped!! ding ding)
MasterD86 is offline  
Old 10-17-2008, 09:25 PM
  #84  
Registered Member
 
GSARL's Avatar
 
Join Date: Dec 2006
Age: 48
Posts: 213
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by MasterD86 View Post
omg im so pissed.

so i got the clear bulbs from a local shop that specializes in bulbs, come home to put them in and wouldn't ya know it....

because the damn power tilt\telescope is fubar I couldn't get the gauge bezel out, then I was thinking to remove the top part of the steering column cover but didn't want to pull too hard and break it?

any idea if I just have to pull the cover off?

(btw selling the LEDs now for $15 shipped!! ding ding)
Wow, thats a cluster f**k...... no pun intended
GSARL is offline  
Old 10-21-2008, 11:10 PM
  #85  
Registered Member
 
Join Date: Oct 2007
Age: 33
Posts: 60
Likes: 0
Received 0 Likes on 0 Posts
k got it in woot! took some struggling and swearing but its all good.

and was expecting to get a whiteish output, but guess there is an amber film somewhere in the cluster. well, im happy though. thanks GSRL and all who posted write ups
MasterD86 is offline  
Old 11-03-2008, 08:31 AM
  #86  
Registered Member
 
Join Date: Mar 2006
Age: 43
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
I had this done over the weekend. I paid mechanic $60 to do it since it was a very "tedious" work. I wanted to help everyone out by pointing out this particular thread. Jerm1386's post would have been very handy with regards to polarity. Use the pictures to determine the polarity as SOME OF THEM ARE NOT MARKET CORRECTLY! This will save you from screwing the backs of cluster to plug it in to dash to see which bulbs are not lighting up, etc...

My mechanic did it by trial and error but this thread would've been very handy! Will save you tons of time!



Originally Posted by jerm1386 View Post
ok, here's something to help everyone who's doing this: pictures and a 'which direction do I put the darn things in?' guide

First off, the LED's. If you buy them from the seller that 97_RLer recommended, as i did, there are some that are facing the right way with respect to the little (+) symbol on the bottom of each LED, and some that are not. You can figure out which is which (which side is the positive vs negative) by comparing your LED's to this picture. I strongly recommend using a marker to indicate which side is positive (red) and which is negative (usually black). The lines with the arrows indicate the direction the longer, insert board is polarized.



This second picture is of the place where the LED's go. For instructions on how to get to this phase, see the original instructions (here) and the PDF version of the service manual (here) . Insert the LED's so that the positive terminals from the first picture (now inserted into the holders) are in contact with the parts of the sheet that are labeled as positive in the second picture. I got 10 for 10 on the first try after some circuit tracing.



For your convenience, I have included a color-coded diagram of which screws go where. Take it easy on the coarse thread ones (orange and red), use a #2-#3 philips and make sure not to strip them. I used a new leatherman wave and it was pretty much perfect. note that in this picture, the rear of the console is shown oriented upside-down

chitownRLer is offline  
Old 11-03-2008, 08:32 AM
  #87  
Registered Member
 
Join Date: Mar 2006
Age: 43
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
Also, I must mention the difference is night and day....for such a small thing, it makes a huge difference. It felt like I was inside a new vehicle when your dash is lighting up all white at night! But now the ac/radio console loooks like crap compared to the dash, LOL.....
But highly recommend everyone get this done if you can...makes a world of difference at night!
chitownRLer is offline  
Old 11-04-2008, 02:05 PM
  #88  
Registered Member
 
Join Date: Mar 2008
Location: Toronto, ON
Age: 34
Posts: 21
Likes: 0
Received 0 Likes on 0 Posts
yeah the console doesn't look that great beside the cluster anymore. There are LEDs that can be put in the console, it's pretty easy to get behind the climate control but it looks like the radio lights are gonna be hard to get to. Also the console will have more of a blue tint as the face that the light shines through is blue (giving it the green color when mixed with the yellow incandescent bulbs). It's worth a shot though if anyone can figure out how to get to the bulbs behind the radio.
thrillhouse is offline  
Old 11-05-2008, 09:01 AM
  #89  
Registered Member
 
Join Date: Mar 2006
Age: 43
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by MasterD86 View Post
ya wish you did!! i may have to take your word on it and find some clear bulbs.

and chitownRLer, I sent you a pm, but to anyone wanting the xenon white LEDs im selling mine, only been on for a couple months so lots of life left on them.
Thanks master, but i think i replied...i ended up purchasing them from that warden guy on ebay and paid mechanic to put it on.
chitownRLer is offline  
Old 03-30-2009, 03:04 PM
  #90  
Registered Member
 
Join Date: Mar 2006
Age: 43
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
Hey guys...my white LED light bulb from JP Warden blinks now by 60 on the MPH and 8 on the RPM...what da hell do I do now?
chitownRLer is offline  
Old 03-31-2009, 04:58 PM
  #91  
Senior Moderator
 
Ken1997TL's Avatar
 
Join Date: May 2003
Location: Better Neighborhood, Arizona
Posts: 45,469
Received 2,166 Likes on 1,235 Posts
They blink? They might be loose
Ken1997TL is offline  
Old 06-19-2009, 09:39 PM
  #92  
Registered Member
 
Join Date: May 2009
Age: 34
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
why didn't you go w/ all blue bulbs, personal preference???
big C 419 is offline  
Old 06-19-2009, 09:51 PM
  #93  
Registered Member
 
Join Date: May 2009
Age: 34
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
if anyone is still interested just search ebay for 2pcs 24 T6.5 Instrument Panel 3 LED Bulbs(Blue/White),
I just bought 3 sets of blue and 1 set of white for $14.76 (shipping included)
big C 419 is offline  
Old 06-21-2009, 08:31 PM
  #94  
Ultimate DIYer
Thread Starter
 
97_RLer's Avatar
 
Join Date: Mar 2007
Location: Dallas, TX
Posts: 99
Likes: 0
Received 9 Likes on 5 Posts
Originally Posted by big C 419 View Post
why didn't you go w/ all blue bulbs, personal preference???
There is an answer in the thread but you missed I think. The blue LEDs cannot illuminate the red zones in the gauges unlike white LEDs. If I'm doing the instrument gauge bulb conversion again, I would go all white LEDs now.

Just my two cents!

97_RLer
97_RLer is offline  
Old 06-28-2009, 03:21 PM
  #95  
Registered Member
 
Join Date: Mar 2006
Age: 43
Posts: 198
Likes: 0
Received 0 Likes on 0 Posts
yeah, and i would not buy the bulb from that jp warden guy...my dash lights are blinking all over the place now!
chitownRLer is offline  
Old 10-10-2009, 08:44 PM
  #96  
New Member
 
Join Date: Oct 2009
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
I purchased the same bulbs and they were too fat to fit in the socket or the hole in the panel. I was really disappointed and don't understand why my instrument cluster is different. I have a 2002 MDX with nav. Any ideas, I would really like to make this modification.
mjr2121 is offline  
Old 12-05-2009, 01:37 PM
  #97  
New Member
 
Join Date: Dec 2009
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Question T6.5 cluster bulbs

97_RLer

Warden_jp2002 replied to me today (Dec 05, 2009) that the T6.5 3-LED bulbs are # 24 not # 37, and wrote thre cross reference number as 74. Are you sure the T6.5 led bulbs are number 37? Also your pictures of the 3-LED light bulbs are different from his pictures for the number 37. Thanks in advance for your response.
64Falcon is offline  
Old 05-17-2010, 12:58 PM
  #98  
Registered Member
 
Join Date: May 2010
Posts: 7
Likes: 0
Received 1 Like on 1 Post
HI im new. Anyone know what bulbs are used in the 99RL? I want to change my cluster to xenon white but all the confusion and i dont know what size i need.
samlbc is offline  
Old 08-12-2010, 10:56 PM
  #99  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
damn I want to do this so bad! Can someone do it for me?
3.5RLv-tec? is offline  
Old 08-13-2010, 09:17 AM
  #100  
Registered Member
 
Join Date: Feb 2007
Age: 33
Posts: 98
Likes: 0
Received 0 Likes on 0 Posts
do we really wanna go with blue leds since it's the hardesst color to focus on? and also some other health hazards associated with blue light?

texyt.com/bright+blue+leds+annoyance+health+risks
ellover009 is offline  
Old 09-09-2010, 01:02 AM
  #101  
Registered Member
 
Join Date: Aug 2010
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by chitownRLer View Post
yeah, and i would not buy the bulb from that jp warden guy...my dash lights are blinking all over the place now!
Hey did you ever get that fixed? I just put mine in earlier and one of them blinks every so often. Gonna take it apart again tomorrow and see if it's just loose (I hope that's it).
Japam is offline  
Old 10-20-2010, 03:20 PM
  #102  
New Member
 
Join Date: Oct 2010
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
I know this an old post, but I have a 97 RL and '64Falcon asked if the #37(6mm) T6.5 3-LED was the correct size for the gauge lights. Also where do I buy them?
Ytown97RL is offline  
Old 10-20-2010, 03:42 PM
  #103  
Registered Member
 
Join Date: Aug 2010
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Ytown97RL View Post
I know this an old post, but I have a 97 RL and '64Falcon asked if the #37(6mm) T6.5 3-LED was the correct size for the gauge lights. Also where do I buy them?
seriously, not to sound like a d*ck, but you can answer your own question by reading this whole thread.
Japam is offline  
Old 10-21-2010, 06:39 PM
  #104  
New Member
 
Join Date: Oct 2010
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
regular gauge bulbs

I was told by Acura that the instrument panel bulbs could not be bought aftermarket. Only available through Acura or Honda. Total price for the bulbs is $250! Since I have not removed the instrument panel to see the bulbs for myself, I wonder if it is true. Does anybody know if the bulbs are available other than Acura? I think replacing them with the same incandesent bulbs again would be fine.
Ytown97RL is offline  
Old 10-23-2010, 02:16 AM
  #105  
Registered Member
 
Join Date: Aug 2010
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Ytown97RL View Post
I was told by Acura that the instrument panel bulbs could not be bought aftermarket. Only available through Acura or Honda. Total price for the bulbs is $250! Since I have not removed the instrument panel to see the bulbs for myself, I wonder if it is true. Does anybody know if the bulbs are available other than Acura? I think replacing them with the same incandesent bulbs again would be fine.
wow that is a complete lie! That's pure bs bro! 250 for bulbs??? lol.

Here are the replacement bulbs for stock:
http://www.rockauto.com/catalog/x,ca...lectrical-Lamp

the LED ones, you can search for the seller's name (on first page of this thread) on ebay .
Japam is offline  
Old 10-31-2010, 12:07 PM
  #106  
Registered Member
 
Join Date: May 2010
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Installing LED bulbs in gauges need help!!!!

Hey guys, I am in the process of installing the T6.5 led bulbs. I got the board removed already and I see the 10 bulbs that I am suppose to be replacing. What I don't get is how can those T6.5 bulbs go in to the hole and stay there tight. Mine seems to want to fall into the hole. I have already figured out the polarity on the LEDs. Can someone show me a pictures of the LEDs install without the back cover on please? Thanks in advance.
Stormrider01 is offline  
Old 10-31-2010, 01:01 PM
  #107  
Registered Member
 
Join Date: May 2010
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Ok guys, for people who aren't so bright like me and ran into the problem that I did, you are suppose to remove the old bulb from the base and replace it with the new bulb. I finally figured it out! Dugh!
Stormrider01 is offline  
Old 11-06-2010, 03:12 PM
  #108  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
Just ordered 6 pairs of #24 T6.5 3LED Xenon white from warden... Hope it arrives soon! I have a 96 RL, hope it fits!
3.5RLv-tec? is offline  
Old 11-08-2010, 08:14 AM
  #109  
Registered Member
 
Join Date: May 2010
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by 3.5RLv-tec? View Post
Just ordered 6 pairs of #24 T6.5 3LED Xenon white from warden... Hope it arrives soon! I have a 96 RL, hope it fits!

If it's the T6.5 from Warden then it should fit. Just remember to check the polarity first because some are wrong. And be very carefully with those 20 screws....not too loose.....not too tight. I just finished mine and I love it. I went with white on the 2 gauge on the side and blue in the middle.
Stormrider01 is offline  
Old 11-13-2010, 10:00 PM
  #110  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
Damn, how long is the shipping usually take? It has been five days already. I can't wait any longer!! lol
3.5RLv-tec? is offline  
Old 11-14-2010, 09:05 PM
  #111  
Registered Member
 
Join Date: Aug 2010
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
it takes a while cause they're coming from Hong Kong. Mine took a week to a week and a half.
Japam is offline  
Old 11-24-2010, 04:34 PM
  #112  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
Fuck! I install the white LED and when I turned it on the Milage is not showing up and the temp is not working too! The LED is working fine. BTW it smell like something is burning too! Man i hope I didn't fry the cluster!!!! Any idea? thx.
3.5RLv-tec? is offline  
Old 11-24-2010, 05:21 PM
  #113  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
update. The temp is working now but the mileage (where the LCD in the speedo show exactly the mileage of the car, trip A, B, and the outside temp) is not showing up! help plz, damn man the cluster is $500! Why me!!!
3.5RLv-tec? is offline  
Old 11-24-2010, 07:54 PM
  #114  
Registered Member
 
Join Date: Aug 2010
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
man..I dont know. triple check everything, make sure all the wires are connected and nothing's loose.
Japam is offline  
Old 11-24-2010, 08:41 PM
  #115  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
how is the mileages recorded? From the ECU or from the cluster itself? 96 RL. Damn I should have paid the mechanic to do it for me, stupid me! I'm planning to buy a used cluster and hopefully I can get the exact mileage back.
3.5RLv-tec? is offline  
Old 11-24-2010, 11:22 PM
  #116  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
Damn I couldn't find any used cluster, I looked at the acuraoempart.c but I couldn't find it. Does any one know the model number for a 96 RL cluster?BTW is it legal to drive with a broken odometer? I've checked with CA DMV website and it didn't say anything about a broken odometer.
3.5RLv-tec? is offline  
Old 11-25-2010, 06:22 AM
  #117  
2008 Acura 3.2TL
 
ParaSurfer1979's Avatar
 
Join Date: May 2010
Location: Wilmington, NC
Age: 39
Posts: 3,138
Received 110 Likes on 88 Posts
Originally Posted by 97_RLer View Post
I used white LED bulbs on those places because the blue LED cannot lit the red zone as I explained above.
I like this look better than the all white as it updates the gauges to look more inline to the current Acura gauges. Great job. Really updates the gauges. Question... Why didnt you go ahead and update the heating/air/audio stack to LED whilr you were in there?
ParaSurfer1979 is offline  
Old 11-26-2010, 09:47 PM
  #118  
Registered Member
iTrader: (2)
 
Join Date: Feb 2007
Posts: 978
Likes: 0
Received 36 Likes on 35 Posts
Still couldn't find any 96-98 Rl speedometer. I saw 99-03 speedometer on ebay but will it work for 96 RL. Thank you.
3.5RLv-tec? is offline  
Old 12-15-2010, 11:02 PM
  #119  
2008 Acura 3.2TL
 
ParaSurfer1979's Avatar
 
Join Date: May 2010
Location: Wilmington, NC
Age: 39
Posts: 3,138
Received 110 Likes on 88 Posts
Originally Posted by 97_RLer View Post
Here are some more pics for your reference.........


<Nightshot-Tacometer>


<Nightshot-Speedometer>


<Nightshot-Fuel and Temp gauge>


<Day shot of instrument cluster>


<Day shot of interior>

97_RLer
Why do you have that awful steeringwheel cover on there? U can spend money on leds but not a leather wheel cover?
ParaSurfer1979 is offline  
Old 01-18-2011, 06:22 AM
  #120  
New Member
 
Join Date: Mar 2009
Posts: 3
Likes: 0
Received 1 Like on 1 Post
Smile

3.5 RLv-tec: Did you find a new cluster? I just change my dashboard to LED's, and the speedometer is showing about 15 mph over my driving speed. I'm going to take it apart this week and try to re-adjust the screws. Good luck finding a cluster.

Willhiro
willhiro is offline  

Thread Tools
Search this Thread
Quick Reply: DIY: 1st Gen Acura RL Instrument Cluster LED Bulbs


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.