Notices

2000 crankshaft position sensor

 
Old 06-16-2019, 04:54 PM
  #1  
New Member
Thread Starter
 
Join Date: Jun 2019
Location: Pennsylvania
Age: 44
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2000 crankshaft position sensor

Does anyone know where i can access a video or even paper manul with instructions on where cps is at and how to replace it? Also is there any way to rebuild the old one or clean it off or anything like that? Car still starts just runs like crap replaced the fuel pump last week now on way home from work yesterday just started running like crap and the check engine light popped on and code says to replace crankshaft position sensor. So no clue where or how hard it will be to do? Any help much appreciated thx in advance
Richard J. Barlow is offline  
Old 07-06-2019, 12:15 AM
  #2  
Registered Member
 
Join Date: Jun 2019
Age: 20
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Richard J. Barlow View Post
Does anyone know where i can access a video or even paper manul with instructions on where cps is at and how to replace it? Also is there any way to rebuild the old one or clean it off or anything like that? Car still starts just runs like crap replaced the fuel pump last week now on way home from work yesterday just started running like crap and the check engine light popped on and code says to replace crankshaft position sensor. So no clue where or how hard it will be to do? Any help much appreciated thx in advance
The crankshaft position sensor is basically a camshaft position sensor. Its underneath the driver side cam pulley so you need to remove everything required to get the timing belt and rear cam pulley off. I'm in the middle of a timing belt job and it was pretty easily to locate the CPS, it was melted down the side of my engine block.
SkyWil is offline  
Old 07-06-2019, 07:14 PM
  #3  
New Member
Thread Starter
 
Join Date: Jun 2019
Location: Pennsylvania
Age: 44
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
As was mine luckily i bought part online instead of threw one of the box stores that wanted over 300 bucks for it, it was shipped to my door for 94 and looked identical to the one that was pulled out. Unfortunately car is still running like crap when the sensor failed i guess it cause 2 coils to go bad because 4 and 6 are still coding for misfires and unfortunately again the coils are not the same as went into the 2000 tl cause i was able to get all 6 and plugs for about 160 bucks took me less then 45 mins to put them all in. The rl on other hand cheapest i found so far was 54 a piece! Just want to get it back to running right it is sucking down gas like there's a whole in the tank lol
Richard J. Barlow is offline  
Old 07-06-2019, 11:47 PM
  #4  
Registered Member
 
Join Date: Jun 2019
Age: 20
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Richard J. Barlow View Post
As was mine luckily i bought part online instead of threw one of the box stores that wanted over 300 bucks for it, it was shipped to my door for 94 and looked identical to the one that was pulled out. Unfortunately car is still running like crap when the sensor failed i guess it cause 2 coils to go bad because 4 and 6 are still coding for misfires and unfortunately again the coils are not the same as went into the 2000 tl cause i was able to get all 6 and plugs for about 160 bucks took me less then 45 mins to put them all in. The rl on other hand cheapest i found so far was 54 a piece! Just want to get it back to running right it is sucking down gas like there's a whole in the tank lol
It sounds like you are just shotgunning parts now. Coil packs and spark plugs are the last thing i would expect to go bad. Did you check to see if the EGR is plugged up? Before replacing the coil packs/plugs etc try swapping a misfiring cylinder that you believe to have a bad coil/plug with one that you know is good from another cylinder and see if it changes. That will at least tell you if its actually a bad coil/plug.
SkyWil is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
300K plus
1G TL Problems & Fixes
1
10-08-2012 09:23 PM
gian_18778
1G TL Problems & Fixes
9
09-05-2008 08:23 PM
tonyng704
First Generation TL (1996-1998)
2
06-16-2008 03:33 PM
tonyng704
First Generation TL (1996-1998)
1
06-10-2008 11:38 PM
amsmk
Second Generation TL (1999-2003)
1
11-05-2006 10:57 PM


Thread Tools
Search this Thread
Quick Reply: 2000 crankshaft position sensor


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.