High mileage or a lemon? - AcuraZine - Acura Enthusiast Community

Notices

High mileage or a lemon?

 
Old 03-13-2019, 09:53 PM
  #1  
New Member
Thread Starter
 
Join Date: Mar 2019
Age: 30
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
High mileage or a lemon?

My RDX is at 207k, and every few weeks I can almost guarantee something is going to fail. This time my sh-awd, vsa, and abs lights came on while I was driving up a mountain, in traffic, during a blizzard. So I checked the forum for some answers. Now I might have looked in the right place but what I can tell you is that itís not the main fuse or fuse 12 related with the horn and brake lights not working. My battery is a half a year old and my alternator is a year in a half old. I changed the vtec oil pressure solenoid in November. And I just went to autozone and nothing came up on their code reader and they couldnít clear it. (I know itís not a real scan tool). It might be the egr, I just want someone to confirm my suspicions. Please and thank you for any help.
Chirado_struggles is offline  
Old 03-14-2019, 12:32 PM
  #2  
Registered Member
 
Join Date: Feb 2014
Posts: 1,021
Thanked 124 Times in 107 Posts
Different codes may trigger the same lights. You definitely need to get codes pulled to help with the diagnosis. Anything someone says before that is just guessing.
Tomtwtwtw is offline  
Old 03-14-2019, 02:33 PM
  #3  
Registered Member
 
Poveiro's Avatar
 
Join Date: Nov 2012
Location: Saint …douard
Posts: 108
Thanked 0 Times in 0 Posts
get a cable (Vag com) and connect to your pc.
Poveiro is offline  
Old 03-14-2019, 04:27 PM
  #4  
Moderator
iTrader: (1)
 
justnspace's Avatar
 
Join Date: Feb 2010
Posts: 79,832
Thanked 13,840 Times in 10,282 Posts
lol that's not the definition of a lemon...

cars are machines, machines have moving parts. moving parts fail. which does not make a lemon.
you're going to have to troubleshoot to figure out the issue.

Have you checked all wheel and ABS sensors in the wheel well?
Do you have ALL Wheel Drive? or did it disable the SHAWD all together?
if you suspect the EGR (highly doubtful) check it! Remove it to see if it has carbon debris making the valve stuck open.

Last edited by justnspace; 03-14-2019 at 04:31 PM.
justnspace is offline  
Old 03-16-2019, 12:28 AM
  #5  
Carmine S.
 
CSmoney28's Avatar
 
Join Date: Nov 2013
Location: New York
Posts: 609
Thanked 31 Times in 28 Posts
I agree, if the fuses are good you need to check your sensors.

Also make sure you go to a good car wash, regularly get underbody washes!
CSmoney28 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
affiliated402
Fourth Generation TL (2009-2014)
9
10-04-2018 03:06 PM
Megatron
Second Generation RL (2005-2012)
8
10-06-2010 10:50 AM
GrandeInter10
Second Generation CL Discussion (2000-2003)
7
02-25-2008 10:52 AM
BobbyDangler
2G CL Transmission Recall Q & A
14
11-03-2004 08:07 PM
rurofan
Second Generation CL Discussion (2000-2003)
5
01-16-2001 01:25 AM


Thread Tools
Search this Thread
Quick Reply: High mileage or a lemon?


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.