Notices

My 98 CL 2.3 5mt Build Thread

 
Old 05-21-2018, 04:45 PM
  #1  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 37
Posts: 5
Thanked 0 Times in 0 Posts
Cool My 98 CL 2.3 5mt Build Thread

My girlfriend and I just bought a 98 CL because the price was right and we were in desperate need of a car. I ended up only paying $800. What usually happens when a car guy gets a daily driver and sees potential? You guessed it. UPGRADES!! I will be posting some pictures later today. I was able to get it cheap because the brakes need work, check engine light is on, and the ABS light is on. So we have owned the car now for about 2 weeks and from what I can tell, whoever worked on it either did a piss poor job on putting things on correctly or just needs to leave repairs to people that actually know what there doing. There was a vibration in the front end that I thought was the driver side axle going bad but after making my girl pull over on the interstate and actually getting ready to have an axle brought to me and changing it there, I discovered 3 out of 4 of the lug nuts were loose! Ever had a tire come off because someone didnt tighten the lugs up? I have and after that shit nobody touches my cars but my dad. So I tightened everything on the car and no more vibration. It needs tie rod bushings, swaybar bushings, anti-roll bar bushings, has an oil leak(small but it got my attention), the exhaust is broke on the back side of the cat, its got dings but not too bad, some rust on the rear quarter but all hondas/acuras get that there, the rear pasenger side brake needs a rotor and it sometimes grinds 4th and always 5th. He said he put a new clutch in it and aside from some adjustment for my driving its good. Oh yeah. I went to check the air pressure in the tires because I thought that could be what was making it pull to the right. The tires say 36 psi and 2 of the tires had double that. Shit, 1 had over 100! And it was missing about 5 fuses. Ive fixed the tire pressure and put the correct fuses where they need to go. It says 278k on the speedo but the guy said the owner before him put a new motor in it. That was just a polite way to say someone drove the shit out of it. Ive been under the hoods of cars since I was 9 years old and I'll be 37 next month so I'm only a noob to the CL. The wishbone suspension is just like my old 91 CB7 accord. The good is it does run good and handles corners pretty good, When my girl isnt with me I'll push it a little to its limits. Planned upgrades that are coming within the next 30-60 days is a double din multi media player, poly bushings, front and back sway bars, a spoiler I found at pull and pay from a 99 CL 3.0, a home made CAI, battery relocation to trunk, and if I can pull it off without my ol lady bitching about what I'm spending I'm gonna try and get the camber kit(not sure which one I want to use yet), coilovers and have it ready for 18s 235/35. My goal is to have this car ready to handle how I drive and I can drive. I'm teaching my girl the basics of road coursing and if it can handle me its safe for her. I'm new here and will check the fourms but I;d like to know if anyone has converted to 5 lug. Also, has anyone had to roll the fenders for 18s? I did on my accord so I thought I'd ask. And lastly, Ive never had a vtech car so how do I know if the vtech is working correctly? does it pull harder or something at the higher rpm? Im a one with the car kinda driver so I go off feel. Im looking forward to this bild so drop advice, do's and donts, ect. Im going to post pics in an hour or so
Murda1 is offline  
Old 05-21-2018, 09:36 PM
  #2  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 37
Posts: 5
Thanked 0 Times in 0 Posts
Pics




hood insert has to go



put this water shield on yesterday


trailer hitch on an acura???? ok


decent sized scratch, very fixable though


typical rust spot on both sides


im thinking carbon fiber trim instead




got new fake wood grain. adding it tonight
Im still figuring out how to add all my attachments. I tried on my laptop and something went wrong. So even if i have to post 1 by 1 they'll get here
Murda1 is offline  
Old 05-21-2018, 09:51 PM
  #3  
Registered Member
Thread Starter
 
Join Date: May 2018
Age: 37
Posts: 5
Thanked 0 Times in 0 Posts
Check engine light/

So after i vacuumed the car before taking those pictures I got out the scanner and the only code it pulled was for the o2 sensor. I figure since i gotta fix the exhaust anyways I'll do both at once. Still deciding on what to do with the exhaust but I want to try and get a diffetent sound then the other imports in my area. Decisions, decisions!
Murda1 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Timmy18
Car Talk
125
03-08-2019 06:21 AM
732xghost
CL Street Encounters
13
07-16-2006 05:48 PM
PeterUbers
Ramblings
12
10-21-2002 08:20 AM


Thread Tools
Search this Thread
Quick Reply: My 98 CL 2.3 5mt Build Thread


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.