Support Question iOS incompatibilities with AZine - AcuraZine - Acura Enthusiast Community



iOS incompatibilities with AZine

Reply
 
 
 
Thread Tools Search this Thread
Old 01-05-2018, 04:51 PM   #1
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
iOS incompatibilities with AZine

There is a serious issue with the post reply text box on AZine and iOS that has been bothering me since iOS10. At first I thought it was just my phone or safari. However, it has progressively gotten worse with every iOS update, I have used a completely new iPhone, using Google Chrome app shows the same issues, and no other online forum I can find behaves the same way. The only common denominator is AcuraZine and iOS 10+. Here are the symptoms I see on an iPhone using either Safari or Google Chrome and I think most of them are related to the auto-zoom feature invoked by using a text box in iOS:

Starting with iOS 10 through 11.1:
- Text box window does not track with cursor. Clicking on the text box places the cursor at the left margin and zooms in on that area. As you type, the words go off the right of the screen and out of view. Manually moving the window is the only way to follow the cursor.
- Typing in the text box pushes the view to the bottom of the text box window. Regardless of where the cursor is, the view will jump to the very last line of the text box once you start typing. For a new or short post with few lines, this is not an issue. However, once the lines exceed the height of the text box, the typing within the text box gets pushed up. If you want to edit the top of the text, you have to do so blindly. You CANNOT see what you are typing.

Starting with 11.1:
- Same issues ^^^ apply plus...
- Even with a single line of text, the window gets shifted up and cuts off the top half of the line you are typing on. Picture below.
- Return carriages placed between paragraphs in the text box get shifted to the bottom when the post is submitted and even edited. Also, return carriages within quotations cause the quote to get split between two quote boxes. (This could be a universal issue as I have seen it a couple times now.) Examples here:
Original post: https://acurazine.com/forums/kids%3B.../#post16157772
Quoted version with returns shifted to bottom of quote box: https://acurazine.com/forums/kids%3B.../#post16158988
Quotes getting split into multiple boxes (sorry about the R&P link): https://acurazine.com/forums/religio.../#post16158844

Cutting off the top half of the top line while typing:

oo7spy is offline   Reply With Quote
The Following User Says Thank You to oo7spy For This Useful Post:
Joecop67 (01-05-2018)
Old 01-05-2018, 05:14 PM   #2
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
Oh, and this is all on the desktop version of the site. I’ve never used the mobile one.
oo7spy is offline   Reply With Quote
Old 01-05-2018, 05:19 PM   #3
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
Thanks for providing this detailed breakdown of the issues you're seeing. We've been working to isolate and fix our editor's iOS-specific bugs over the past few months. In the coming weeks, we'll be rolling out an update that should allow for the editor to work correctly with more recent iOS updates. I'll post an update here once it's gone live.
IB Jason is online now   Reply With Quote
The Following User Says Thank You to IB Jason For This Useful Post:
oo7spy (01-05-2018)
Old 01-05-2018, 05:42 PM   #4
Registered Member
 
RDX10's Avatar
 
Join Date: Dec 2014
Posts: 3,922
Thanked 437 Times in 362 Posts
The problem with the text box sliding up and out of view is the most aggravating part of using acurazine on my phone. I literally stopped logging on for the past 4 months because I got fed up with it and I hardly go on a laptop/monitor so I have been avoiding the site. This problem has been occuring since before ios10 for me. On top of that, the space function is not working either, i.e if I try to break up my paragraphs into blocks they keep posting as one monster block of text vs splitting up. To say this issue is infuriating is putting it far too kindly.
RDX10 is offline   Reply With Quote
Old 01-08-2018, 12:06 PM   #5
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
oo7spy is offline   Reply With Quote
Old 01-08-2018, 12:47 PM   #6
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 31,891
Thanked 5,177 Times in 4,134 Posts
Can confirm similar issue Just tried using Chrome yesterday and there was some weird bug where the picture upload dialog wouldn't pop up. Had to use Safari and it did...
thoiboi is online now   Reply With Quote
Old 01-08-2018, 03:07 PM   #7
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
Quote:
Originally Posted by thoiboi View Post
Can confirm similar issue Just tried using Chrome yesterday and there was some weird bug where the picture upload dialog wouldn't pop up. Had to use Safari and it did...
Is this a frequent occurrence, or was that the first time you tried to open the image uploader and it didn't work?
IB Jason is online now   Reply With Quote
Old 01-08-2018, 03:20 PM   #8
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 31,891
Thanked 5,177 Times in 4,134 Posts
first time in a while, i know it's worked before but can't tell you when was the last time I used it on mobile (too much postwhoring to recollect properly)
thoiboi is online now   Reply With Quote
Old 01-08-2018, 05:41 PM   #9
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
Quote:
Originally Posted by thoiboi View Post
first time in a while, i know it's worked before but can't tell you when was the last time I used it on mobile (too much postwhoring to recollect properly)
Okay, thanks. I haven't been able to recreate the issue on my own device, but if you see it happen again, please let me know.
IB Jason is online now   Reply With Quote
Old 01-08-2018, 06:08 PM   #10
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 31,891
Thanked 5,177 Times in 4,134 Posts
Quote:
Originally Posted by IB Jason View Post
Okay, thanks. I haven't been able to recreate the issue on my own device, but if you see it happen again, please let me know.
Just tried it again right now and it's doing the thing Bond is describing in his OP


Google Chrome for iOS..
on Request Desktop Site FWIW
iOS 11.2
thoiboi is online now   Reply With Quote
Old 01-09-2018, 01:09 PM   #11
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
Ah, on desktop site. That's where I went wrong in my testing. Are you seeing the dark gray overlay appear when you press the button, but just not the uploader itself? Due to varying screen sizes and the fact that the desktop site is technically designed for larger screens, what occasionally happens is the uploader does not immediately center itself on the iPhone screen and instead goes where the "center" of a hypothetically wider screen would be. We try to minimize this from happening, but in the instances when it does, you should be able to drag your view over to the uploader and use it as normal.
IB Jason is online now   Reply With Quote
Old 01-09-2018, 01:22 PM   #12
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 31,891
Thanked 5,177 Times in 4,134 Posts
Quote:
Originally Posted by IB Jason View Post
Ah, on desktop site. That's where I went wrong in my testing. Are you seeing the dark gray overlay appear when you press the button, but just not the uploader itself? Due to varying screen sizes and the fact that the desktop site is technically designed for larger screens, what occasionally happens is the uploader does not immediately center itself on the iPhone screen and instead goes where the "center" of a hypothetically wider screen would be. We try to minimize this from happening, but in the instances when it does, you should be able to drag your view over to the uploader and use it as normal.
See I know that's the proper behavior and scrolled all around to look for it but it doesn't show. There's no dark grey overlay at all this time.
thoiboi is online now   Reply With Quote
Old 01-09-2018, 01:32 PM   #13
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
Yeah, photo upload won’t pop-up the window on iOS the past few days.
oo7spy is offline   Reply With Quote
Old 01-09-2018, 01:33 PM   #14
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
Something changed yesterday though. The window is no longer jumping to the bottom of the text box. The first line is still shifted up, being cut off, and the window doesn’t track with the cursor. But really long posts don’t push you down to the bottom anymore.


oo7spy is offline   Reply With Quote
Old 01-09-2018, 07:35 PM   #15
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
Thanks for working with me while I troubleshooted the photo uploader pop-up. It should be fixed with the coming update, as will some other editor behavior quirks.
IB Jason is online now   Reply With Quote
Old 01-10-2018, 01:14 AM   #16
The Third Ball
 
Sarlacc's Avatar
 
Join Date: Sep 2002
Location: Los Angeles, Ca
Age: 38
Posts: 45,770
Thanked 3,421 Times in 1,786 Posts
OK...never had an issue with this on Safari on macOS.

I was having the issue on Safari on iOS.

I haven’t seen the issue much on my iPhone where it was really bad.

BUT I just had it happen on my iPad.
Sarlacc is offline   Reply With Quote
Old 01-10-2018, 03:03 AM   #17
The Third Ball
 
Sarlacc's Avatar
 
Join Date: Sep 2002
Location: Los Angeles, Ca
Age: 38
Posts: 45,770
Thanked 3,421 Times in 1,786 Posts
Never mind. Just got it on my phone again.
Sarlacc is offline   Reply With Quote
Old 02-07-2018, 12:38 AM   #18
Senior Moderator
Thread Starter
 
oo7spy's Avatar
 
Join Date: Dec 2010
Location: Austin, TX
Posts: 21,453
Thanked 3,660 Times in 2,661 Posts
I’m nervous to call it a success, but something has changed, and it’s changed for the better! Nearly everything works as expected on iOS the past day. The one exemption is that the screen does not scroll with the words, but shit, now I can see what I’m writing!!!
oo7spy is offline   Reply With Quote
Old 02-07-2018, 12:49 AM   #19
Registered Member
 
RDX10's Avatar
 
Join Date: Dec 2014
Posts: 3,922
Thanked 437 Times in 362 Posts
Quote:
Originally Posted by oo7spy View Post
Iím nervous to call it a success, but something has changed, and itís changed for the better! Nearly everything works as expected on iOS the past day. The one exemption is that the screen does not scroll with the words, but shit, now I can see what Iím writing!!!
Itís been working perfectly for me as well the past 2-3 days. I donít want to jinx it though. I ca even reply to multiple quotes while seeing what I am writing!!
RDX10 is offline   Reply With Quote
Old 02-07-2018, 12:55 PM   #20
IB Staff
iTrader: (-1)
 
Join Date: Jun 2013
Age: 38
Posts: 186
Thanked 97 Times in 46 Posts
I'm glad to hear the editor is working better for you guys! We rolled out an update last week to address a lot of the bugs.

Regarding the screen/word scrolling, the editor "box" should have an independent scroll from the rest of the page. So if you tap the box and then start scrolling, it'll only scroll the words within the box versus if you tap anywhere else, it'll scroll the entirety of the page. Is that what you're experiencing, or is it behaving differently?
IB Jason is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTT: My Silver AZINE Stickers for Your Black AZINE Stickers civicdrivr Car Parts for Sale 6 05-04-2012 12:56 PM
Azine rocks! Thanks to all the Azine Greats! EagleEye Third Generation TL (2004-2008) 22 06-22-2011 01:22 PM
Cisco IOS Experts...Simple ACL Question thunder04 Ramblings 4 01-18-2010 02:49 PM
SP2 Incompatibilities Beelzebub Ramblings 2 08-19-2004 11:05 PM
Anybody know CISCO IOS? mcdanjw Ramblings 5 05-02-2002 01:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.