P1717 CEL along with D flashing light - AcuraZine - Acura Enthusiast Community

Notices

P1717 CEL along with D flashing light

Old 04-15-2014, 11:31 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
P1717 CEL along with D flashing light

I've had my TL for a little over 2 years now, with the first being fantastic followed by a trechorous one. About 2 months into gettin the car, I had gotten this p1717 code and the blinking D light when I thought I had tried to switch it into reverse, turned off the car and car is back to normal. I dont get this code for another year, but this time I was 100% sure it occurred right as I switched into reverse. Turned off the car, waited and turned it back on, but the CEL was still on it but no D light blinking. Ran some errands which included finding out the code was p1717 and the CEL came off on a random start up later on in the day. Code doesnt come back for about 2 months which was about a week ago and after switching to reverse to pull out of a spot, CEL comes on, D light blinking. Turn car off, wait a few, then back on, and CEL is still on. The p1717 code again! wtf! It has been coming on for me about once a day since it first started a week ago. It would then turn off about a half hour later and not come on til the next day. Around the same time, I feel the car being almost misfiring randomly whether the CEL is on or not (i feel that is either transmission or that a routine maintenance hasnt been done, specifically, spark plugs or something). I read online somewhere that 3rd and 4th gear pressure switches MIGHT be of some help but I wanted some other opinions. Thanks for your inputs!
ArAbiAnArAb is offline  
Old 04-15-2014, 11:44 PM
  #2  
Registered Member
iTrader: (1)
 
WolfgangVonBrutal's Avatar
 
Join Date: Jun 2013
Location: San Ramon, CA
Age: 27
Posts: 91
Thanks: 0
Thanked 14 Times in 13 Posts
As I recall, the flashing D light indicates a failure in the transmission range switch and the code most likely pertains to that, especially considering that the code pops when switching gears.
WolfgangVonBrutal is offline  
Old 04-15-2014, 11:46 PM
  #3  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
would the transmissio range switch include 3rd and 4th gear pressure switches and would require the other gear switches being changed as well?
ArAbiAnArAb is offline  
Old 04-16-2014, 01:16 AM
  #4  
Registered Member
iTrader: (1)
 
WolfgangVonBrutal's Avatar
 
Join Date: Jun 2013
Location: San Ramon, CA
Age: 27
Posts: 91
Thanks: 0
Thanked 14 Times in 13 Posts
Assuming that's what the problem is, the pressure switches have nothing to do with it.

Follow the steps outlined in posts #8 and #9 of this thread:

https://acurazine.com/forums/3g-tl-problems-fixes-114/tranny-problems-d-indacator-flashing-848418/

If your results show a failure in the transmission range switch, then follow the instructions in this thread to replace it:

https://acurazine.com/forums/third-generation-tl-2004-2008-93/c-037-diy-gear-position-sensor-replacement-aka-transmission-range-switch-892223/
WolfgangVonBrutal is offline  
The Following User Says Thank You to WolfgangVonBrutal For This Useful Post:
ArAbiAnArAb (04-16-2014)
Old 04-16-2014, 09:22 AM
  #5  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
I'm gonna check that out, but do u think the misfiring is due to the spark plugs? They haven't been done since I've gotten the car
ArAbiAnArAb is offline  
Old 04-16-2014, 10:51 AM
  #6  
Here I come!
 
Houston's Avatar
 
Join Date: Jan 2008
Location: H-Town,TX.
Posts: 383
Thanked 61 Times in 41 Posts
No, not the spark plugs, but it could definitely be the Neutral Safety Switch / Range Sensor.
Houston is offline  
The Following User Says Thank You to Houston For This Useful Post:
ArAbiAnArAb (04-16-2014)
Old 04-16-2014, 11:10 AM
  #7  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
I'm gonna do the test thing that Wolfgang had pointed me to later on tonight when I get a chance...I was thinking it has something to do with a certain switch...I'll find out for sure later tonight, thank you guys
ArAbiAnArAb is offline  
Old 04-16-2014, 04:21 PM
  #8  
Registered Member
iTrader: (1)
 
WolfgangVonBrutal's Avatar
 
Join Date: Jun 2013
Location: San Ramon, CA
Age: 27
Posts: 91
Thanks: 0
Thanked 14 Times in 13 Posts
Please let us know what you figure out! I'm curious what the outcome will be, and it will help me out if my car ever has similar symptoms haha!
WolfgangVonBrutal is offline  
Old 04-16-2014, 06:52 PM
  #9  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
woflgang, i just did the test and these are my results

D light blinking: 6 long and 2 short (code 62)

CEL blinking: 16 long and 5 short (code165?!)

they arent on that post you referred to me earlier..gonna do some more researching now
ArAbiAnArAb is offline  
Old 04-16-2014, 07:58 PM
  #10  
Registered Member
Thread Starter
 
Join Date: Aug 2012
Posts: 80
Thanked 1 Time in 1 Post
just ran the test again and I got the same exact reading?? i cant seem to find what the codes mean anywhere..im thinking of getting my 3rd and 4th gear pressure switches done...regardless if it will fix this problem, its still necessary to do
ArAbiAnArAb is offline  
Old 10-22-2014, 11:22 PM
  #11  
2007 TL
 
tj19855's Avatar
 
Join Date: May 2009
Location: Houston, TX
Age: 33
Posts: 125
Thanks: 0
Thanked 3 Times in 3 Posts
This second time this has happened

http://youtu.be/CA0o82iCM_M

See video

Did you ever get this fixed? This just happened to me today. 07 TL 110K
tj19855 is offline  
Old 07-10-2015, 05:53 PM
  #12  
Registered Member
 
Join Date: Jul 2014
Posts: 67
Thanked 5 Times in 5 Posts
Originally Posted by WolfgangVonBrutal View Post
Assuming that's what the problem is, the pressure switches have nothing to do with it.

Follow the steps outlined in posts #8 and #9 of this thread:

Tranny Problems D indacator flashing?? - AcuraZine Community

If your results show a failure in the transmission range switch, then follow the instructions in this thread to replace it:

DIY: Gear Position Sensor Replacement (aka "transmission range switch") - AcuraZine Community
Does anybody know if this will fit an 07 transmission? The link shows it's for an 05 TL, and I know the transmission in the 07 is slightly different!
TheEntrepreneur is offline  
Old 12-12-2015, 09:47 AM
  #13  
New Member
 
Join Date: Dec 2015
Age: 98
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2007 Acura MDX Transmission Codes

I just shorted the 4 and 9 pins of OBD Port and the dash display gave me two numbers: 17 & 38 for my 07 Acura MDX. These codes do not match with the codes posted on the above posts. I have since ordered a repair manual to check what those codes mean.

I am hoping it's the same sensor, but let's see ..
tj007 is offline  
Old 10-04-2016, 04:51 PM
  #14  
Registered Member
 
Join Date: Mar 2010
Age: 38
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by ArAbiAnArAb View Post
woflgang, i just did the test and these are my results

D light blinking: 6 long and 2 short (code 62)

CEL blinking: 16 long and 5 short (code165?!)

they arent on that post you referred to me earlier..gonna do some more researching now
Sorry to bump such an old thread but I have the same exact issue as you and my D light blinks indicate code 62 as well. CEL doesn't blink but the code I pulled was P1717 as well.

Did you ever fix this issue or figure out what the cause was?
XGaSpAcHo is offline  
Old 10-03-2018, 07:50 PM
  #15  
New Member
 
Join Date: Oct 2018
Age: 36
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Neutral Safety Switch Issue

I know this is an old threat BUT I had to post my experience. I drive a 2008 Acura TL base w/navi. Started getting codes on my navi screen P1717 being one of them amongst others plus engine light was on but wld then go off until I put it in reverse. I took it to the Acura dealer and they said the tranny is failing and wanted $6K for a REBUILT tranny (ha! yeah right) well I came on here and read some of the threads and was confident it was the neutral safety switch. Ordered one from Acura Parts Warehouse paid like $98 , shipping was fast and my uncle just put it on and it cleared out all of the codes on my navi screen. Acura dealer is ridiculous. I even told the guy what it could be he stated "it is possible but more than likely you need a new transmission".

The car was driving fine except for when I put it in reverse the D would blink and it wldnt start at times unless I put it in neutral. I am a female so it is sad to say that they do try to get over on you. Glad I wasnt a statistic. I Love this forum! Thank guys!
dmack82 is offline  
The Following User Says Thank You to dmack82 For This Useful Post:
Joecop67 (10-04-2018)
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RLX-Sport Hybrid
Third Generation RLX (2013+)
43
12-16-2015 10:45 PM
ibGTV
First Generation CL Discussion (1997-1999)
14
09-28-2015 03:40 AM
Greengecko
3G TL Audio, Bluetooth, Electronics & Navigation
4
09-16-2015 08:19 PM
HeloDown
3G TL Problems & Fixes
4
09-08-2015 06:51 PM
darknite123
Acura RSX Discussion
0
08-30-2015 03:00 PM


Thread Tools
Search this Thread
Quick Reply: P1717 CEL along with D flashing light


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.