Notices

Bought used Comptech Supercharger!

 
Old 03-13-2018, 08:41 AM
  #321  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Thatís ridiculous,

I need only the alt bracket aswell. Did you give the shop a template, or just bring in the S/C unit and have them match it?

You mentioned that you used two radiator hoses and a coupling. Where did you buy them?

I think going your route will save time and money.

Would you be so kind to send me a few pics of your alt mount and radiator piping?
Saving4aTL is online now  
Old 03-13-2018, 09:19 AM
  #322  
Registered Member
 
Join Date: Aug 2003
Location: S. Florida
Posts: 2,560
Received 490 Likes on 423 Posts
Originally Posted by Saving4aTL View Post
Thatís ridiculous,

I need only the alt bracket aswell. Did you give the shop a template, or just bring in the S/C unit and have them match it?

You mentioned that you used two radiator hoses and a coupling. Where did you buy them?

I think going your route will save time and money.

Would you be so kind to send me a few pics of your alt mount and radiator piping?
Saving4aTL, I believe you can get an idea of what the alt mount and radiator piping look like by looking at the link below for the S/C'er install directions. On the first page with the pictures, I think the part above the 'battery tie down bracket' is the Alt mount and the radiator hose is there as well. In addition, Step # 6 on the install directions shows a part of the alt mount as well.

http://www.ct-engineering.com/Portal...-SCKit2009.pdf
zeta is offline  
Old 03-13-2018, 09:36 PM
  #323  
Registered Member
iTrader: (1)
 
Duronn's Avatar
 
Join Date: Apr 2010
Location: Dallas, Tx
Age: 36
Posts: 191
Received 25 Likes on 21 Posts
I believe there is already a bracket where the alternator is, I had a shop weld a piece of metal to it to lengthen it as well as drill & tap it. I also brought them my SC to make sure for correct fitment.


For the radiator, I just used an aluminum conduit to form & shape where I needed the radiator to go. Then I went to a few auto stores and looked at few radiator hoses & compared which 2 hoses came close to what I needed and spliced them together.
Duronn is offline  
Old 03-16-2018, 07:11 AM
  #324  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Would the s/c unit be ok if I fitted it on without that bracket? As long as the belt isnít attached I donít see an issue. This way the shop can get the exact length without me doing work I thier parking lot(Vatozone style).
Saving4aTL is online now  
Old 03-16-2018, 09:18 PM
  #325  
Registered Member
 
Join Date: Aug 2003
Location: S. Florida
Posts: 2,560
Received 490 Likes on 423 Posts
Originally Posted by Saving4aTL View Post
Would the s/c unit be ok if I fitted it on without that bracket? As long as the belt isnít attached I donít see an issue. This way the shop can get the exact length without me doing work I thier parking lot(Vatozone style).
Did you plan on driving the car over to the shop or tow it over?
zeta is offline  
Old 03-29-2018, 10:29 AM
  #326  
Registered Member
 
Join Date: Feb 2003
Location: Ontario Canada
Age: 37
Posts: 314
Received 55 Likes on 35 Posts
Nice build ! Following the build ! I bought a 4g SC for my 05 RL and will be installing it in two months ! Unfortunate I have to use AEM FIC as the RL has SHAWD

may be selling the coolant bottle and battery tray and battery cables
JDMCRX is offline  
Old 04-16-2018, 03:53 PM
  #327  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
updates?
mrlunecy is offline  
Old 04-16-2018, 04:34 PM
  #328  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
I've been quietly catching up on this thread for some time now, and I hope everything is wrapping up nicely for the OP.
I have been pretty dormant on AZine for a long time, but usually listen in on some topics, or search for solutions/ideas, but I still have my SC'd TL

Here's the scoop of my experience thus far:
06 5AT with plenty of bolt-ons, comptech SC with Hondata reflash
Boosted (approx. 4psi) since 10k, currently @ 80k miles.
Never had engine/SC issues
HOWEVER, the trans has been slowly degrading in performance over the last few years; Lumpy/surging shifts at highway speeds (during overtaking) and sluggish shifts between 1st and 2nd (clutch pack slipping). Plenty of evidence in the form of wear material found in every ATF change. Also repeating P0741 torque conv clutch sol perf or stuck off code.
had a local trans shop confirm the trans needed rebuilding. Both the shop rep and myself thought for sure the increase in power would be reason why the trans was failing, but after they rebuilt it, the shop believes it was due to "degeneration of clutch material" most likely due to the fluid or contamination of the fluid. I was running nothing but Royal Purple ATF since 10k miles and went back to stock the last few thousand miles when the trans was getting worse. I believe the ATF was the culprit and needless to say, will not run anything other that stock ATF anymore. However, I haven't heard of any 5AT guys run into any issues with redline.
In summary, the shop did a great job in rebuilding my trans and it runs like new again! (Boston Transmissions, Pico Rivera).

TUNNING,
Main reason why I'm here: As I said, I got my car tuned by Hondata through Autowave in Huntington Beach, shortly after SC'ing, (around 2007/08, not sure). The tune was pretty experimental/preliminary IMO, since the demand just isn't there and Hondata's Doug MacMillan was working with very few TLs (mostly one 6MT) at the time. I'm not sure if he officially released any tune for the TL. I have been out of the loop for a while and curious to know if there are any other tuning options out there for the small supercharged community. I've been pretty much done modding my car for a while now, (just enjoying it!), but I wouldn't mind some fine-tuning on the programming side.

Last edited by mrlunecy; 04-16-2018 at 04:47 PM.
mrlunecy is offline  
Old 04-16-2018, 11:48 PM
  #329  
Registered Member
iTrader: (1)
 
Duronn's Avatar
 
Join Date: Apr 2010
Location: Dallas, Tx
Age: 36
Posts: 191
Received 25 Likes on 21 Posts
Vittuned.com did my tuning, and I believe theres also a member who tunes as well: DomGSR-T, and I'm sure theres other who I don't know of as well.
Duronn is offline  
Old 04-17-2018, 05:37 PM
  #330  
2005 SSM 6MT
iTrader: (8)
 
EvilVirus's Avatar
 
Join Date: Apr 2011
Location: Houston
Posts: 4,121
Received 1,072 Likes on 853 Posts
CT Engineering recommends the use of Redline High Temp ATF Fluid
EvilVirus is offline  
Old 04-25-2018, 10:43 PM
  #331  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Hey Fellas,

Ive got everything ready to go for the install(even redline high-temp ATF), except for the custom radiator hose and the s/c to alternator mount that Iím forced to build. Comptech does not consider to reply to even thier vendors these days. I canceled my order for he two parts after waiting on CT engineering since December 2017.

beem very busy lately, I still pop in from time to time. Going to be installing the S/C in he next 12 weeks.

Saving4aTL is online now  
Old 04-26-2018, 11:44 AM
  #332  
2005 SSM 6MT
iTrader: (8)
 
EvilVirus's Avatar
 
Join Date: Apr 2011
Location: Houston
Posts: 4,121
Received 1,072 Likes on 853 Posts
So what will you do about heat soak?
EvilVirus is offline  
Old 04-28-2018, 01:32 AM
  #333  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
As far as the tranny? I wonít be romping on it much, so heatsoak wonít be an issue for me.
Saving4aTL is online now  
Old 04-30-2018, 05:32 PM
  #334  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
I have a trans fluid temp gauge on mine, and I never seen any abnormally high temps during regular DD, a bit of romping, or even when I took it autocrossing on a warm day with sessions that lasted just under a minute. I do have a B&M trans cooler, though. But not sure how much it helps.
mrlunecy is offline  
Old 05-02-2018, 10:30 PM
  #335  
Chapter Leader (NY/NJ)
iTrader: (10)
 
InFaMouSLink's Avatar
 
Join Date: Oct 2008
Location: Rahway, NJ
Age: 34
Posts: 2,572
Received 173 Likes on 137 Posts
Originally Posted by Saving4aTL View Post
Hey Fellas,

Ive got everything ready to go for the install(even redline high-temp ATF), except for the custom radiator hose and the s/c to alternator mount that I’m forced to build. Comptech does not consider to reply to even thier vendors these days. I canceled my order for he two parts after waiting on CT engineering since December 2017.

beem very busy lately, I still pop in from time to time. Going to be installing the S/C in he next 12 weeks.


12 weeks???

Reading up on my s/c leak from the mount near the EGR brought me here. Haven't been on AZ in what seems forever. Honestly didn't read everything but hope all goes well. I see Rockstar,ThisAznboi, and Gus still here cheering you on.

Last edited by InFaMouSLink; 05-02-2018 at 10:34 PM.
InFaMouSLink is offline  
Old 05-04-2018, 08:28 PM
  #336  
Registered Member
 
pohljm's Avatar
 
Join Date: Sep 2006
Location: San Diego, CA
Posts: 4,745
Received 471 Likes on 378 Posts
Originally Posted by Saving4aTL View Post
As far as the tranny? I wonít be romping on it much, so heatsoak wonít be an issue for me.
Not even sure what to say here...............I just thought this statement needed to be memorialized in some way
pohljm is offline  
Old 05-05-2018, 10:14 AM
  #337  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Just a bit of the olí in-out, in-out.
Saving4aTL is online now  
Old 05-07-2018, 11:08 AM
  #338  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
Originally Posted by InFaMouSLink View Post
12 weeks???

Reading up on my s/c leak from the mount near the EGR brought me here. Haven't been on AZ in what seems forever. Honestly didn't read everything but hope all goes well. I see Rockstar,ThisAznboi, and Gus still here cheering you on.
mine leaked once from the same spot once after re-installing the SC. Gotta pull the unit back out and check for a pinched or damaged o-ring on the camshaft mounting point. Have to lube it with oil and be very careful putting it back on. I have a Honda part number for the o-ring if I can dig it up.
mrlunecy is offline  
The following users liked this post:
InFaMouSLink (05-08-2018)
Old 05-08-2018, 06:31 PM
  #339  
Chapter Leader (NY/NJ)
iTrader: (10)
 
InFaMouSLink's Avatar
 
Join Date: Oct 2008
Location: Rahway, NJ
Age: 34
Posts: 2,572
Received 173 Likes on 137 Posts
Originally Posted by mrlunecy View Post
mine leaked once from the same spot once after re-installing the SC. Gotta pull the unit back out and check for a pinched or damaged o-ring on the camshaft mounting point. Have to lube it with oil and be very careful putting it back on. I have a Honda part number for the o-ring if I can dig it up.
I replaced the O-Ring when I first installed it. Its been years so i'll just replace it. I have the o-ring part number somewhere. it probably dried up for lack of car-use lol.
Thanks.
InFaMouSLink is offline  
Old 05-17-2018, 04:55 PM
  #340  
2005 SSM 6MT
iTrader: (8)
 
EvilVirus's Avatar
 
Join Date: Apr 2011
Location: Houston
Posts: 4,121
Received 1,072 Likes on 853 Posts
Updates OP?
EvilVirus is offline  
Old 05-24-2018, 07:48 AM
  #341  
New Member
 
Join Date: May 2018
Age: 37
Posts: 2
Likes: 0
Received 4 Likes on 2 Posts
In the same boat

I am also installing a used CT charger and am very close to cranking. Hoping someone can help with a couple questions.

-is wiring the ACM the same for 07-08 as it is for 06? Install manual only shows 04-05 and 06.

-my ACM appears to have been wired for a diff application as there is no green and white/green wire open to solder. Instead I have orange, white/orange, black/white, white/black. These four wires are outside the harness and appear to be needing to be connected...??? Not noted on install manual.







-third, what is avg boost psi on regular pulley? Maybe this will give me an idea of how worn out the used charger is?

pics included 07 tls 6spd
ChrisCansler is offline  
The following 2 users liked this post by ChrisCansler:
EvilVirus (06-01-2018), rockstar143 (05-27-2018)
Old 05-26-2018, 01:26 PM
  #342  
Registered Member
 
Join Date: May 2018
Location: NJ/NY
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Always wanted to do a supercharger install on the TL. Had over 200k on the stock motor and still pulled strong.
RIP06TL is offline  
Old 05-30-2018, 01:45 AM
  #343  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
Originally Posted by ChrisCansler View Post
I am also installing a used CT charger and am very close to cranking. Hoping someone can help with a couple questions.

-third, what is avg boost psi on regular pulley? Maybe this will give me an idea of how worn out the used charger is?

pics included 07 tls 6spd
Stock boost pulley yields around 6 psi with stock exhaust, around 4 psi with aftermarket exhaust, j-pipe.
Mine peaks at 3.5 psi with catback exhaust, j-pipe, high flow cats and 3rd cat delete. I have 80k miles on the blower. High boost pulley from comptech is around 2 psi over stock, but I don't dare try it. Doesn't sound like much, but many good engines have been lost in that realm.
mrlunecy is offline  
Old 05-30-2018, 01:54 AM
  #344  
312 HP 271 TQ Dynapack
iTrader: (1)
 
mrlunecy's Avatar
 
Join Date: Jun 2004
Location: SoCal 562
Age: 37
Posts: 446
Received 6 Likes on 6 Posts
BTW, for a 3.5 liter, you should expect to see even lower boost numbers than what I previously mentioned.
mrlunecy is offline  
Old 05-30-2018, 10:43 PM
  #345  
New Member
 
Join Date: May 2018
Age: 37
Posts: 2
Likes: 0
Received 4 Likes on 2 Posts
Update

after 2 days driving on SC with ACM

2007 TL Type S manual 6 speed

power is noticeable and linear from 2500 - 5500

no boost gauge yet, no wideband yet so I am concerned but it seems to be running well

some notables, since I have an 07 the last documented instructions for ACM were from 2006. Currently I have the orange/wht and wht/orange wires from ACM hooked to map on ecu, green/red. I did not connect black/wht and wht/blk to knock based on a prior acurazine post stating not necessary. My jumper harness did not plug in (either male or female) and required modification. Minimal 2 min mod to trim plastic to allow plug in. I believe my ACM was an earlier 04-05.

needless to say I was concerned about the electronics. Car fires up no codes

still plan to add hondata data and boost gauge and wideband this week for piece of mind but in the meantime itís fun as hell to drive. 3rd and 4th gear on hwy are awesome

happy to get the used kit going and it was worth it




ChrisCansler is offline  
The following 2 users liked this post by ChrisCansler:
EvilVirus (06-01-2018), teh CL (06-01-2018)
Old 05-31-2018, 10:56 PM
  #346  
Registered Member
iTrader: (1)
 
Duronn's Avatar
 
Join Date: Apr 2010
Location: Dallas, Tx
Age: 36
Posts: 191
Received 25 Likes on 21 Posts
Time to add methanol
Duronn is offline  
Old 06-01-2018, 06:52 AM
  #347  
Moderator
Chapter Leader (South Florida Region)
iTrader: (6)
 
rockstar143's Avatar
 
Join Date: Sep 2008
Posts: 66,851
Received 14,801 Likes on 11,020 Posts
time to change my panties...
rockstar143 is offline  
Old 06-04-2018, 11:42 AM
  #348  
Registered Member
 
twokexlv6coupe's Avatar
 
Join Date: Jul 2017
Age: 32
Posts: 78
Received 8 Likes on 7 Posts
Mother of God that's sexual
twokexlv6coupe is offline  
Old 06-17-2018, 12:10 AM
  #349  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts

Sorry for the long wait fellas. I pul on the loctite today and put the two parts of the supercharger together. The loctite will dry tonight and Iíll put 180ml of s/c oil in it.

next weekend Iím having my timing belt changed for the first time. Itís at 158k miles now :o Iíve got a gates kit that includes the water pump. During that time Iím going to fab up the bracket that goes on the neck by the pulley.

I got into an accident a month ago. A large lifted truck towing an even larger boat hit me at low speed. I need a new trunk and taillight, aswell as have mascot pull the metal some before they fix all the other songs before they repaint her.
Saving4aTL is online now  
Old 06-17-2018, 12:15 AM
  #350  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts










Saving4aTL is online now  
The following 2 users liked this post by Saving4aTL:
EvilVirus (06-19-2018), zeta (06-17-2018)
Old 06-30-2018, 10:19 PM
  #351  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Today:
- I changed the spark plugs for the Denso IK22 1 step colder plugs.
- 3x3 drain and fill with REDLINE high temp ATF
- Repositioned the wires next to the S/C pulley onthe engine bay
- Replaced motor oil/filter
- Replaced upper tranny mount and side engine mount
- Trimmed radiator fan shroud to make room for S/C
- Cleaned the engine bay

Anything else I should do before Supercharger goes in tomorrow?

for the pulley/alternator mount, Iím having one fabbed up on Monday.

Last edited by Saving4aTL; 06-30-2018 at 10:24 PM.
Saving4aTL is online now  
Old 06-30-2018, 10:26 PM
  #352  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts



Saving4aTL is online now  
Old 06-30-2018, 11:18 PM
  #353  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Racing against both of my brothers at Portland International Raceway. I wanted to get a feel for the car pre-Supercharger.






Saving4aTL is online now  
Old 06-30-2018, 11:24 PM
  #354  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Saving4aTL is online now  
Old 07-01-2018, 12:50 AM
  #355  
Registered Member
iTrader: (1)
 
Duronn's Avatar
 
Join Date: Apr 2010
Location: Dallas, Tx
Age: 36
Posts: 191
Received 25 Likes on 21 Posts
where you gonna relocate your radiator fluid overflow tank?
Duronn is offline  
Old 07-01-2018, 01:34 AM
  #356  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
Good question, I was thinking of mounting it in the area where the Comptech overflow tank would be. Any suggestions?
Saving4aTL is online now  
Old 07-01-2018, 02:19 AM
  #357  
Registered Member
iTrader: (1)
 
Duronn's Avatar
 
Join Date: Apr 2010
Location: Dallas, Tx
Age: 36
Posts: 191
Received 25 Likes on 21 Posts
On the frame?
Duronn is offline  
Old 07-01-2018, 08:24 AM
  #358  
Rotrex + Comptech TLer
Thread Starter
 
Saving4aTL's Avatar
 
Join Date: May 2007
Posts: 1,026
Received 108 Likes on 96 Posts
I was thinking to secure it to the frame somehow. Something that looks nice and functions well.
Saving4aTL is online now  
Old 07-01-2018, 08:35 AM
  #359  
Registered Member
 
Join Date: Aug 2003
Location: S. Florida
Posts: 2,560
Received 490 Likes on 423 Posts
Originally Posted by Saving4aTL View Post
Today:
- I changed the spark plugs for the Denso IK22 1 step colder plugs.
- 3x3 drain and fill with REDLINE high temp ATF
- Repositioned the wires next to the S/C pulley onthe engine bay
- Replaced motor oil/filter
- Replaced upper tranny mount and side engine mount
- Trimmed radiator fan shroud to make room for S/C
- Cleaned the engine bay

Anything else I should do before Supercharger goes in tomorrow?

for the pulley/alternator mount, Iím having one fabbed up on Monday.
Not sure if you somehow already addressed this; however, did you modify the fuel pressure regulator? Step #16 on the link below:

http://www.ct-engineering.com/Portal...-SCKit2009.pdf

In addition, don't forget to take pics of how your fabricator manages to innovate the 'pulley/alternator mount'.

Good Luck!
zeta is offline  
Old 07-01-2018, 08:38 PM
  #360  
Registered Member
 
Join Date: Feb 2003
Location: Ontario Canada
Age: 37
Posts: 314
Received 55 Likes on 35 Posts
Take some pics of the install ! I will be doing my RL install soon lol
JDMCRX is offline  

Thread Tools
Search this Thread
Quick Reply: Bought used Comptech Supercharger!


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.