Check charging system flashing - AcuraZine - Acura Enthusiast Community

Notices

Check charging system flashing

 
Old 02-03-2019, 04:52 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Aug 2013
Location: Orlando, FL
Age: 36
Posts: 534
Thanked 76 Times in 68 Posts
Check charging system flashing

Good afternoon all,

So unfortunate turn of events this weekend. MDX died on the Mrs while we were on out of town. I ended up getting a new battery and a new alternator from AutoZone that was remanufactured (only one available) to get back home.

Spent the next 6 hours installing it with my dad and it was a PITA. All seemed well until this morning. As I started driving, the check charging system light would flash during braking. I went back to Autozone to return the core and test out the system. Both battery and alternator tested good/pass. With that, I was able to make the 3 hour drive home, but still have this check charging system light flashing.

Any tips?
nats007 is offline  
Old 02-03-2019, 07:02 PM
  #2  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,038
Thanked 5,718 Times in 4,584 Posts
Originally Posted by nats007 View Post
Good afternoon all,

So unfortunate turn of events this weekend. MDX died on the Mrs while we were on out of town. I ended up getting a new battery and a new alternator from AutoZone that was remanufactured (only one available) to get back home.

Spent the next 6 hours installing it with my dad and it was a PITA. All seemed well until this morning. As I started driving, the check charging system light would flash during braking. I went back to Autozone to return the core and test out the system. Both battery and alternator tested good/pass. With that, I was able to make the 3 hour drive home, but still have this check charging system light flashing.

Any tips?

Bad tension on belt
thoiboi is offline  
Old 02-03-2019, 08:01 PM
  #3  
Registered Member
Thread Starter
 
Join Date: Aug 2013
Location: Orlando, FL
Age: 36
Posts: 534
Thanked 76 Times in 68 Posts
Originally Posted by thoiboi View Post



Bad tension on belt
I read the belt tension could be an issue. The belt Im running only has about 6k om it (changed with last service). It was very tight to get off and on, so I don't think it's tension. I ended up checking all fuses and they seem to be ok. Just completed an oil change and reset the Maintenance minder, so we'll see if there were any improvements.
nats007 is offline  
Old 02-04-2019, 08:04 PM
  #4  
Registered Member
Thread Starter
 
Join Date: Aug 2013
Location: Orlando, FL
Age: 36
Posts: 534
Thanked 76 Times in 68 Posts
So, I cleared all codes yesterday and thought all is well. Left work this evening and the check charging system was flashing again intermittently. I called my Indy mechanic and explained the issue and he bet it's the refurbished AutoZone alternator. Bringing it in tomorrow to test and then swap for a Denso/OEM equivalent alternator.
nats007 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jfwalker2
4G TL Problems & Fixes
1
10-01-2017 02:25 PM
wmahmud
4G TL Problems & Fixes
41
01-03-2017 12:12 PM
RedlineCL-S
2G CL Problems & Fixes
1
12-04-2016 10:26 PM
lareacap
Second Generation RL (2005-2012)
42
02-24-2015 12:34 PM
xjbych2810
Second Generation RL (2005-2012)
7
08-26-2011 08:12 PM


Thread Tools
Search this Thread
Quick Reply: Check charging system flashing


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.