2009 Acura MDX Tech - Rear Right Door - AcuraZine - Acura Enthusiast Community

Notices

2009 Acura MDX Tech - Rear Right Door

 
Old 02-04-2019, 02:30 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
2009 Acura MDX Tech - Rear Right Door

Hi
I have a 2009 MDX with ~ 80K on it.

I noticed a weird issue going on with the rear right passenger door. When the door is open, the central panel (that displays open doors/tail gate) doesn't show that the rear right door is open. Also, I am able to centrally lock the car even though the rear right door is open.

Any advice on what might be causing this ?

Appreciate your help in advance

Thanks
Raj
yuvasethu is offline  
Old 02-04-2019, 02:56 PM
  #2  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,038
Thanked 5,718 Times in 4,584 Posts
the sensor is stuck closed
thoiboi is offline  
The Following User Says Thank You to thoiboi For This Useful Post:
yuvasethu (02-04-2019)
Old 02-04-2019, 03:04 PM
  #3  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
Thank you. How to find it and fix? Can you provide some insight please?
yuvasethu is offline  
Old 02-04-2019, 03:06 PM
  #4  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,038
Thanked 5,718 Times in 4,584 Posts
Open the door, look for the sensor plunger, it's a little black rubber-covered switch. See if it's just stuck in and if you can use your finger to 'unstick' it. Then report back
thoiboi is offline  
Old 02-04-2019, 06:55 PM
  #5  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
thoiboi , thank you for the direction. I checked the sensor plunger and could not find any switch covered by the plunger. When I squeezed the plunger, it was just going in & out free like a feeding bottle nipple. (apologize for this reference, as I couldn't find any better appropriate comparison).

I am attaching the picture herewith as well, for your reference. Please advice what I can do to fix this. I am sure if I go to the dealer, it will cost me a fortune.


Rear Right Door Sensor Plunger
yuvasethu is offline  
Old 02-04-2019, 07:02 PM
  #6  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,038
Thanked 5,718 Times in 4,584 Posts
https://www.oemacuraparts.com/oem-pa...ta-35400s5a013


Could be just a bad switch, part number is there, Amazon link is slightly more expensive but includes shipping:
https://smile.amazon.com/Genuine-Hon...ustomerReviews

Video here:

thoiboi is offline  
The Following User Says Thank You to thoiboi For This Useful Post:
yuvasethu (02-19-2019)
Old 02-04-2019, 08:24 PM
  #7  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
Originally Posted by thoiboi View Post
https://www.oemacuraparts.com/oem-pa...ta-35400s5a013


Could be just a bad switch, part number is there, Amazon link is slightly more expensive but includes shipping:
https://smile.amazon.com/Genuine-Hon...ustomerReviews

Video here: https://www.youtube.com/watch?v=Hobu18SceaI
Thanks a lot.

Let me try this out and update you. May take a few days, thoiboi.
yuvasethu is offline  
Old 02-19-2019, 07:10 PM
  #8  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
hello thoiboi
At last, I received the replacement part last week and had the exercise done. The part was broken and was way deep inside the body. Oh god, it was a hassle to pull the cord out and remove the broken piece and put on the new one. Took almost an hour with very limited tools.

Anyways, I thank you a lot for the timely responses and directions.

Not to overwhelm you, since this past week, I have been getting the below three messages ;

1. Vehicle Stability Assist: 67
2. Trailer Stability Assist: 69
3. All-Wheel Drive: 77

The All-Wheel Drive alert is very transparent as I can clearly see that no power being transmitted to the rear wheels.

Any idea what is causing this?

Thanks
Yuvaraj
yuvasethu is offline  
Old 02-19-2019, 07:15 PM
  #9  
Moderator
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 37,038
Thanked 5,718 Times in 4,584 Posts
Typically a bunch of codes popping up at the same time can be attributed to a bad battery / low voltage.

In your case however, it may be an ABS /Wheel sensor that is malfunctioning that is causing all 3 of those codes to come up at once.

Is the battery old? If it's been a few years, you can try replacing it and seeing if the codes clear after replacement.
thoiboi is offline  
Old 02-19-2019, 08:16 PM
  #10  
Registered Member
Thread Starter
 
Join Date: Feb 2019
Age: 41
Posts: 6
Thanked 0 Times in 0 Posts
Originally Posted by thoiboi View Post
Typically a bunch of codes popping up at the same time can be attributed to a bad battery / low voltage.

In your case however, it may be an ABS /Wheel sensor that is malfunctioning that is causing all 3 of those codes to come up at once.

Is the battery old? If it's been a few years, you can try replacing it and seeing if the codes clear after replacement.
Thanks again thoiboi. The battery is close to 2 years, I believe. Is that too old, as per the standards?
yuvasethu is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MDXAF
1G & 2G MDX Discussion (2001-2013)
7
09-08-2018 01:40 AM
J&M_MDX
Audio, Video, Electronics & Navigation
0
08-20-2018 10:05 PM
mverma
3G MDX Discussion (2014+)
3
06-23-2015 10:22 PM
NSXRguy
Second Generation RL (2005-2012)
24
02-20-2010 04:37 AM
kc1953
Fourth Generation TL (2009-2014)
14
06-17-2009 10:42 PM


Thread Tools
Search this Thread
Quick Reply: 2009 Acura MDX Tech - Rear Right Door


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.