Navigation Screen doesn't display and Top Radio display doesn't work. - AcuraZine Community
AcuraZine Acura Forums Home Acura CL Forums Acura ILX Forums Acura MDX Forums Acura NSX Forums Acura RDX ForumsAcura RL ForumsAcura RSX ForumsAcura TL ForumsAcura TSX ForumsAcuraZine ZDX DiscussionAcuraZine Regional DiscussionAcuraZine Off Topic Discussion

Go Back   AcuraZine Community > AcuraZine TL Community > Third Generation TL (2004-2008) > Audio, Bluetooth, Electronics & Navigation
Sign in using an external account
Register Forgot Password?
Register Albums FAQ Members Calendar Search Today's Posts Mark All Read ExperienceUsed CarsVendor DirectoryGarage
Search
Welcome to AcuraZine Community

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 07-18-2011, 2:17 PM   #1
kreed
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,016, Level: 17
Points: 1,016, Level: 17 Points: 1,016, Level: 17 Points: 1,016, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Navigation Screen doesn't display and Top Radio display doesn't work.

Started my 2006 TL this morning and the navigation screen wouldn't come on. Then I noticed that the radio channel display was not working on the dashboard, either. I've read a couple posts about this but none with any resolution that worked for me.

Just came out of warranty 200 miles ago. Thankfully my transmission failed RIGHT before the warranty expired, so I'm not complaining. I doubt the repair for the audio/nav will be nearly the cost of a new transmission.

Any suggestions on where to start with this nav/radio display thing would be greatly appreciated. Not sure if this is relevant but about 3 months ago the back light on the seat warmer went out and then over the past 3 months (one at a time) almost all of the backlights on the buttons on my steering wheel have gone out.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
kreed is offline   Reply With Quote
Old 07-18-2011, 7:42 PM   #2
ParaSurfer1979
2008 Acura 3.2TL
Garage is empty, add now
 
ParaSurfer1979's Avatar
 
Trader Rating: (0)
Join Date: May 2010
Location: Wilmington, NC
Age: 35
Posts: 3,132
Thanks: 83
Thanked 110 Times in 88 Posts
Desmond.MacRae parasurfer1979
Points: 8,597, Level: 62
Points: 8,597, Level: 62 Points: 8,597, Level: 62 Points: 8,597, Level: 62
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
200miles ago acura will still probably warranty it. Take it to Acura asap and see what they can work out. Good luck bro. Keep us posted. Speak to Service manager.
__________________
Desmond,
Currently- '13 Taffeta White Honda FIT Sport w/ Navigation
Previous- '08 Alabaster Silver Acura TL/Technology Pkg Equipped w/ Menox Hand Controls (I'm a paraplegic)
ParaSurfer1979 is offline   Reply With Quote
Old 07-18-2011, 9:04 PM   #3
csmeance
Senior Moderator
2006 BMW 7-Series
My Garage
 
csmeance's Avatar
 
Trader Rating: (0)
Join Date: Feb 2006
Location: Daytona Beach/Gainesville FL
Posts: 15,709
Thanks: 40
Thanked 402 Times in 242 Posts
I facetube, I think! Is it twitting? Twittering? Darn it! Linked-Out csmeance :idontlikemyinfostolen:
Points: 41,818, Level: 100
Points: 41,818, Level: 100 Points: 41,818, Level: 100 Points: 41,818, Level: 100
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
Quote:
Originally Posted by ParaSurfer1979 View Post
200miles ago acura will still probably warranty it. Take it to Acura asap and see what they can work out. Good luck bro. Keep us posted. Speak to Service manager.


it sounds like one of the boards inside the screen failed since the navi-screen connects the upper display as well as the navi system. If acura doesn't cover it, PM me and I'll see if I can help out with figuring out a cheaper solution.
__________________
2010 Honda Accord EX - Basque Red/Ivory
lOE Fog Lightsl

2006 BMW 760Li - Alpine White/Ebony-Ivory Two Tone
lMud-Guardsl426WHP/430WTQ V12l

2007 MDX Sport/Ent.- NGM/Taupe
lRB Slotted RotorslRoof RailslFront & Rear GarnishlAuto Mirrorl

2004 TL NAVI Auto - SSM/Quartz
lComptech SwaybarlHacked NavlTVNAV2GolUSA-SPEClDVD PlayerlSwitchblade KeylRB Slotted RotorslA-Spec Brakesl
csmeance is offline   Reply With Quote
The Following User Says Thank You to csmeance For This Useful Post:
D1G1TAL GHOST (07-24-2011)
Old 07-20-2011, 9:46 PM   #4
kreed
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 1,016, Level: 17
Points: 1,016, Level: 17 Points: 1,016, Level: 17 Points: 1,016, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
kreed is offline   Reply With Quote
Old 07-20-2011, 9:47 PM   #5
kreed
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 1,016, Level: 17
Points: 1,016, Level: 17 Points: 1,016, Level: 17 Points: 1,016, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Please forgive the typos. (iPad)
kreed is offline   Reply With Quote
Old 07-21-2011, 1:16 PM   #6
csmeance
Senior Moderator
2006 BMW 7-Series
My Garage
 
csmeance's Avatar
 
Trader Rating: (0)
Join Date: Feb 2006
Location: Daytona Beach/Gainesville FL
Posts: 15,709
Thanks: 40
Thanked 402 Times in 242 Posts
I facetube, I think! Is it twitting? Twittering? Darn it! Linked-Out csmeance :idontlikemyinfostolen:
Points: 41,818, Level: 100
Points: 41,818, Level: 100 Points: 41,818, Level: 100 Points: 41,818, Level: 100
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
Quote:
Originally Posted by kreed View Post
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
Acura is a good brand that takes care of their customers. You have to remember that acura's car's are a bit more technical than your typical toyota with features like auto dimming mirrors, HID's, memory seats, navi, solar sensing climate control, etc.

It's just like a BMW/Mercedes, the more technology you have, the more prone something is to break! Take my BMW for example, in time I've had it out of factory warranty, the aftermarket company has picked up the tab for almost 23,000 dollars worth of repair work.

My Transmission went out on my TL and my dash cracked and Acura covered it even though I was past 100K miles! That's why I bought a honda and didn't compare to a toyota or nissan or other brand. They took care of me and made me into a loyal customer.
__________________
2010 Honda Accord EX - Basque Red/Ivory
lOE Fog Lightsl

2006 BMW 760Li - Alpine White/Ebony-Ivory Two Tone
lMud-Guardsl426WHP/430WTQ V12l

2007 MDX Sport/Ent.- NGM/Taupe
lRB Slotted RotorslRoof RailslFront & Rear GarnishlAuto Mirrorl

2004 TL NAVI Auto - SSM/Quartz
lComptech SwaybarlHacked NavlTVNAV2GolUSA-SPEClDVD PlayerlSwitchblade KeylRB Slotted RotorslA-Spec Brakesl
csmeance is offline   Reply With Quote
Old 07-23-2011, 11:28 PM   #7
D1G1TAL GHOST
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jan 2011
Age: 26
Posts: 33
Thanks: 3
Thanked 0 Times in 0 Posts
Points: 2,777, Level: 32
Points: 2,777, Level: 32 Points: 2,777, Level: 32 Points: 2,777, Level: 32
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
I have the same issue again with my navi. I had the issue a while back when the navi would be intermittently working. The problem was that it kept losing connection with all of the buttons and even the LCD radio screen would not work. What literally solved my problem was hitting a bumb. I hit one at a good speed that everything came on. I'm thinking it's a bad ground? Not really sure. Only problem now is that the problem is back after 6 months. If anyone knows how yo fix this please pm me. I live in San Francisco if u guys know any shops that can fix it.
D1G1TAL GHOST is offline   Reply With Quote
Old 11-26-2013, 12:50 AM   #8
Fedexo
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2011
Age: 35
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,733, Level: 24
Points: 1,733, Level: 24 Points: 1,733, Level: 24 Points: 1,733, Level: 24
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
Did you get it fixed? I have the same problem with the radio stations not displaying. The navigation works only if I turn off the radio. I'll be taking mine apart soon and let you know if I find a short, loose wires, or maybe there are quarters in the tape deck.
Quote:
Originally Posted by kreed View Post
Driving home from work, yesterday,nthe screen came on and I had to enter my dcode. Stayed on for about an hour but it's off again. I so frustrated with this car! Just had the transmission replaced last mont. Thank god I still had the warranty. I used to be a Toyota buyer but I decided to go with the Acura when I bought it two years ago. It had 45k miles on it when I bought it. Obviously I can put some serious miles on a vehicle so I really thought acura was the way to go. I'm considering buying a new(to me) car and I don't know if I should give Acura another shot or if I should go back to Toyota. Grrrr
Fedexo is offline   Reply With Quote
Old 11-30-2013, 10:11 PM   #9
GBeeman
Registered Member
2006 Acura TL
 
Trader Rating: (0)
Join Date: Jul 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,211, Level: 19
Points: 1,211, Level: 19 Points: 1,211, Level: 19 Points: 1,211, Level: 19
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
My screen quit working in September. Took it to the dealer and they diagnosed a bad screen and sent it out for repair. Seven weeks later they tell me the screen can't be repaired and a used one (no warranty) is $800 and a new one is $3,000! I'm not a happy camper. Does anyone have a better solution?

Gordon
GBeeman is offline   Reply With Quote
Old 11-30-2013, 10:11 PM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
04, 2006, accord, acura, blank, bmw, display, honda, light, mdx, navigation, radio, screen, tl, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 9:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup