Odometer and Trip Meter Stopped Working - AcuraZine Community
AcuraZine Acura Forums Home Acura CL Forums Acura ILX Forums Acura MDX Forums Acura NSX Forums Acura RDX ForumsAcura RL ForumsAcura RSX ForumsAcura TL ForumsAcura TSX ForumsAcuraZine ZDX DiscussionAcuraZine Regional DiscussionAcuraZine Off Topic Discussion

Go Back   AcuraZine Community > AcuraZine TL Community > First Generation TL (1996-1998) > Problems & Fixes
Sign in using an external account
Register Forgot Password?
Register Albums FAQ Members Calendar Search Today's Posts Mark All Read ExperienceUsed CarsVendor DirectoryGarage
Search
Welcome to AcuraZine Community

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 12-29-2009, 4:06 PM   #1
main70072
Registered Member
Garage is empty, add now
 
main70072's Avatar
 
Trader Rating: (0)
Join Date: Nov 2007
Location: New Orleans, LA
Age: 26
Posts: 1,402
Thanks: 39
Thanked 85 Times in 81 Posts
Points: 8,084, Level: 60
Points: 8,084, Level: 60 Points: 8,084, Level: 60 Points: 8,084, Level: 60
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
Odometer and Trip Meter Stopped Working

So just today, I have noticed that both my odometer and trip meter stopped working. I have tried to reset the trip meter to see if that made any difference, and nothing. I have tried to reset the maintenace required indicator to see if that made any difference, and still nothing. I listened closely to see if there were any noises, and could hear nothing. What could possibly be wrong. My speedometer needle that register my speed works normally, and so does everything else. Thanks in advance for your help!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
main70072 is offline   Reply With Quote
Old 12-30-2009, 9:50 PM   #2
main70072
Registered Member
Garage is empty, add now
 
main70072's Avatar
 
Trader Rating: (0)
Join Date: Nov 2007
Location: New Orleans, LA
Age: 26
Posts: 1,402
Thanks: 39
Thanked 85 Times in 81 Posts
Threadstarter
Points: 8,084, Level: 60
Points: 8,084, Level: 60 Points: 8,084, Level: 60 Points: 8,084, Level: 60
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
Bump... Anyone have any ideas? I thought the odometer works with the speedometer, but my speedometer works just fine, minus the odometer. I know my speed is registered by the speed sensor, but what about the odometer? Could it be my speedometer cluster or a sensor in one of the wheels or trans?
main70072 is offline   Reply With Quote
Old 12-31-2009, 8:15 AM   #3
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
Speedometer, Odometer and Trip Odometer are driven by same circuit. Failure of Odometer and Trip Odometer suggests a circuit board fault on the instrument panel. A used instrument panel or repair of yours is probabaly best options. Check online for IP repair sources.

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 12-31-2009, 8:29 AM   #4
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
Check car-part.com for a used IP. You may need to file a mileage change statement w/ your state if IP is replaced.

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 12-31-2009, 8:56 AM   #5
main70072
Registered Member
Garage is empty, add now
 
main70072's Avatar
 
Trader Rating: (0)
Join Date: Nov 2007
Location: New Orleans, LA
Age: 26
Posts: 1,402
Thanks: 39
Thanked 85 Times in 81 Posts
Threadstarter
Points: 8,084, Level: 60
Points: 8,084, Level: 60 Points: 8,084, Level: 60 Points: 8,084, Level: 60
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
So it's a circuit board fault...it just seems so strange how the needle works but numbers don't roll. Thanks for the response TexasHonda!
main70072 is offline   Reply With Quote
Old 12-31-2009, 3:29 PM   #6
blueninja
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Mar 2009
Location: Houston, TX
Age: 34
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,750, Level: 24
Points: 1,750, Level: 24 Points: 1,750, Level: 24 Points: 1,750, Level: 24
Activity: 2.0%
Activity: 2.0% Activity: 2.0% Activity: 2.0%
I have the same problem, is this an easy DIY or should a shop do it?
__________________
96 T.l 3.2

260*** miles and counting
blueninja is offline   Reply With Quote
Old 12-31-2009, 8:50 PM   #7
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
Quote:
Originally Posted by blueninja View Post
I have the same problem, is this an easy DIY or should a shop do it?
Instrument panel removal is not hard if you follow the shop manual instructions for trim removal. I've done it once on my 2.5TL to replace the D4 light bulb. PM your email address and I'll forward the pdf files for the procedure.

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 01-02-2010, 6:53 PM   #8
main70072
Registered Member
Garage is empty, add now
 
main70072's Avatar
 
Trader Rating: (0)
Join Date: Nov 2007
Location: New Orleans, LA
Age: 26
Posts: 1,402
Thanks: 39
Thanked 85 Times in 81 Posts
Threadstarter
Points: 8,084, Level: 60
Points: 8,084, Level: 60 Points: 8,084, Level: 60 Points: 8,084, Level: 60
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
So I removed the cluster today, shook it up and gave it some knocks. It works after putting it back together.
main70072 is offline   Reply With Quote
Old 01-31-2010, 10:02 PM   #9
perugino
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Jan 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
HELP ME Im changing my water pump and timing belt on my 1996 ACURA TL, but I can't get the bolt on the drive shaft pulley off.Is it a regular thread or revers thread. Or anyone that can help please let me know!! THANKS.....
perugino is offline   Reply With Quote
Old 06-06-2010, 8:29 PM   #10
deej0121
deej0121
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Nov 2005
Location: Louisiana
Age: 54
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 4,925, Level: 44
Points: 4,925, Level: 44 Points: 4,925, Level: 44 Points: 4,925, Level: 44
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Let's see what everyone thinks about this one. I asked my local ACURA dealer about this. The tech said he has seen the odometer & trip meter not working being caused by failed speed sensor. If I understood correctly, he thinks it is a speed sensor associated with the tranny (???). Has anyone on our forum been down this road--had a speed sensor replaced to fix this problem? Thanks in advance!!!
__________________
1998 3.2 TL, black, no mods.
deej0121 is offline   Reply With Quote
Old 06-06-2010, 8:52 PM   #11
Go90go
大日本帝国
Garage is empty, add now
 
Go90go's Avatar
 
Trader Rating: (0)
Join Date: Apr 2006
Location: Double Standard Land
Posts: 5,272
Thanks: 21
Thanked 30 Times in 25 Posts
Points: 14,214, Level: 77
Points: 14,214, Level: 77 Points: 14,214, Level: 77 Points: 14,214, Level: 77
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
^ The Vehicle Speed Sensor goes into the differential, and is what makes your speedometer and odometers work. If that fails, then your D4 light should start flashing, and either the speedometer will be bouncy or not work at all. Perhaps he forgot that 1Gs have a differential, so he said the tranny, but it's in the diff.

~Cheers~
Go90go is offline   Reply With Quote
Old 06-07-2010, 7:41 AM   #12
main70072
Registered Member
Garage is empty, add now
 
main70072's Avatar
 
Trader Rating: (0)
Join Date: Nov 2007
Location: New Orleans, LA
Age: 26
Posts: 1,402
Thanks: 39
Thanked 85 Times in 81 Posts
Threadstarter
Points: 8,084, Level: 60
Points: 8,084, Level: 60 Points: 8,084, Level: 60 Points: 8,084, Level: 60
Activity: 3.5%
Activity: 3.5% Activity: 3.5% Activity: 3.5%
Like Go90go said, the speedometer should malfunction too if speed sensor failed. If only the odometer and trip meter stopped working, it will most likely be the cluster itself. I had this problem, but since took the cluster out and give it a nice tap/knock, put it back in and it has worked since.
main70072 is offline   Reply With Quote
Old 06-10-2010, 9:28 PM   #13
deej0121
deej0121
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Nov 2005
Location: Louisiana
Age: 54
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 4,925, Level: 44
Points: 4,925, Level: 44 Points: 4,925, Level: 44 Points: 4,925, Level: 44
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
I remembered the post about pulling out the cluster & giving it a shake to "fix" it, so I figured I should ask everyone here before I just go with the Acura dealer's thoughts. Thanks so much!!
__________________
1998 3.2 TL, black, no mods.
deej0121 is offline   Reply With Quote
Old 06-11-2010, 7:36 AM   #14
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
I would try Main70072's solution before replacing the speed sensor.

I don't see any way speedometer can work with a failed VSS disabling odometer/trip odometer. VSS provides signal input to circuit that drives speedometer.

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 05-15-2011, 2:47 AM   #15
SimplyGheju
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: May 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 5, Level: 1
Points: 5, Level: 1 Points: 5, Level: 1 Points: 5, Level: 1
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
I have a 1997 TL and the same exact thing happened to me today.. I have 2 questions. Was the procedure hard and do you mind sending me those PDFs for the procedure?
SimplyGheju is offline   Reply With Quote
Old 05-16-2011, 5:49 AM   #16
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
Quote:
Originally Posted by SimplyGheju View Post
I have a 1997 TL and the same exact thing happened to me today.. I have 2 questions. Was the procedure hard and do you mind sending me those PDFs for the procedure?
PM your email address to me and I'll forward.

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 08-14-2012, 3:29 PM   #17
amindian
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 5, Level: 1
Points: 5, Level: 1 Points: 5, Level: 1 Points: 5, Level: 1
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
I have 1998 TL3.2. Its used car that I bought. Trip meter was not working when I bought it. But yesterday, my odometer also stopped. My speedometer is working fine. What would be the problem? how much would be the cost to fix this up?
amindian is offline   Reply With Quote
Old 08-15-2012, 5:29 AM   #18
TexasHonda
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2005
Age: 68
Posts: 2,290
Thanks: 0
Thanked 43 Times in 42 Posts
Points: 12,724, Level: 73
Points: 12,724, Level: 73 Points: 12,724, Level: 73 Points: 12,724, Level: 73
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
First try resetting the trip odometer to zero; several times. Sometimes this will "reboot" the odometer/trip odometer. It may be a mechanical problem w/ the gears that are jamming. If you remove suggest adding a tiny amount of machine oil to the movement and bumping/thumpoing to loosen/distribute.

Note, it could be a circuit board fault. Here you will need to inspect board closely and resolder all the connections (reheat and add a little solder).

good luck
__________________
2006 Acura TSX
1994 Honda Accord
2005 Toyota Matrix
2003 Acura MDX
I don't drive em, just fix em.
TexasHonda is offline   Reply With Quote
Old 09-02-2013, 9:01 AM   #19
Redturbo0
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2013
Age: 29
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 5, Level: 1
Points: 5, Level: 1 Points: 5, Level: 1 Points: 5, Level: 1
Activity: 0.5%
Activity: 0.5% Activity: 0.5% Activity: 0.5%
could you send me those pdf files? Do you have them for a 96 integra?
Redturbo0 is offline   Reply With Quote
Old 09-02-2013, 9:08 AM   #20
Redturbo0
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Sep 2013
Age: 29
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 5, Level: 1
Points: 5, Level: 1 Points: 5, Level: 1 Points: 5, Level: 1
Activity: 0.5%
Activity: 0.5% Activity: 0.5% Activity: 0.5%
wow why did this come up when I searched integra odometer not working in google.... thats why I posted, maybe its the same?
Redturbo0 is offline   Reply With Quote
Old 09-02-2013, 9:08 AM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
1994, 1997, accord, acura, cluster, honda, instrument, malfunction, meter, odometer, panel, rl, speedometer, stopped, trip, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 3:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup