Sooo these wiper blades??? - AcuraZine Community
AcuraZine Acura Forums Home Acura CL Forums Acura ILX Forums Acura MDX Forums Acura NSX Forums Acura RDX ForumsAcura RL ForumsAcura RSX ForumsAcura TL ForumsAcura TSX ForumsAcuraZine ZDX DiscussionAcuraZine Regional DiscussionAcuraZine Off Topic Discussion

Go Back   AcuraZine Community > AcuraZine TSX Community > First Generation TSX Discussion (2004-2008) > Problems & Fixes
Sign in using an external account
Register Forgot Password?
Register Albums FAQ Members Calendar Search Today's Posts Mark All Read ExperienceUsed CarsVendor DirectoryGarage
Search
Welcome to AcuraZine Community

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 03-24-2008, 2:13 PM   #1
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Mar 2008
Age: 39
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Sooo these wiper blades???

I work at Carquest. I tried to sell a neoform to a friend for his 06 TSX but the passenger side is offset??? it was up on the rubber about an inch. I did try to turn the new blade around and it wouldn't snap on. I did have it snapped on and seated in the U.

Is there a problem with these passenger blades that makes aftremarket blades like the trico Neoforms not applicable for these cars? or was I just doin something wrong in applying the 16" blade to the passenger side?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
Prestieg is offline   Reply With Quote
Old 03-25-2008, 8:53 AM   #2
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Mar 2008
Age: 39
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
You guys are making me feel stupid here.. Noone knows anything about this?
Prestieg is offline   Reply With Quote
Old 03-25-2008, 8:54 AM   #3
Moderator
Garage is empty, add now
 
moda_way's Avatar
 
Trader Rating: (0)
Join Date: Jul 2003
Location: Cincinnati, OH
Age: 39
Posts: 7,604
Thanks: 0
Thanked 3 Times in 3 Posts
Points: 21,264, Level: 91
Points: 21,264, Level: 91 Points: 21,264, Level: 91 Points: 21,264, Level: 91
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Not sure what you are asking us for? They are different sizes yes. Bosch makes perfect replacements for it... 26" Drivers side, 16" on the passenger side. I have no idea about Neoforms.

Other than the site saying you need the 16-260 and 16-160 (Driver/Passenger respectively), I'm not sure what else to say unless someone else has used them.
moda_way is offline   Reply With Quote
Old 03-25-2008, 1:28 PM   #4
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2007
Location: Pittsburgh, PA
Age: 36
Posts: 2,545
Thanks: 0
Thanked 2 Times in 2 Posts
Points: 5,059, Level: 45
Points: 5,059, Level: 45 Points: 5,059, Level: 45 Points: 5,059, Level: 45
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Do they make a smaller one you could put on the passenger side? Seems easy enough.
LukeaTron is offline   Reply With Quote
Old 03-25-2008, 1:32 PM   #5
Registered Member
Garage is empty, add now
 
golfboy's Avatar
 
Trader Rating: (0)
Join Date: Dec 2006
Age: 38
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Same issue...

I tried to replace the OEM one-piece wiper blades on my 2006 TSX with aftermarket ones and none of the 16" sizes fit the passenger side. The problem is that the OEM blades have an offset mount that effectively seats the blade higher up the windshield when the wiper is at rest. This allows the blade to clear the windshield frame. Aftermarket ones don't have this offset and the mount is right at the center of the blade itself.

I resorted to using a 15" standard blade on the passenger side since the one-pieces like the Bosch ICONs don't come in 15". Yup, back to standard style wipers....that's how much I hate the OEMs.
golfboy is offline   Reply With Quote
Old 03-25-2008, 1:36 PM   #6
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Mar 2007
Location: Antioch, IL
Age: 32
Posts: 563
Thanks: 0
Thanked 0 Times in 0 Posts
I just had my OEM wiper blade inserts replaced today while I was getting my A1 service done. They wipe great now. I believe it cost me $20 to replace them. The originial ones lasted me 1.5 years, so I didn't think they were too bad. But, what do I know?
JLTSX07 is offline   Reply With Quote
Old 03-25-2008, 2:56 PM   #7
Registered Member
Garage is empty, add now
 
golfboy's Avatar
 
Trader Rating: (0)
Join Date: Dec 2006
Age: 38
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by JLTSX07
I just had my OEM wiper blade inserts replaced today while I was getting my A1 service done. They wipe great now. I believe it cost me $20 to replace them. The originial ones lasted me 1.5 years, so I didn't think they were too bad. But, what do I know?
I also had my OEMs replaced after 7 months and only after living with some pretty awful skipping for a month. They worked great after a couple of months with no issues...then the dreaded skipping returned. I lived with it for another month before getting fed up and trying a bunch of aftermarkets. Finially have a set of steel framed Bosch Micro-Edges on and no more skipping for 3 months now. I guess my luck with the OEMs just isn't that good.
golfboy is offline   Reply With Quote
Old 03-25-2008, 5:35 PM   #8
Old Guy
1985 Ferrari 308
My Garage
 
Simba91102's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Posts: 2,737
Thanks: 0
Thanked 145 Times in 126 Posts
Points: 9,383, Level: 65
Points: 9,383, Level: 65 Points: 9,383, Level: 65 Points: 9,383, Level: 65
Activity: 2.0%
Activity: 2.0% Activity: 2.0% Activity: 2.0%
There have been a couple of threads on the wiper problems that some are experiencing (fortunately, I'm not one of them). Although this is the first I heard of the unusual design of the OE blades, I'm not surprised I guess (the blade itself sure looks different). I'll probably have the dealer replace the blades on my wife' 07 at the next service (the car will be a little over a year old and probably 26K to 28K miles). Except for the freebies I always got with the Audi's (gotta love free maintenance for 4 yr./50K miles), the TSX's are the first cars that I haven't taken care of the wiper blade changes myself (I've had the dealer do it on the 05 which actually is due too). I always change them out once a year or so. They take a beating here in Mass. with the dirty roads all winter, so it's a regular spring job.
Simba91102 is offline   Reply With Quote
Old 03-26-2008, 2:04 AM   #9
Registered Member
Garage is empty, add now
 
PhiSigBrotha's Avatar
 
Trader Rating: (0)
Join Date: Aug 2006
Location: Goodyear, AZ
Age: 33
Posts: 152
Thanks: 2
Thanked 1 Time in 1 Post
Points: 7,510, Level: 57
Points: 7,510, Level: 57 Points: 7,510, Level: 57 Points: 7,510, Level: 57
Activity: 0.4%
Activity: 0.4% Activity: 0.4% Activity: 0.4%
my two OEM sets wiped horribly after just a couplee months. so i switched to the Anco Contour blades.

http://www.federal-mogul.com/en/Afte...lades/Contour/

i tried the nice bosch ones but i too found out about the passenger side offset on the 06. the Ancos are a 16" blade for passenger and look like OEM. plus they are holding up much better than the OEMs too.


luther
PhiSigBrotha is offline   Reply With Quote
Old 03-26-2008, 3:54 AM   #10
Old Guy
1985 Ferrari 308
My Garage
 
Simba91102's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Posts: 2,737
Thanks: 0
Thanked 145 Times in 126 Posts
Points: 9,383, Level: 65
Points: 9,383, Level: 65 Points: 9,383, Level: 65 Points: 9,383, Level: 65
Activity: 2.0%
Activity: 2.0% Activity: 2.0% Activity: 2.0%
Quote:
Originally Posted by PhiSigBrotha
my two OEM sets wiped horribly after just a couplee months. so i switched to the Anco Contour blades.

http://www.federal-mogul.com/en/Afte...lades/Contour/

i tried the nice bosch ones but i too found out about the passenger side offset on the 06. the Ancos are a 16" blade for passenger and look like OEM. plus they are holding up much better than the OEMs too.


luther
I've always used Anco blades in the past. I found they worked the best for the money. They're reasonably priced, work as well as anything, and being replaced once a year anyway, I've never found any need to spend more on wiper blades.
Simba91102 is offline   Reply With Quote
Old 03-26-2008, 1:39 PM   #11
Moderator
2008 Acura TL-S
 
LoveMyTL-S's Avatar
 
Trader Rating: (0)
Join Date: Mar 2005
Location: Jacksonville, FL
Age: 57
Posts: 11,719
Thanks: 296
Thanked 304 Times in 262 Posts
micheal.cain
Points: 25,196, Level: 95
Points: 25,196, Level: 95 Points: 25,196, Level: 95 Points: 25,196, Level: 95
Activity: 0.8%
Activity: 0.8% Activity: 0.8% Activity: 0.8%
I replaced mine with Bosch and noticed the same thing on the drivers side, overlaping on the rubber about an inch. I reseated the blade into the arm and it fit with no problems after that. Just make sure the blade is seated completely into the arm hook.
LoveMyTL-S is offline   Reply With Quote
Old 03-27-2008, 7:21 AM   #12
Registered Member
Garage is empty, add now
 
'06 Arctic's Avatar
 
Trader Rating: (0)
Join Date: Jan 2007
Location: Pittsburgh, PA
Age: 33
Posts: 889
Thanks: 0
Thanked 6 Times in 4 Posts
Points: 4,873, Level: 44
Points: 4,873, Level: 44 Points: 4,873, Level: 44 Points: 4,873, Level: 44
Activity: 0.9%
Activity: 0.9% Activity: 0.9% Activity: 0.9%
Yep, I had the same thing happen with the new set of blades I just got, they are Michelin Optimum Wiper Blades. Application guide specifies the 16" and when I installed the blade it overlaps by about an inch. Looked to see if I could adjust the hook latch on the blade but no go. When it is completed seated, still overlaps. As LuvMyTSX said, I had Bosch Icons before and don't recall having this problem. Guess I should have bought them again huh?
'06 Arctic is offline   Reply With Quote
Old 03-27-2008, 8:52 AM   #13
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Mar 2008
Age: 39
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
thanks for the help guys
Prestieg is offline   Reply With Quote
Old 04-01-2008, 8:30 PM   #14
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Apr 2008
Age: 52
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I have 2006 tsx and have been unable to find a blade that fits the passenger side. None of the big auto parts dealers in my town have anything that fits. I bought neoforms but they are too long. They don't have the 16inch Bosch icons. I can order them off the internet do they fit? I didn't think it looked like they have an offset design like the original. Advance auto parts measured many different blades but none worked for my car.
hook is offline   Reply With Quote
Old 04-02-2008, 9:09 AM   #15
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2007
Age: 32
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
I bought a Bosch 16" for my passenger wiper. For some reason it extended into the plastic edge of the window. I ended up having to cut a 1/2 inch off the blade and bent the metal skeleton part that keeps the wiper stiff to make it fit.
justinangil is offline   Reply With Quote
Old 04-02-2008, 9:22 AM   #16
Quattro in.....
Garage is empty, add now
 
Viking's Avatar
 
Trader Rating: (0)
Join Date: Jun 2004
Location: NYC
Posts: 3,401
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 6,417, Level: 52
Points: 6,417, Level: 52 Points: 6,417, Level: 52 Points: 6,417, Level: 52
Activity: 0.2%
Activity: 0.2% Activity: 0.2% Activity: 0.2%
Quote:
Originally Posted by justinangil
I bought a Bosch 16" for my passenger wiper. For some reason it extended into the plastic edge of the window. I ended up having to cut a 1/2 inch off the blade and bent the metal skeleton part that keeps the wiper stiff to make it fit.
I just replaced my passenger side wiper with a 16" Bosch Excel+. I noticed the same thing and was pissed but then checked the Bosch packaging/box and found the other adapters for the blade. Switched out the adapter to the shorter one and the blade fit perfect! Did you check the box for other adapters?
Viking is offline   Reply With Quote
Old 04-02-2008, 1:07 PM   #17
Moderator
2008 Acura TL-S
 
LoveMyTL-S's Avatar
 
Trader Rating: (0)
Join Date: Mar 2005
Location: Jacksonville, FL
Age: 57
Posts: 11,719
Thanks: 296
Thanked 304 Times in 262 Posts
micheal.cain
Points: 25,196, Level: 95
Points: 25,196, Level: 95 Points: 25,196, Level: 95 Points: 25,196, Level: 95
Activity: 0.8%
Activity: 0.8% Activity: 0.8% Activity: 0.8%
Quote:
Originally Posted by Viking
I just replaced my passenger side wiper with a 16" Bosch Excel+. I noticed the same thing and was pissed but then checked the Bosch packaging/box and found the other adapters for the blade. Switched out the adapter to the shorter one and the blade fit perfect! Did you check the box for other adapters?
That may have been what I did with mine.
LoveMyTL-S is offline   Reply With Quote
Old 04-03-2008, 7:51 PM   #18
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Apr 2008
Age: 52
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I only had one adapter in my trico neoforms. I called the acura dealer but they don't have the blades...still looking and frustrated. My local dealers service dept sucks there parts dept is just as bad I think.
hook is offline   Reply With Quote
Old 04-17-2012, 2:28 AM   #19
Registered Member
2006 Acura TSX
 
Trader Rating: (0)
Join Date: Aug 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 550, Level: 10
Points: 550, Level: 10 Points: 550, Level: 10 Points: 550, Level: 10
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
Can't get replacement wipers

Hi all: Here's the deal. I have a 2006 TSX. Need a set of wipers. I go to auto parts dealer and buy a set of Rain x 16 and . Due to the offset on the passenger side the listed 16 is too long while the 15 would be way too short. It's due to an offset. There is no attachment that comes with the blades to account for this. Is the only thing I can use OEM blades? Any help anyone can provide is greatly appreciated. I can't believe everyone hasn't run into this problem due to this offset. I see folks below bending blades and cutting them but I'm not sure that an answer and other folks using certain brands but without the offset it will always leave a space on your windshield unwiped. Thoughts?
Joeya527 is offline   Reply With Quote
Old 04-17-2012, 4:28 AM   #20
Old Guy
1985 Ferrari 308
My Garage
 
Simba91102's Avatar
 
Trader Rating: (0)
Join Date: Apr 2007
Posts: 2,737
Thanks: 0
Thanked 145 Times in 126 Posts
Points: 9,383, Level: 65
Points: 9,383, Level: 65 Points: 9,383, Level: 65 Points: 9,383, Level: 65
Activity: 2.0%
Activity: 2.0% Activity: 2.0% Activity: 2.0%
Quote:
Originally Posted by Joeya527 View Post
Hi all: Here's the deal. I have a 2006 TSX. Need a set of wipers. I go to auto parts dealer and buy a set of Rain x 16 and . Due to the offset on the passenger side the listed 16 is too long while the 15 would be way too short. It's due to an offset. There is no attachment that comes with the blades to account for this. Is the only thing I can use OEM blades? Any help anyone can provide is greatly appreciated. I can't believe everyone hasn't run into this problem due to this offset. I see folks below bending blades and cutting them but I'm not sure that an answer and other folks using certain brands but without the offset it will always leave a space on your windshield unwiped. Thoughts?
I have used Bosch Icon blades for a few years with no problem (on my wife's 07), and that's using the standard sizes (26" and 16"). There has been quite a bit of chatter here about this issue over the last (over) 6 years and a search may also shed some light. I think it's actually the wiper arm itself that changed (on the 06-08 models). I also have an 05 TSX and have found that blades that work well on the 05 don't particularly on the 07 and vice versa. Of course there's always the old standby of using OE replacement parts.
Simba91102 is offline   Reply With Quote
Old 05-07-2012, 8:21 PM   #21
New Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 34, Level: 1
Points: 34, Level: 1 Points: 34, Level: 1 Points: 34, Level: 1
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
i had the same problems with rain-x brand wiper blades. sucks because they worked great on my wifes rsx.
pmcgavis is offline   Reply With Quote
Old 05-07-2012, 8:21 PM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
03, 12, 2006, acura, adjust, arm, blade, blades, center, inch, passenger, replace, shorter, side, tsx, wiper

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup