P2254 CEL Code on 2004 TL - AcuraZine Community

Go Back   AcuraZine Community > AcuraZine TL Community > Third Generation TL (2004-2008) > Problems & Fixes
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 02-10-2012, 10:00 PM   #1
Registered Member
 
JBSTRD's Avatar
 
Trader Rating: (0)
Join Date: Mar 2008
Location: SW Washington
Age: 33
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 4,683, Level: 43
Points: 4,683, Level: 43 Points: 4,683, Level: 43 Points: 4,683, Level: 43
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
P2254 CEL Code on 2004 TL

I recently popped a P2254 code upon startup yesterday. My car has shown no signs of any apparent issues. The code reads: Negative current circuit/open Bank 2 Sensor 1.

I cleared the code and have driven about 20 miles. The code has not appeared again. I have searched, but I have not found much info on this particular code. I found a write-up on the P2251, which is the same issue only for Bank 1 Sensor 1.

I am wondering if anybody knows if this typically means the o2 sensor needs replaced. If the light stays off should I still replace the sensor? The best I can tell, Bank 2 Sensor 1 is located on the exhaust manifold just behind the radiator. Is this correct? Also, is the correct part number for this sensor 36531-RDM-A01?

Thanks in advance, Jason
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
__________________
2004 TL- NBP, Navi, 6MT, Type-S Wheels, A-Spec Lip Kit

Last edited by JBSTRD; 02-10-2012 at 10:08 PM.
JBSTRD is offline   Reply With Quote
Old 02-11-2012, 5:56 AM   #2
Registered Member
 
Trader Rating: (1)
Join Date: Apr 2007
Location: NJ
Age: 50
Posts: 6,220
Thanked 425 Times in 362 Posts
Points: 13,662, Level: 76
Points: 13,662, Level: 76 Points: 13,662, Level: 76 Points: 13,662, Level: 76
Activity: 11.7%
Activity: 11.7% Activity: 11.7% Activity: 11.7%
There are many tests that can be performed, but most need to be done with the Honda/Acura test equipment, but yes, that is the problem child and the correct sensor number. There are electrical values and continuity checks that can be made, but probably the easiest, although not the least expensive, is to just replace the sensor and give it a try.
Turbonut is offline   Reply With Quote
Old 02-11-2012, 9:14 AM   #3
Registered Member
 
JBSTRD's Avatar
 
Trader Rating: (0)
Join Date: Mar 2008
Location: SW Washington
Age: 33
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 4,683, Level: 43
Points: 4,683, Level: 43 Points: 4,683, Level: 43 Points: 4,683, Level: 43
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Quote:
Originally Posted by Turbonut View Post
There are many tests that can be performed, but most need to be done with the Honda/Acura test equipment, but yes, that is the problem child and the correct sensor number. There are electrical values and continuity checks that can be made, but probably the easiest, although not the least expensive, is to just replace the sensor and give it a try.
Thanks for the reply. My plan is to monitor it and see if the CEL returns. If so, I will just suck it up and drop the $130 on a new A/F Sensor.
__________________
2004 TL- NBP, Navi, 6MT, Type-S Wheels, A-Spec Lip Kit
JBSTRD is offline   Reply With Quote
Old 02-17-2012, 8:08 PM   #4
Registered Member
 
JBSTRD's Avatar
 
Trader Rating: (0)
Join Date: Mar 2008
Location: SW Washington
Age: 33
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Threadstarter
Points: 4,683, Level: 43
Points: 4,683, Level: 43 Points: 4,683, Level: 43 Points: 4,683, Level: 43
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Just a quick update since I hate when I am searching and find good info, but people do not talk about their resolution.

Anyways, the CEL came back on after about 4 days. Went and checked the code and it was another P2254. I guess that is a good thing, huh? I ordered the proper sensor for Bank 2, Sensor 1 (Part #36531-RDM-A01) from OEMAcuaraParts.com. Should be here tomorrow. I will let you know if the CEL comes back on after the install.

***fingers crossed***
__________________
2004 TL- NBP, Navi, 6MT, Type-S Wheels, A-Spec Lip Kit
JBSTRD is offline   Reply With Quote
Old 12-25-2012, 9:35 AM   #5
New Member
 
Trader Rating: (0)
Join Date: Oct 2009
Age: 44
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 2,649, Level: 31
Points: 2,649, Level: 31 Points: 2,649, Level: 31 Points: 2,649, Level: 31
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Did it work?
trileftwing is offline   Reply With Quote
Old 12-25-2012, 9:35 AM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
2004, 36531rdma01, acura, acure, b2s1, back, bank, cel, code, codes, honda, installing, p2251, p2254, test, tl, troule

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 7:38 AM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup