HID headlights - Bad Inverter - AcuraZine Community

Log In 


HID headlights - Bad Inverter

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-15-2008, 03:12 PM   #1
Registered Member
Thread Starter
 
Join Date: Sep 2008
Age: 50
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question HID headlights - Bad Inverter

I'm new to this forum and have read several post about the HID headlight systems. My passenger side low beam is operating intermittently. I took it to the Dealer who informed me the inverter was bad and wanted $750 to fix. My question is this.. How hard are they to replace? Due to the high voltage, are there any precautions I need to take or be aware of if I decide to buy the part and attempt to replace myself?

Thanks
rmcgee211 is offline   Reply With Quote
Old 09-15-2008, 10:26 PM   #2
wham bam thank you ma'am
iTrader: (8)
 
Rajca's Avatar
 
Join Date: Dec 2006
Location: Illinois
Age: 26
Posts: 11,406
Thanked 35 Times in 31 Posts
did u try swapping the bulbs to make sure that its not just the bulbs or ignitor/ ballast
Rajca is offline   Reply With Quote
Old 09-15-2008, 11:19 PM   #3
03 ABP tls
iTrader: (3)
 
slavver01's Avatar
 
Join Date: Apr 2007
Location: western ma
Age: 28
Posts: 710
Thanks: 0
Thanked 0 Times in 0 Posts
sounds like a bad connection, but just to be safe, you culd try switching out the bulbs. i had the same problem on my 99 tl tho, light went on and off then finally just dies. ended up being a bad ballast/inverter.

search ebay or post a WTB ad in the black market for an inverter for your car and hopefully you'll find a used one for cheap. or new ones, i think they go for like $200+. to switch is real easy tho, search the forum for the DIY on taking off front bumper, and theres also one for switching ballast i think. just use common sense when switching it, dont have any water next to ya, etc.

i believe its best recommended to not have turned on your lights for at least a few hours. so maybe do it one morning like i did. good luck, and use the SEARCH button
slavver01 is offline   Reply With Quote
Old 09-16-2008, 04:41 AM   #4
wham bam thank you ma'am
iTrader: (8)
 
Rajca's Avatar
 
Join Date: Dec 2006
Location: Illinois
Age: 26
Posts: 11,406
Thanked 35 Times in 31 Posts
i have two ignitors for sale
Rajca is offline   Reply With Quote
Old 09-16-2008, 07:36 AM   #5
Registered Member
 
Join Date: Jul 2003
Location: boston, ma
Age: 41
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
dont buy one from ebay. i just replaced mine this wekeend with one from an acura dealership. go to acuraoemparts.com. i payed lke 178$ for the part and it took me about 15 minutes to do. disconnect the neg on the battery so you dont get zapped. bumper drops down without much problem ( i did however have a tough time lining it back up going in, so give it a good study before you drop it) after that there is a few screws on the headlights to take out, very easy to see. and the ignitor is inside the headlight attached to the top of the ballast. unscrew the ballast and you can just pop off the ignitor. I suggest doing the swap test as suggested. first swap bulbs on both sides and see what you got, then ignitors. If it is not fixed you are left with trying the ballasts.
chrismeoli is offline   Reply With Quote
Old 09-16-2008, 08:00 AM   #6
Registered Member
Thread Starter
 
Join Date: Sep 2008
Age: 50
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Wink

The dealer told me it was the inverter. I have not tried the swapping yet but I will. Is the inverter the same as the ballist, is it the same as the ignitor, or is it a totally separate part. I know some part names are interchangable but since I'm new to HID systems I don't know all the technical terms and parts well enough to know the difference.

Thanks for everyone's patience
rmcgee211 is offline   Reply With Quote
Old 09-16-2008, 08:47 AM   #7
Registered Member
 
Join Date: Jul 2003
Location: boston, ma
Age: 41
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
inverter is same as ignitor. it plugs into the ballast with a little phone jack looking plug, righ ton top of ballast.

if you can pull out your bulb , the ignitor/inverter is the black wire that you take off the bulb, thats it. it plugs into the ballast on the underside of the lamp assambly
chrismeoli is offline   Reply With Quote
Old 09-21-2008, 07:53 PM   #8
Registered Member
 
Join Date: Sep 2007
Posts: 240
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Rajca View Post
i have two ignitors for sale
What price are you looking for them?
spiro is offline   Reply With Quote
Old 09-21-2008, 08:06 PM   #9
wham bam thank you ma'am
iTrader: (8)
 
Rajca's Avatar
 
Join Date: Dec 2006
Location: Illinois
Age: 26
Posts: 11,406
Thanked 35 Times in 31 Posts
$25 for one or $40 for both +shipping on both
Rajca is offline   Reply With Quote
Old 09-22-2008, 09:46 AM   #10
New Member
 
Join Date: Sep 2008
Age: 74
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
cl lowbeams

I'm glad that y'all are finding success doing it yourselves. the alternative to get my low beams working on a 2003 CL was close to $1900 for diagnosis of my headlights not working and the the bulbs that were alledgedly shorted by the inverters and the inverters that were $485 (x2) from the dealer and the bulbs were $140 (x2) from auto supply store
garyrh is offline   Reply With Quote
Old 09-22-2008, 10:33 AM   #11
Registered Member
 
totaledTL's Avatar
 
Join Date: Apr 2008
Location: Louisville, KY
Age: 54
Posts: 2,344
Thanked 33 Times in 29 Posts
OMG that's terrible
totaledTL is offline   Reply With Quote
Old 09-22-2008, 11:06 AM   #12
Registered Member
 
Join Date: Sep 2007
Posts: 240
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Rajca View Post
$25 for one or $40 for both +shipping on both
I will take them for $40.
email me harrydsharma@yahoo.ca. We will work out the paying and shipping details.
I see you have a 2002 ,I take it these igniters are from this car or they will work on this car.
spiro is offline   Reply With Quote
Old 09-28-2008, 01:01 PM   #13
New Member
 
Join Date: Sep 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Bad Inverter?

I have a 2001 TL and just got my passenger side inverter replaced because my headlight kept going out. Now I am having issues with my battery draining. I noticed that every time that I start my car, it keeps getting slower and slower to start and 3 days later since my inverter was replaced, my car now won't start.

I got it jumped, went to Auto Zone who did a diagnostic check on it and the alternater and battery are fine so my question to all of you other TL'ers.....would the new inverter slowly drain my battery? Something they did is causing this because I NEVER had this problem before!

HELP!!
Acura Gurl is offline   Reply With Quote
Old 09-28-2008, 02:34 PM   #14
wham bam thank you ma'am
iTrader: (8)
 
Rajca's Avatar
 
Join Date: Dec 2006
Location: Illinois
Age: 26
Posts: 11,406
Thanked 35 Times in 31 Posts
an inverter wont drain the battery. u could have a light bulb that stays on (trunk, dome, something plugged in the cigarette lighter, door light) could be many different things.
Rajca is offline   Reply With Quote
Old 09-28-2008, 02:59 PM   #15
New Member
 
Join Date: Sep 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks, Rajca! Could it be a coincidence that sense I got this work done to my car, the battery drains? I've done nothing different to my car. You can see that something is running since it arc's when you tap the battery. Anyone have suggestions?
Acura Gurl is offline   Reply With Quote
Old 09-08-2009, 01:39 PM   #16
New Member
 
Join Date: Jul 2006
Posts: 4
Thanked 0 Times in 0 Posts
Anybody else have an inverter/igniter for a 2002 TL Type-S?

My dealer just told me that mine needs to be replaced. They want to charge me $550 for the part. That's just sick.

Thanks in advance!
derning is offline   Reply With Quote
Old 09-08-2009, 02:21 PM   #17
03 TL-S
 
DIRTYSOUTH_TYPE-S's Avatar
 
Join Date: Nov 2006
Location: SWFL
Age: 31
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
You should just get an aftermarket HID kit ($200-$300 +/-) and call it a day
DIRTYSOUTH_TYPE-S is offline   Reply With Quote
Old 02-08-2016, 10:24 AM   #18
Registered Member
 
Join Date: Feb 2016
Age: 36
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Hi,

I noticed that the passenger side low beam headlight is not working on my 2003 3.2 TL.
The dealer did diagnosis and told me to replace the igniter/inverter. He asked me around 800 bucks for this which is completely out of my budget and so couldnt get it done. Today, I noticed that the passenger side light came on all by itself. But when I stopped the car and turned it on it didn't come back. I am not a mechanic but any suggestions on how to get this done fixed would be greatly appreciated.

Thank you,
Shashi
shashim is offline   Reply With Quote
Old 02-08-2016, 10:37 AM   #19
das wascist
 
thoiboi's Avatar
 
Join Date: Apr 2010
Location: SoCal, CA
Posts: 15,502
Thanked 2,477 Times in 2,012 Posts
Www.theretrofitsource.com for an aftermarket kit for 150 bucks. Get the matusuhita female to 9006 male adapter for 20.


Tel the dealer to go eff themselves.
thoiboi is offline   Reply With Quote
Old 03-03-2016, 11:30 AM   #20
Registered Member
 
Join Date: Sep 2006
Age: 56
Posts: 33,612
Thanked 1,088 Times in 1,024 Posts
if you are on a tight budget look at HIDeXtra | HID, LED, Xenon Vehicle Headlight Kits & Bulbs
get the hid `kit`- comes with 2 new ballast, ignitor/invertors and 2 new bulbs, under 70 dollars! with 12 month warranty

You can diy this with the help of several threads we have on here
Because we have HID = it does not need a new relay or wiring harness- we just swap out bad parts for modern ones!!
Get 35 watt ballast, and 5000k color bulbs for close to stock look and function from the bulbs
Higher number is not more power!!
01tl4tl is offline   Reply With Quote
Old 03-08-2016, 04:37 PM   #21
Registered Member
 
murky's Avatar
 
Join Date: Jul 2008
Age: 44
Posts: 97
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by shashim View Post
Hi,

I noticed that the passenger side low beam headlight is not working on my 2003 3.2 TL.
The dealer did diagnosis and told me to replace the igniter/inverter. He asked me around 800 bucks for this which is completely out of my budget and so couldnt get it done. Today, I noticed that the passenger side light came on all by itself. But when I stopped the car and turned it on it didn't come back. I am not a mechanic but any suggestions on how to get this done fixed would be greatly appreciated.

Thank you,
Shashi
You can get a new ballast and igniter, OEM from Ebay for $130. It takes about an hour to swap them out, less if you have new clips for the bumper cover instead of trying to save the old, brittle ones.

I bought them to replace mine, but it turned out my problem was the connector on the car side that plugs into the ballast was loose. There was nothing wrong with my ballast and ignitor, but it wasn't until I went to fully change them that I noticed the problem in my connector.

(in fact, my used, perfectly good ballast and ignitor are currently up for sale on Ebay)

The Ebay parts were the same as originals.

Once I reseated my connector, cheap HID bulbs worked fine.
murky is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS: 2003 Acura CL-S 6MT ABP ★★Location of Vehicle : Edmonton, AB, Canada★★ rp_guy Member Cars for Sale 6 03-30-2016 10:50 PM
Another HID question....'07 Type S MilanoRedDashR 3G TL Problems & Fixes 25 10-08-2015 10:30 AM
Quick question about '07 Type S headlights MilanoRedDashR Third Generation TL (2004-2008) 5 09-27-2015 10:15 PM
Acura TL Headlight h22lude Third Generation TL (2004-2008) 7 09-27-2015 06:22 PM


Tags
02, 2003, 2004, acura, bad, bulb, buy, headlight, hid, igniter, ignitor, intermittently, inverter, replaced, rl, tl, tls

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:39 PM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.