Hfl module on mdx 2007... where is it ? - AcuraZine Community

Go Back   AcuraZine Community > Acura MDX Community > 1G & 2G MDX Discussion (2001-2013)
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 10-26-2011, 6:40 PM   #1
New Member
 
Trader Rating: (0)
Join Date: Oct 2011
Age: 49
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 10, Level: 1
Points: 10, Level: 1 Points: 10, Level: 1 Points: 10, Level: 1
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
Hfl module on mdx 2007... where is it ?

I want To disconnect the hfl module because i think it drain the battery.
Where is it?

Thanks
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
fuseemdx is offline   Reply With Quote
Old 10-27-2011, 6:01 AM   #2
3G TL/2G MDX Owner
 
Trader Rating: (1)
Join Date: Oct 2006
Location: The west side of the Potomac River
Posts: 5,202
Thanks: 417
Thanked 915 Times in 758 Posts
PM me
Points: 10,159, Level: 67
Points: 10,159, Level: 67 Points: 10,159, Level: 67 Points: 10,159, Level: 67
Activity: 1.6%
Activity: 1.6% Activity: 1.6% Activity: 1.6%
i believe it is in the overhead console where the sunroof controls are. that's where it is in the TL...the MDX isn't structured that much differently in that dept.

can someone else confirm?
TLtrigirl is offline   Reply With Quote
Old 10-28-2011, 12:31 PM   #3
Registered Member
 
Trader Rating: (2)
Join Date: Oct 2003
Location: Bean Town
Posts: 110
Thanks: 0
Thanked 2 Times in 2 Posts
Points: 8,470, Level: 62
Points: 8,470, Level: 62 Points: 8,470, Level: 62 Points: 8,470, Level: 62
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Quote:
Originally Posted by TLtrigirl View Post
i believe it is in the overhead console where the sunroof controls are. that's where it is in the TL...the MDX isn't structured that much differently in that dept.

can someone else confirm?
No, it's actually between the center armrest and the rear vents. In the picture, it's the module with the white sticker on it.

Click the image to open in full size.
riontegra is offline   Reply With Quote
The Following User Says Thank You to riontegra For This Useful Post:
random2k (01-17-2014)
Old 10-28-2011, 1:36 PM   #4
3G TL/2G MDX Owner
 
Trader Rating: (1)
Join Date: Oct 2006
Location: The west side of the Potomac River
Posts: 5,202
Thanks: 417
Thanked 915 Times in 758 Posts
PM me
Points: 10,159, Level: 67
Points: 10,159, Level: 67 Points: 10,159, Level: 67 Points: 10,159, Level: 67
Activity: 1.6%
Activity: 1.6% Activity: 1.6% Activity: 1.6%
Quote:
Originally Posted by riontegra View Post
No, it's actually between the center armrest and the rear vents. In the picture, it's the module with the white sticker on it.

Click the image to open in full size.
well what do you know?

thanks for correcting.
TLtrigirl is offline   Reply With Quote
Old 10-28-2011, 7:06 PM   #5
Registered Member
 
NBP04TL4ME's Avatar
 
Trader Rating: (0)
Join Date: Oct 2003
Location: SE Mass
Age: 48
Posts: 3,081
Thanks: 165
Thanked 333 Times in 287 Posts
Points: 12,545, Level: 73
Points: 12,545, Level: 73 Points: 12,545, Level: 73 Points: 12,545, Level: 73
Activity: 49.8%
Activity: 49.8% Activity: 49.8% Activity: 49.8%
Would never have guessed that it is in the center console and in the back of it as well. You can see the Bluetooth symbol on the label.
__________________
2008 TL Type S NBP/Ebony 6 Speed (His) - 8.5" Gun Metal A-Specs - Escort 8500 X50
2007 Lexus ES350 (Hers)
2009 Honda Accord EX-L (Kids)
2007 Acura MDX Tech/Ent Nimbus Grey/Ebony (Traded)
2004 Acura TL NBP/Quartz 6 Speed with Nav (Traded)
NBP04TL4ME is offline   Reply With Quote
Old 07-11-2012, 4:16 PM   #6
New Member
 
Trader Rating: (0)
Join Date: Jul 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 10, Level: 1
Points: 10, Level: 1 Points: 10, Level: 1 Points: 10, Level: 1
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%
Any issues or suggestions for removing the module once you have the access?
christoper0077 is offline   Reply With Quote
Old 01-09-2013, 5:44 PM   #7
Registered Member
 
Decayin's Avatar
 
Trader Rating: (0)
Join Date: Sep 2011
Location: Glendale, AZ
Age: 21
Posts: 141
Thanks: 15
Thanked 26 Times in 22 Posts
Points: 2,165, Level: 28
Points: 2,165, Level: 28 Points: 2,165, Level: 28 Points: 2,165, Level: 28
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
sorry to revive thread, but how to I open up the console?
My Mom's MDX keeps dying and I am sure the HFL is the culprit.
My TL's battery has also been dying, I just disconnected the HFL
and am charging the battery as I type.
__________________
Decayin is offline   Reply With Quote
Old 02-03-2013, 8:01 PM   #8
New Member
 
Trader Rating: (0)
Join Date: May 2011
Age: 42
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,243, Level: 19
Points: 1,243, Level: 19 Points: 1,243, Level: 19 Points: 1,243, Level: 19
Activity: 0.2%
Activity: 0.2% Activity: 0.2% Activity: 0.2%
My battery was dying randomly and I couldn't understand why, I would have never have guessed it had to do with my HFL, is there no other alternative to fixing the HFL besides changing the module?
frankv27 is offline   Reply With Quote
Old 02-03-2013, 8:54 PM   #9
Registered Member
 
NBP04TL4ME's Avatar
 
Trader Rating: (0)
Join Date: Oct 2003
Location: SE Mass
Age: 48
Posts: 3,081
Thanks: 165
Thanked 333 Times in 287 Posts
Points: 12,545, Level: 73
Points: 12,545, Level: 73 Points: 12,545, Level: 73 Points: 12,545, Level: 73
Activity: 49.8%
Activity: 49.8% Activity: 49.8% Activity: 49.8%
Quote:
Originally Posted by frankv27 View Post
My battery was dying randomly and I couldn't understand why, I would have never have guessed it had to do with my HFL, is there no other alternative to fixing the HFL besides changing the module?
Owners of the 3G TL who have had a similar problem have simply disconnected the HFL unit. Obviously you loose the functionality, but some didn't care. I'm guessing you are out of warranty?? You may want to talk with your local dealer and see if there is any good will possible or if they might consider sharing the repair cost. Just a thought.
__________________
2008 TL Type S NBP/Ebony 6 Speed (His) - 8.5" Gun Metal A-Specs - Escort 8500 X50
2007 Lexus ES350 (Hers)
2009 Honda Accord EX-L (Kids)
2007 Acura MDX Tech/Ent Nimbus Grey/Ebony (Traded)
2004 Acura TL NBP/Quartz 6 Speed with Nav (Traded)
NBP04TL4ME is offline   Reply With Quote
Old 02-24-2013, 11:26 AM   #10
Electrical expert
 
yungone501's Avatar
 
Trader Rating: (4)
Join Date: Aug 2011
Location: Texas
Posts: 1,770
Thanks: 36
Thanked 436 Times in 334 Posts
Points: 8,294, Level: 61
Points: 8,294, Level: 61 Points: 8,294, Level: 61 Points: 8,294, Level: 61
Activity: 9.9%
Activity: 9.9% Activity: 9.9% Activity: 9.9%
Funny that I see this thread now.

Within the past two weeks, I've had two 06 TLs come in at the shop both with battery drains. If you sat in the car with all doors closed, windows up, car off and completely silent...if you listened very closely, you could hear a faint tick noise every 20-30 seconds or so. Btw, I only realized this after laying beneath the drivers dash trying to locate a circuit with an amperage reading above normal. Anyways, after further investigating I found that the sound was actually coming from the instrument cluster. Removing the cluster from its mounts and still plugged in, I hooked up a amperage meter and confirmed it was indeed the source of the drain.

One TL had 6x,xxx miles and the other 116,xxx. This is obviously a common occurance however, I've been doing automotive electrical work for a long time and is the first I've ever seen of it.

I'd recommend listening for the tick sound and seeing if perhaps the cluster is the culprit. Good luck.

I just realized I posted this in the MDX section, had two windows open and thought it was the TL section LOL

I ALWAYS see MDXs in for bad AC compressor relays causing battery drains. They get stuck closed, with ignition off it drains the battery. Simply replacing the relay fixes the issue.
__________________
***Electrical Specialist***
Auto Electric Services in Plano, Tx - Owner


Forums first turbo hybrid 2.8 build-
http://cl.acurazine.com/forums/showthread.php?t=873314

Last edited by yungone501; 02-24-2013 at 11:31 AM.
yungone501 is offline   Reply With Quote
Old 11-23-2013, 3:20 PM   #11
Registered Member
 
Trader Rating: (0)
Join Date: Nov 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,494, Level: 21
Points: 1,494, Level: 21 Points: 1,494, Level: 21 Points: 1,494, Level: 21
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
my new HFL just arrived today. any tips on how to remove the rear climate control / back of the center console?
is it just held in with clips or are there any screws?

Quote:
Originally Posted by riontegra View Post
No, it's actually between the center armrest and the rear vents. In the picture, it's the module with the white sticker on it.

Click the image to open in full size.
fritzner is offline   Reply With Quote
Old 11-25-2013, 12:26 PM   #12
Registered Member
 
Trader Rating: (0)
Join Date: Nov 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 1,494, Level: 21
Points: 1,494, Level: 21 Points: 1,494, Level: 21 Points: 1,494, Level: 21
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%
for the record, the rear of the center console is held with clips only. it is a little scary, but it pops right off.

the new HFL (~$200) was very easy to install and everything is up and working again. the X had a slow battery drain which i hope is remedied by the new module as well.

Quote:
Originally Posted by fritzner View Post
my new HFL just arrived today. any tips on how to remove the rear climate control / back of the center console?
is it just held in with clips or are there any screws?
fritzner is offline   Reply With Quote
Old 01-17-2014, 2:03 PM   #13
New Member
 
Trader Rating: (0)
Join Date: Jan 2014
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
Points: 10, Level: 1
Points: 10, Level: 1 Points: 10, Level: 1 Points: 10, Level: 1
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
Instructions for the Do It Yourself people out there:

You can find the repair diagrams for accessing the HFL / HFT on your MDX at http://ww2.justanswer.com/uploads/ac...42_binder1.pdf

Make sure you remove your floor mat so the cover can slide out easily.

The instructions refer to using the Acura Trim Kit tool. Instead of using the Acura tool, I used an alternative that I found on Amazon: http://www.amazon.com/gp/product/B0017HX5DE/ref=oh_details_o00_s00_i00?ie=UTF8&psc=1

I found the wide trim remover to be the best one for releasing the console clips without scratching the trim.

The job is very easy to to. My dealer wanted to charge me almost $500 to replace this unit. I am very happy that I was able to find the part online for less than $200 (with shipping). The total time spent for this repair should be less than an hour for the average person. Possibly 15 minutes if you are really efficient.
random2k is offline   Reply With Quote
Old 05-05-2014, 6:43 PM   #14
New Member
 
Trader Rating: (0)
Join Date: May 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 185, Level: 3
Points: 185, Level: 3 Points: 185, Level: 3 Points: 185, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Hello people, I am new to this. I own 2007 mdx-- having same problem not starting--checked for parasitic draw--mixed readings with my meter do any one know what kind od min reading I should be looking for. Disconnecting HFL gave me the same reading as connecting. My battery is volting 10.5 Vts....Thanks
Himag is offline   Reply With Quote
Old 05-05-2014, 8:14 PM   #15
Registered Member
 
Trader Rating: (2)
Join Date: Oct 2003
Location: Bean Town
Posts: 110
Thanks: 0
Thanked 2 Times in 2 Posts
Points: 8,470, Level: 62
Points: 8,470, Level: 62 Points: 8,470, Level: 62 Points: 8,470, Level: 62
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Voltage doesn't measure draw. What you need to measure is the current and current can only be measured with a C-clamp.

Regardless, 10.5 Volts is low. Is this with the car not running? Not running should be around 12 volts and running it should measure around 14 volts.

Is it the original battery from 2007? Your voltage seems low and you probably need a new battery. Most batteries last 6-8 years so you're probably due for battery replacement.

Last edited by riontegra; 05-05-2014 at 8:17 PM.
riontegra is offline   Reply With Quote
Old 05-10-2014, 9:02 PM   #16
New Member
 
Trader Rating: (0)
Join Date: May 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 185, Level: 3
Points: 185, Level: 3 Points: 185, Level: 3 Points: 185, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Thanks riontegra, You were right My battery is gone One bad cell. every thing is ok. The Battery was 1 yr old still under warranty. That's why I was not thinking about it to be at fault.
Himag is offline   Reply With Quote
Old 05-10-2014, 9:04 PM   #17
New Member
 
Trader Rating: (0)
Join Date: May 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 185, Level: 3
Points: 185, Level: 3 Points: 185, Level: 3 Points: 185, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
Anybody have any idea of a nice sporty grill design ?
Himag is offline   Reply With Quote
Old 06-19-2014, 9:01 PM   #18
New Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
Points: 17, Level: 1
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Activity: 1.8%
Activity: 1.8% Activity: 1.8% Activity: 1.8%
Smile Awesome, Now I know where to find it, Now to remove and replace.

Quote:
Originally Posted by TLtrigirl View Post
well what do you know?

thanks for correcting.

Awesome, Now I know where to find it, Now to remove and replace.
Faces387 is offline   Reply With Quote
Old 06-19-2014, 9:01 PM   #19
New Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
Points: 17, Level: 1
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Activity: 1.8%
Activity: 1.8% Activity: 1.8% Activity: 1.8%
I like this forum
Faces387 is offline   Reply With Quote
Old 06-20-2014, 6:24 PM   #20
New Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
Points: 17, Level: 1
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Activity: 1.8%
Activity: 1.8% Activity: 1.8% Activity: 1.8%
Pairing Instructions

Quote:
Originally Posted by random2k View Post
Instructions for the Do It Yourself people out there:

You can find the repair diagrams for accessing the HFL / HFT on your MDX at http://ww2.justanswer.com/uploads/ac...42_binder1.pdf

Make sure you remove your floor mat so the cover can slide out easily.

The instructions refer to using the Acura Trim Kit tool. Instead of using the Acura tool, I used an alternative that I found on Amazon: http://www.amazon.com/gp/product/B00...?ie=UTF8&psc=1

I found the wide trim remover to be the best one for releasing the console clips without scratching the trim.

The job is very easy to to. My dealer wanted to charge me almost $500 to replace this unit. I am very happy that I was able to find the part online for less than $200 (with shipping). The total time spent for this repair should be less than an hour for the average person. Possibly 15 minutes if you are really efficient.
okay, today 06/20/2014 I removed the old module and installed the new HFL unit. But now every time I try to operate the HFL it gives me the options such as phone set up , pair, transfer et... but when I tell it phone set up or pair or anything . The Hfl repeats the options or doesn't do anything. What can I do to resolve this problem? ANY helpful Ideas.
Faces387 is offline   Reply With Quote
Old 06-20-2014, 10:37 PM   #21
New Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 21, Level: 1
Points: 21, Level: 1 Points: 21, Level: 1 Points: 21, Level: 1
Activity: 0.5%
Activity: 0.5% Activity: 0.5% Activity: 0.5%
Where is the HFL module located in a 2009 MDX?
JohnS1 is offline   Reply With Quote
Old 06-24-2014, 11:24 PM   #22
Registered Member
 
Trader Rating: (0)
Join Date: Jun 2014
Location: North East
Posts: 53
Thanks: 0
Thanked 10 Times in 8 Posts
Points: 305, Level: 6
Points: 305, Level: 6 Points: 305, Level: 6 Points: 305, Level: 6
Activity: 2.6%
Activity: 2.6% Activity: 2.6% Activity: 2.6%
For 2009 MDX its in the same place as pictured above.

Rear console, it pulls right off held by clips.

Try disconnecting the new HFL unit and try again and make sure your phone is compatible to your car. Go to Handsfreelink.com to check.

When replacing to new HFL units for some reason from my experience it likes to be happy when a phone is paired to it or else it may keep draining your battery.

Hope that helps.
ECRD is offline   Reply With Quote
Old 06-25-2014, 10:35 AM   #23
Registered Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Points: 57, Level: 1
Points: 57, Level: 1 Points: 57, Level: 1 Points: 57, Level: 1
Activity: 3.0%
Activity: 3.0% Activity: 3.0% Activity: 3.0%
Does anybody know if I get a new HFL module it will be able to see my Galaxy S3?

I have a 2008 MDX and it won't see pair with (or even see) my phone. I've read elsewhere that my model phone has problems with the 2008.

But a new module should fix that, one could only hope.

Anybody know about this?

thanks!
Buford is offline   Reply With Quote
Old 06-25-2014, 12:46 PM   #24
Registered Member
 
NBP04TL4ME's Avatar
 
Trader Rating: (0)
Join Date: Oct 2003
Location: SE Mass
Age: 48
Posts: 3,081
Thanks: 165
Thanked 333 Times in 287 Posts
Points: 12,545, Level: 73
Points: 12,545, Level: 73 Points: 12,545, Level: 73 Points: 12,545, Level: 73
Activity: 49.8%
Activity: 49.8% Activity: 49.8% Activity: 49.8%
You can use the following link to help find out if your phone is compatible -

http://www.acura.com/handsfreelink.aspx
__________________
2008 TL Type S NBP/Ebony 6 Speed (His) - 8.5" Gun Metal A-Specs - Escort 8500 X50
2007 Lexus ES350 (Hers)
2009 Honda Accord EX-L (Kids)
2007 Acura MDX Tech/Ent Nimbus Grey/Ebony (Traded)
2004 Acura TL NBP/Quartz 6 Speed with Nav (Traded)
NBP04TL4ME is offline   Reply With Quote
Old 06-25-2014, 8:49 PM   #25
Registered Member
 
Trader Rating: (0)
Join Date: Jun 2010
Location: willowbrook,il
Posts: 233
Thanks: 1
Thanked 19 Times in 14 Posts
Points: 3,755, Level: 38
Points: 3,755, Level: 38 Points: 3,755, Level: 38 Points: 3,755, Level: 38
Activity: 4.2%
Activity: 4.2% Activity: 4.2% Activity: 4.2%
Quote:
Originally Posted by Buford View Post
Does anybody know if I get a new HFL module it will be able to see my Galaxy S3?

I have a 2008 MDX and it won't see pair with (or even see) my phone. I've read elsewhere that my model phone has problems with the 2008.

But a new module should fix that, one could only hope.

Anybody know about this?

thanks!
I have 2012 mdx and mine works with galaxy3...
__________________
Current:
2012 Acura MDX Tech.
Mods-Advance running boards, roof rack, tint all over, K&N filter, RV6 J-pipe, HFPC, Xenon reverse lights and fog lights, Alpine amp and 8' sub, some LED'S...
Sold:2007 Acura TL Type-s,2002 Acura RL,1992 Acura Legend
dzionny_dzionassi is offline   Reply With Quote
Old 07-02-2014, 4:05 PM   #26
New Member
 
Trader Rating: (0)
Join Date: Jun 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Points: 51, Level: 1
Points: 51, Level: 1 Points: 51, Level: 1 Points: 51, Level: 1
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%
on the 2007 acura tl the hfl unit is above the rear view mirror and above the cabin lights I just replaced my unit
Don D is offline   Reply With Quote
Old 07-02-2014, 4:05 PM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
2005, 2007, 2008, 2009, acura, hfl, ipod, mdx, module, rl, s4859066049387788888888889567765432888492, spec, tl, turn, usa

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 3:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup